Sn0wBreeze Windows jailbreak updated to 2.8b6 to officially support iOS 5 beta 6

sn0wbreeze jailbreak

Sn0wBreeze for Windows users has now officially been updated to support iOS 5 beta 6 users. We reported the old version of Sn0wBreeze already working for some users, yet others had complications. But the tool has now been updated to officially support beta 6.

Yes the jailbreak is still tethered (with the exception of old bootrom iPhone 3GS users). This version of Sn0wBreeze not only lets you jailbreak iOS 5 beta 6, it will also allow you to skip the UDID check. This basically means you can install the beta without having a developer's license. (We don't condone this but to each their own.) Sn0wBreeze will also preserve your baseband like before and allow "hacktivation". The following devices are supported -

  • Original iPad
  • iPhone 3GS (if you had the older bootrom it will also be untethered)
  • iPhone 4 (GSM)
  • iPhone 4 (CDMA)
  • iPod Touch 3G
  • iPod Touch 4

Keep in mind that not only is iOS 5 still in beta but that these jailbreaks are also beta. So if you're not afraid of some bugs and are already aware of the risks involved, simply hit the link below to download the updated version of Sn0wBreeze.

[Sn0wBreeze 2.8b6 download link]

Allyson Kazmucha

Help and how to editor for iMore. I can take apart an iPhone in less than 6 minutes. I also like coffee and Harry Potter more than anyone really should.

More Posts

 

1
loading...
0
loading...
0
loading...
0
loading...

← Previously

How to switch from webOS to iPhone and iPad

Next up →

Keep golf scores with Birdies for iPhone

There are 4 comments. Add yours.

Jellis1414 says:

I am running IOS5 beta 6 with develper lice. When I run SnowBreeze - and then grab the IOS5beta6 upload and drag it to the load spot - Snowbreeze checks it, and then says the file is Invalid??
This is the one right from Apple? I dont understand? Should I use a different one? Any suggestions would be greatly appreciated. Thanks.

Wayne Williams says:

What's the latest on Ultrasnow on iOS 5, anyone know? My 3GS is jailbroken and unlocked but I'm still using it on ATT. I'd love to upgrade to iOS5 when it comes out.

Iphonemanstan says:

People Wonder Why Apple Ends Up Being One Step Ahead When They Release A Final Version Of Their Software Because They Developers For Jailbreak "Announce" To Apple Thru Sites Like This That They Have Found A Way To Jailbreak Their Latest Software, So Apple Again Comes Out With A Update That Blocks It & So Forth. Would It Be So Hard To Keep The Latest Jailbreak "A Secret" Until Apple Releases The Final Version For Once So THE WORLD could jailbreak On The Latest Release For Once? #JustAThought. ;-)

Temp says:

The jailbreak works via a hardware exploit, hence this cannot be fixed by Apple and explains why iPad 2 is not vulnerable.