The Dev Team have updated their blog to let the jailbreakers of the world know how to go about jailbreaking iPhone 3.1. It seems as if Apple has really thrown a monkey wrench into jailbreaking the 3.1 software, however, so sit tight as this may be a bit confusing...

First and foremost they have released the PwnageTool 3.1 for Mac OS X that should only be used with the original iPhone and iPhone 3G. Sorry 3GS owners, you'll have to wait. Be sure to heed some of the Dev Teams warnings before attempting to jailbreak your device.

  • If you are using a 3G iPhone with ultrasn0w and rely on ultrasn0w to obtain cellular service, then you should only upgrade to 3.1 with a PwnageTool created .ipsw. - Stay away from Appleā€™s direct updates.
  • If you have an original iPhone (1st generation) then 3.1 unlock works with this PwnageTool release. iPhone 3G users upgrading to 3.1 will need to continue using ultrasn0w with a PwnageTool created 3.1 .ipsw
  • PwnageTool WILL work for Original iPhone (1st Generation), Original iPod touch (1st Generation) and the iPhone 3G.

For the full rundown please visit the Dev Teams blog and make sure you fully understand what you are getting yourself into before attempting to jailbreak iPhone 3.1.

If you don't understand it, don't do it, and TiPb takes no responsibility for the outcome either way. Need more? Check out TiPb