Plants vs. Zombies 2 now available in the U.S. - Go get it!

Plants vs. Zombies 2, the sequel to Popcap's smash-hit original, is now available in the U.S. and other international App Stores. Previously Australia and New Zealand only, Georgia's already posted her Plants vs. Zombies 2 preview and she'll be back soon with her ultimate PvZ2 tips, hints, and cheat guide.

Meanwhile, download, play, and tell me what you think!

Thanks: CG

Have something to say about this story? Share your comments below! Need help with something else? Submit your question!

Rene Ritchie

Editor-in-Chief of iMore, co-host of Iterate, Debug, Review, Vector, and MacBreak Weekly podcasts. Cook, grappler, photon wrangler. Follow him on Twitter and Google+.

More Posts

 

6
loading...
0
loading...
82
loading...
0
loading...

← Previously

iOS 7 design language comes to Mac and Windows... via iCloud web makeover

Next up →

MacBreak Weekly 363: The iPhone Outie

Reader comments

Plants vs. Zombies 2 now available in the U.S. - Go get it!

6 Comments

I'm glad to see Georgia bak on the site. I'm not big oven freemium games, I'd rather pay $5 to $10 for the game like the first one and just own it outright. That being said I will still try it out.

Being in Australia, I've had this for a few weeks. Objectively it's mostly PvZ, with a few quite nifty additions to gameplay, but a very reduced selection of plants. However, the freemium aspect of this game is almost detestable. "You need 15 stars to advance to the next world. Go back and grind a few levels again to get them, or... You know, you could buy them right now and save yourself the trouble." "You need 5 keys to unlock this section of the map. Go back and grind a few levels to collect them, or... If you like, we can sell them to you straight away."

This game has EA written all over it. I loved the first PvZ, bought it three times, but I won't be spending a cent on the second incarnation.

Just installed on my Mini. Went to play, and there is no sound. Music is set high, no it is not on mute, just no sound. Anyone else experience this?