The iPhone Dev-Team has gone ahead and updated UltraSn0w as planned with full support for unlocking your iPhone 3G, 3GS and iPhone 4 under iOS 5.

UltraSn0w 1.2.4 is available in Cydia now and supports iPhone 3G and 3GS basebands 04.26.08, 05.11.07, 05.12.01, 05.13.04, and 06.15.00. Remember, If you're trying to unlock your iPhone 4, the only baseband currently supported by UltraSn0w is 01.59.00.

You'll need to jailbreak your iPhone running iOS 5 before getting started. It's possible to preserve your baseband on the iPhone 4 while still updating to iOS 5 by using the latest version of Redsn0w for Mac (a Windows version is in the works).

Got any questions? Just jump into our jailbreak and unlock forums to help you along the way!

Source: iPhone Dev-Team