<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/terms/" xmlns:foaf="http://xmlns.com/foaf/0.1/" xmlns:og="http://ogp.me/ns#" xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#" xmlns:sioc="http://rdfs.org/sioc/ns#" xmlns:sioct="http://rdfs.org/sioc/types#" xmlns:skos="http://www.w3.org/2004/02/skos/core#" xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
<head profile="http://www.w3.org/1999/xhtml/vocab">
<!--[if IE]><![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="x-dns-prefetch-control" content="on" />
<link rel="dns-prefetch" href="//www.imore.com" />
<!--[if IE 9]>
<link rel="prefetch" href="//www.imore.com" />
<![endif]-->
<script>
    var isChromium = window.chrome,
    winNav = window.navigator,
    vendorName = winNav.vendor,
    isOpera = winNav.userAgent.indexOf("OPR") > -1,
    isIEedge = winNav.userAgent.indexOf("Edge") > -1,
    isIOSChrome = winNav.userAgent.match("CriOS");
    var isChrome = isChromium !== null && isChromium !== undefined && vendorName === "Google Inc." && isOpera == false && isIEedge == false;
    
    if(isChrome) {
      /* observer-6.3.0 */!function t(e,n,o){function r(i,s){if(!n[i]){if(!e[i]){var u="function"==typeof require&&require;if(!s&&u)return u(i,!0);if(a)return a(i,!0);var c=new Error("Cannot find module '"+i+"'");throw c.code="MODULE_NOT_FOUND",c}var d=n[i]={exports:{}};e[i][0].call(d.exports,function(t){var n=e[i][1][t];return r(n?n:t)},d,d.exports,t,e,n,o)}return n[i].exports}for(var a="function"==typeof require&&require,i=0;i<o.length;i++)r(o[i]);return r}({1:[function(t,e,n){function o(t){var e="NEW_SCRIPT_EVENT",n=new r(e,{detail:{}});t.dispatchEvent(n)}const r=t(3);e.exports=o},{3:3}],2:[function(t,e,n){function o(t){t.adonis=t.adonis||{},t.adonis.scriptStatuses={},t.adonis.requestStatuses={};const e=t.XMLHttpRequest,n=function(){const n=new e,o=n.open;return n.open=function(e,a){return n.addEventListener("error",function(e){0===n.status?t.adonis.scriptStatuses[a]="error":t.adonis.scriptStatuses[a]="load"}),n.addEventListener("load",function(e){t.adonis.scriptStatuses[a]="load"}),n.addEventListener("loadend",function(e){t.adonis.requestStatuses[a]=n.status,r(t)}),o.apply(n,arguments)},n};t.XMLHttpRequest=n,e.prototype.constructor=n}const r=t(1);e.exports={wrapXMLHttpRequest:o}},{1:1}],3:[function(t,e,n){(function(t){function n(){try{var t=new o("cat",{detail:{foo:"bar"}});return"cat"===t.type&&"bar"===t.detail.foo}catch(e){}return!1}var o=t.CustomEvent;e.exports=n()?o:"undefined"!=typeof document&&"function"==typeof document.createEvent?function(t,e){var n=document.createEvent("CustomEvent");return e?n.initCustomEvent(t,e.bubbles,e.cancelable,e.detail):n.initCustomEvent(t,!1,!1,void 0),n}:function(t,e){var n=document.createEventObject();return n.type=t,e?(n.bubbles=Boolean(e.bubbles),n.cancelable=Boolean(e.cancelable),n.detail=e.detail):(n.bubbles=!1,n.cancelable=!1,n.detail=void 0),n}}).call(this,"undefined"!=typeof global?global:"undefined"!=typeof self?self:"undefined"!=typeof window?window:{})},{}],4:[function(t,e,n){function o(t,e,n,o){"addEventListener"in t?t.addEventListener(e,n,o):"attachEvent"in t&&t.attachEvent("on"+e,n)}const r=t(2),a=t(1);!function(){window.adonis=window.adonis||{},window.adonis.scriptStatuses={},r.wrapXMLHttpRequest(window),o(document,"load",function(t){t.target&&"SCRIPT"===t.target.nodeName&&(window.adonis.scriptStatuses[t.target.src]="load",a(window))},!0),o(document,"error",function(t){t.target&&"SCRIPT"===t.target.nodeName&&(window.adonis.scriptStatuses[t.target.src]="error",a(window))},!0)}()},{1:1,2:2}]},{},[4]);
    }
    </script><script>
    /* Check for email addresses in fragment...if found, then completely remove it*/
    if(window.location.hash.match(/(.*?)([\w.+-]+(@|%40)[a-z\d.-]+\.[a-z]{2,})([^a-z\d.-].*|$)/i)) {
      window.location.hash = "";
    }
  </script><meta name="msapplication-tooltip" content="iMore" />
<meta property="og:site_name" content="iMore" />
<meta property="article:published_time" content="2017-11-28T16:08:17-05:00" />
<meta property="article:section" content="article" />
<meta property="article:tag" content="News" />
<meta property="article:tag" content="Macs" />
<meta property="article:tag" content="Security" />
<meta property="article:tag" content="macOS high sierra" />
<meta property="article:tag" content="high sierra" />
<link rel="alternate" href="android-app://com.imore.app/https/www.imore.com/macos-has-root-bug" />
<meta name="viewport" content="width=1024" />
<meta name="msapplication-name" content="iMore" />
<meta name="terms" content="News,Macs,Security,macOS high sierra,high sierra" />
<meta property="og:image" content="https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/11/macbook-pro-touch-id-setup.jpg?itok=1PAoa-oX" />
<meta name="msapplication-TileColor" content="#f8d509" />
<meta name="msapplication-square70x70logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/tiny.png" />
<meta name="msapplication-square150x150logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/square.png" />
<meta name="msapplication-wide310x150logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/wide.png" />
<meta name="msapplication-square310x310logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/large.png" />
<meta name="msapplication-notification" content="frequency=30;polling-uri=https://www.imore.com/live-tile/0;polling-uri2=https://www.imore.com/live-tile/1;polling-uri3=https://www.imore.com/live-tile/2;polling-uri4=https://www.imore.com/live-tile/3;polling-uri5=https://www.imore.com/live-tile/4; cycle=1" />
<meta name="theme-color" content="#f8d509" />
<link rel="amphtml" href="https://www.imore.com/macos-has-root-bug?amp" />
<link rel="apple-touch-icon" sizes="57x57" href="https://www.imore.com/sites/imore.com/files/images/icons/apple-touch-57x57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="https://www.imore.com/sites/imore.com/files/images/icons/apple-touch-72x72.png" />
<link rel="apple-touch-icon" sizes="114x114" href="https://www.imore.com/sites/imore.com/files/images/icons/apple-touch-114x114.png" />
<meta name="msapplication-navbutton-color" content="#f8d509" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.imore.com/macos-has-root-bug" />
<link href="//forums.imore.com" rel="dns-prefetch" />
<script type="application/ld+json">
    {
    "@context": "http://schema.org",
    "mainEntityOfPage": "https://www.imore.com/macos-has-root-bug",
    "@type": "NewsArticle",
    "headline": "macOS High Sierra has a critical \u0027root\u0027 security bug \u2014 here\u0027s what you need to do right now",
    "url": "https://www.imore.com/macos-has-root-bug",
    "datePublished": "2017-11-28T21:08:17+0000",
    "dateCreated": "2017-11-28T21:08:17+0000",
    "dateModified": "2017-11-28T21:37:56+0000",
    "author": {
        "@type": "Person",
        "name": "Rene Ritchie"
    },
    "creator": "Rene Ritchie",
    "thumbnailUrl": "https://www.imore.com/sites/imore.com/files/styles/thumbnail/public/field/image/2016/11/macbook-pro-touch-id-setup.jpg?itok=k4qniIQJ",
    "keywords": [
        "macos high sierra",
        "high sierra"
    ],
    "articleSection": "News",
    "image": [
        "https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/11/macbook-pro-touch-id-setup.jpg?itok=1PAoa-oX"
    ],
    "publisher": {
        "@type": "Organization",
        "name": "iMore",
        "logo": {
            "@type": "ImageObject",
            "url": "https://www.imore.com/sites/imore.com/files/im-amp-logo_0.png",
            "width": null,
            "height": null
        }
    }
}
  </script>
<script type="text/javascript">
    var parsely_google = {
    "@context": "http://schema.org",
    "mainEntityOfPage": "https://www.imore.com/macos-has-root-bug",
    "@type": "NewsArticle",
    "headline": "macOS High Sierra has a critical \u0027root\u0027 security bug \u2014 here\u0027s what you need to do right now",
    "url": "https://www.imore.com/macos-has-root-bug",
    "datePublished": "2017-11-28T21:08:17+0000",
    "dateCreated": "2017-11-28T21:08:17+0000",
    "dateModified": "2017-11-28T21:37:56+0000",
    "author": {
        "@type": "Person",
        "name": "Rene Ritchie"
    },
    "creator": "Rene Ritchie",
    "thumbnailUrl": "https://www.imore.com/sites/imore.com/files/styles/thumbnail/public/field/image/2016/11/macbook-pro-touch-id-setup.jpg?itok=k4qniIQJ",
    "keywords": [
        "macos high sierra",
        "high sierra"
    ],
    "articleSection": "News",
    "image": [
        "https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/11/macbook-pro-touch-id-setup.jpg?itok=1PAoa-oX"
    ],
    "publisher": {
        "@type": "Organization",
        "name": "iMore",
        "logo": {
            "@type": "ImageObject",
            "url": "https://www.imore.com/sites/imore.com/files/im-amp-logo_0.png",
            "width": null,
            "height": null
        }
    }
};
  </script><meta name="msvalidate.01" content="21BE5B9D4A670657156555D9E8E78D8D" />
<meta property="fb:pages" content="230016313741478" />

<script>
    !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
    n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
    document,'script','https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1674633419534068');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=1674633419534068&ev=PageView&noscript=1"
    /></noscript>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/mobilenations1-network/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script><link href="//www.windowscentral.com" rel="dns-prefetch" />
<link href="//www.androidcentral.com" rel="dns-prefetch" />
<link href="//crackberry.com" rel="dns-prefetch" />
<link href="//www.imore.com" rel="dns-prefetch" />
<link href="//www.vrheads.com" rel="dns-prefetch" />
<link href="//www.thrifter.com" rel="dns-prefetch" />
<link href="//www.modmy.com" rel="dns-prefetch" />
<link href="//passport.mobilenations.com" rel="dns-prefetch" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@iMore" />
<meta name="twitter:title" content="macOS High Sierra has a critical &#039;root&#039; security bug — here&#039;s what you need to do right now" />
<meta name="twitter:domain" content="https://www.imore.com" />
<meta name="twitter:image" content="https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/11/macbook-pro-touch-id-setup.jpg?itok=1PAoa-oX" />
<meta name="twitter:app:name:googleplay" content="iMore" />
<meta name="twitter:app:id:googleplay" content="com.imore.app" />
<meta name="twitter:app:url:googleplay" content="https://www.imore.com/macos-has-root-bug" />
<meta name="twitter:creator:id" content="10194392" />
<meta name="twitter:description" content="A critical flaw has been discovered in macOS High Sierra that lets an attacker with physical access to your Mac login as &#039;root&#039; simply by leaving the password field blank and trying multiple times in a row. Here&#039;s how to &quot;fix&quot; it right now." />
<meta property="og:title" content="macOS High Sierra has a critical &#039;root&#039; security bug — here&#039;s what you need to do right now" />
<meta property="og:description" content="A critical flaw has been discovered in macOS High Sierra that lets an attacker with physical access to your Mac login as &#039;root&#039; simply by leaving the password field blank and trying multiple times in a row. Here&#039;s how to &quot;fix&quot; it right now." />
<meta name="description" content="A critical flaw has been discovered in macOS High Sierra that lets an attacker with physical access to your Mac login as &#039;root&#039; simply by leaving the password field blank and trying multiple times in a row. Here&#039;s how to &quot;fix&quot; it right now." />
<link rel="image_src" href="https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/11/macbook-pro-touch-id-setup.jpg?itok=1PAoa-oX" />
<link rel="canonical" href="https://www.imore.com/macos-has-root-bug" />
<title>macOS High Sierra has a critical 'root' security bug — here's what you need to do right now | iMore</title>
<link rel="alternate" type="application/rss+xml" title="iMore RSS" href="/rss.xml" />
<link type="text/css" rel="stylesheet" href="https://www.imore.com/sites/imore.com/files/advagg_css/css__CpZOXHV-C7h-_b8i4aMy612anDVzdE3p3ubdU5EdIcs__hDRrm6EdaeDNP7ZKgBD8ldxPp2A6-YobbPNpdgwxknQ__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.css" media="all" />
<style type="text/css" media="all">
/* <![CDATA[ */
.async-hide{opacity:0 !important}

/* ]]> */
</style>
<link type="text/css" rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.1.25/jquery.fancybox.min.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.imore.com/sites/imore.com/files/advagg_css/css__wyYCaKwg7Iq99X-4wpQRf4OhbCPxeXqnYfTsX-un6rw__ZnyvWcKB1b9F_l68KpGgp_eylaVvzV6im_-eXckO5XU__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.imore.com/sites/imore.com/files/advagg_css/css__emDGL7ELG26TbATw8aEDLbN8OgFOe5nAFtOjEDSOdic__CeJ9sPMWeVLOU0T6LJ7s99OsPnPSuB0ZkUTUAQWeyB8__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.css" media="screen" />
<link type="text/css" rel="stylesheet" href="https://www.imore.com/sites/imore.com/files/advagg_css/css__rA4Ese4To_8R8gOaLFg9GoiAytgq5ChcUrmUWsI5qzo__JG2rnozDVhz5vT8axsxJ6uHz3ixMBUW3Umc1XozArX0__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.css" media="all" />
<link rel='stylesheet' type='text/css' href='https://passport.mobilenations.com/cache/css/nationsbar_d_im.css?v41' />
<link rel='stylesheet' type='text/css' href='https://passport.mobilenations.com/js/cluetip/jquery.cluetip.css?v41' />
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__q4ZluDEr7yHOp8TDo4l-cypOrRNOvxyaxrSrBudwQ2E__JILlNGib1Hz87izGwrCoeUVWHEurARtSrto0pJK-26Q__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var vwoArticle = true;
//--><!]]>
</script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__UW4URQsON5h-xjwepC-HoW32RCC10thhh4f0DQ1P8z4__uTWMSc1Zxo2wEdMKHac2qruodQR5Ar_12AqBzSkBhm0__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

    var gptadslots = [];
    var googletag = googletag || {cmd:[]};
    var mapping1 = function(){
      return googletag.sizeMapping()
                .addSize([1350, 0], ['fluid'])
                .addSize([728, 0], ['fluid'])
                .addSize([320, 0], ['fluid'])
                .addSize([0, 0], ['fluid'])
                .build();
    };
    var mapping2 = function(){
      return googletag.sizeMapping()
                .addSize([1350, 0], [[300, 285], [300, 700]])
                .addSize([780, 0], [[300, 285]])
                .addSize([320, 0], [[300, 285], [300, 100]])
                .addSize([0, 0], [])
                .build();
    };
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

    googletag.cmd.push(function() {
      googletag.pubads().enableSingleRequest();
      googletag.pubads().setTargeting('category', ["news","macs","security"])
                              .setTargeting('pageid', ['44675'])
                              .setTargeting('tag', ["macos-high-sierra","high-sierra"]);
      googletag.pubads().collapseEmptyDivs();
      googletag.pubads().setForceSafeFrame(false);
      googletag.enableServices();
    });
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__52ZGpB_C6NP-K_0i-Kq9dylmkXA4U-taF9wS9maDsOI__O87By6wtfrhBGSW-xQsoDsH6ikyxmO6mS1iQFp-VM9Y__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
$ = jQuery;
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var _vwo_code=(function(){
var account_id=315429,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
//--><!]]>
</script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__5yUve_okM3zBhFmJZYPrVDZO2XqcgD1b0CJUZrbqwEk__cbncTTVXfaD9BwwssMA5fenq2V3fUhFjFwWeOvWJrCI__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","//www.google-analytics.com/analytics.js","ga");ga("create", "UA-2017486-7", {"cookieDomain":".imore.com"});ga("set", "dimension1", "full");ga("set", "dimension2", "article");ga("set", "dimension3", "true");ga("set", "dimension4", "C:article,S:standard,B:w400");ga('require', 'linkid');ga("send", "pageview");setTimeout("ga('send','event','NoBounce','Over 20 seconds')",20000);
//--><!]]>
</script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__10A0AxObDNchBBRVwKSJiuBaG2P9sCmUVJWlKofw29U__xIotbIjKJ74YzsOeKVc8bzUJkk0IU-uzSD3JYlc5C40__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js"></script>
<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.1.25/jquery.fancybox.min.js"></script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__TVYqXtaCXvxXnYs-pUdkGoDE2EUXscxjIhbNs1mfung__PtZNebG5xM4aZROmopg39Y7R5z3A270bhIvJLFxshRU__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js"></script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__Ls7xyOQwv3P3pY93ObUOTbwkdG05i2DK4T9rFTLcTVE__WxmVYTuzEq0_BDgfelN-Iy9a67adI0ZnEcEPrat32KI__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js" defer="defer"></script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__ABDGXkk1PZ10uvbB4tKyGf-eNSFdQHX4s09ziuNz6e0__AwG0TzxJvXcjIExG_2TmRyy0JvGv-qlsULLK7oPUSbs__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  targeting = {};
  targeting['stype'] = 'Edito';
  targeting['ctype'] = 'article2015';
  targeting['requestSource'] = 'GPT';

  var terms = $('meta[name=terms]');
  if(terms.length) {
    terms = terms.attr("content");

    var kw = $.map(terms.split(","), function(s) {
      s = s.toLowerCase();
      s = s.replace(/[^0-9a-zA-Z ]/g,"");
      s = s.replace(/ /g,"_");
      s = s.replace(/_+/g,"_");
      s = s.replace(/^_/,"");
      s = s.replace(/_$/,"");
      return s;
    });
    kw.push('im-44675');
    if(kw.length) targeting['kw'] = kw;
  }
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      if (typeof(mbn_config) === 'undefined') var mbn_config = {};
      mbn_config = $.extend(true, mbn_config, {"pp_register":"https:\/\/passport.mobilenations.com\/?u=eNpVkE9LxDAQxb_KkoPoods2tk2dZVlQWPDgRfde0nTaht00JX-oIH53k-jF25sfM-89hkMDXxZKCsTgIA0K13lzI4fAylwnILNzq4U837ZtL5U2uBda5YoLbbOZ28xo7bLeT1wn71RntTcCjyPi0HuzoLmLVAVfrxJNs-Bq5XJajudAYHeZ8XWd9YLPNz3t7uVbCHlI-c3_Tp0a6sgfQ9ehFiNlVdv0NasoE0jboqH9yLFlrRjTXgXESodRhgupogiWXFw4qZc4tNF_ktahSXkFkJeP93N30VcMCz0UfxQ_V2n475mEsg6foayu6OH7BzYdaGU,","pp_login":"https:\/\/passport.mobilenations.com\/?u=eNpVkE9LxDAQxb_KkoPoods2Nm2dZVlQWPDgRfde0nTaht00JX-oIH53k-jF25sfM-89hkMNXxZKCsTgIA0K13lzI4fAylwnILNzq4U837ZtL5U2uBda5YoLbbOZ28xo7bLeT1wn71RntTcCjyPi0HuzoLmLVAVfrxJNs-Bq5XJajudAYHeZ8XWd9YLPNz3t7uVbCHlI-fX_Tp0aWOSPoevAxEibqq171lS0EUjboqb9yLFtWjGmvQqIlQ6jDBdSRREsuXBSL3FgQEKkTLosgLx8vJ-7i75iID0UfxQ_V2n4742EkoW30IZV9PD9A-VcJ2cW","pp_social":{"fb":"https:\/\/passport.mobilenations.com\/?u=eNpVkEtrwzAQhP9K8KG0B8e26lc2hEILgR56aXM3kry2RVwir9EDF0r_e2W1l95mP2Z2luVQw5eFgkFisFcGpeu8uSXHwIoDJJNzi4UsW9d1rzQZ3EvSmeaSbDpxmxpcIpcKPz55pztL3kg8DYi98GZGc7dRHfZ6HWmcJdcLV-N8OgcCu8uEr8tEMz7faNzdq7dQ8hD76_83dbqvNv4Ybu0rObCmbGtRNSVrJLI2r5kYOLZNK4foKyGxyuEmQ0LpTYSVXFw6RXMsCNha6gYuURBdI8shefl4P3cXumJwCcj_KH4uyvDfrIKiCu9hTVWy4_cPUVwiahk,","gp":"https:\/\/passport.mobilenations.com\/?u=eNpVkEtrwzAQhP9K8KG0B8e26lcUQiCFQA-9tLkLSV7LopbX6IELpf-9stseetv9mJ0ZltOafjpaEJpY6LQF6VmwY3KMrDjQZPB-djTLlmXZa4MW9hJNZrhElw7cpRbRp1wiqHPwhjkMVsKpB-hEsBPYu5Wa6BvMRrddcjNzrabTNRK6uw3wPA84wWVEtbvXLzHkYcuv_3dipqtW_hi7dpXsSVO2taiakjQSSJvXRPQc2qaV_aYraeK0h3WMF9qsQ7Tk0muctoA8KhwyhahG-CNPb69XdsN3iBpB818KH7O2_OdS06KKzyFNVZLj1zd0PGla","ms":"https:\/\/passport.mobilenations.com\/?u=eNpVkEtrwzAQhP9K8KG0B8e24lc2hEILgR56aXM3kry2RSOv0QMXSv97ZbWX3nY_ZmeG5VDDl4WCQWKwVwal67y5JafAiiMkk3OLhSxb13WvNBncS9KZ5pJsOnGbGlwilwo_PnqnO0veSDwPiL3wZkZzt1EdfL2ONO6S64WrcT5fAoHddcKXZaIZn2407u7Vawh5iPn1_06d7quNH0LXvpIDa8q2FlVTskZcImvzmomBY9u0coi6EhKrHG5juFB6G4Ill07RHAMOQWGp00oasjS4CHNInt_fLt2VPjDIBOR_FD8XZfjvsYKiCv9hTVWy0_cPzwhqtg,,","tw":"https:\/\/passport.mobilenations.com\/?u=eNpVkE1rwzAMhv9KyWFshzSJl6-qlMEGhR122Xo3jqMkZnUU_EEGY_99jrvLbtLDq1evJKCGbwsFg8RgrwxKx725JsfAigMkk3OLhSxb13WvNBncS9KZFpJsOgmbGlwil3Z-fPJOc0veSDwNiH3nzYzmbqM6-Hodaeyl0ItQ43w6BwK7y4Svy0QzPl9p3N2rt7DkIe6v_2fiuq82_hiy9pUcWFO2dVc1JWsksjavWTcIbJtWDlFXQmKVw60ME0pvRbAU0imabwcGhSXuVuUcmohySF4-3s_8Qp8YRB3kfxS_FmXEbVRBUYXvsKYq2fHnF--0afE,"},"user":{"pdevice":null,"puid":null,"cuid":"","optin":null,"geo":"US","member":"false"},"site":{"site":"im","name":"iMore","cookie_domain":".imore.com","push_host":"https:\/\/push.mobilenations.com","push_manage_host":"https:\/\/www.imore.com","push_manage_page":"\/follow\/","dev":0}});
      
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if(typeof mbn_config === 'undefined') var mbn_config = {};
  mbn_config = $.extend(true, mbn_config, {"style":"full","site_abbr":"im","mobile":false,"domain":"imore.com","subdomain":"*","platform":"d","show_sidebar":true,"node_type":"article","nid":"44675","section":"article","pp_login":"https:\/\/passport.mobilenations.com\/?u=eNpVjssOwiAQRf-FfW0pr3ZcXJr4Aeq-oUAqsYgBmpoY_12obtzdOZl7ZiRweEXALaBgtA1GpWEJM9pHoA2ga0qPCHW9ruvOOh_MTnlXO6l8rK4yVsH7VI3LVPYx_3cMTrPCSXZzI0atBSNY0VaPVNBe874TqqMNkZxs91wwRZtMiblhXQlZKVWy_l4GBmj2k90yzs8dzqfjcPE3k8kIzY-a58MG-e1YwAzjvhWMtvv3B-5cJ0jP","pp_register":"https:\/\/passport.mobilenations.com\/?u=eNpVjssOgjAURP-FPUKhD7gsTfxcMHVP-go0WkvaEkyM_26LbtzNncycuRwovAKgBgqvlfFaxnH192IIgGso5hiXXDBVtW3bwVjn9UE6W1kuXShnHkrvXFwsxTrlPKL_jNEqkv02salmQilGWiRxowRmuFe075jscN1y2u57UAQTdZapYWwWCcllNO6Rjy7zXCcTovb7XvrveDmfxqu76RQQUP9cXP1cXIzn35oBRBDqG0ZwM7w_5DlKHg,,","user":{"pdevice":"","puid":""},"themes":{"full":"\/macos-has-root-bug?utm_source=feedburner\u0026utm_medium=feed\u0026utm_campaign=Feed%3A+TheIphoneBlog+%28iMore%29\u0026style=default","mobile":"\/macos-has-root-bug?utm_source=feedburner\u0026utm_medium=feed\u0026utm_campaign=Feed%3A+TheIphoneBlog+%28iMore%29\u0026style=mobile"}});
  
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

  // Taboola NEWSROOM SCRIPT 
  window._newsroom = window._newsroom || [];  
    !function (e, f, u) {
      e.async = 1;
      e.src = u; f.parentNode.insertBefore(e, f);
    }(document.createElement('script'),document.getElementsByTagName('script')[0], '//c2.taboola.com/nr/mobilenations1-imore/newsroom.js');
    // END NEWSROOM SCRIPT
//--><!]]>
</script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__u6ynLPEoNicHEQFN_ohUtuDnJxNer45ZerXu_HQ0CcI__HobDFW7e3amnjJQ_tVMdajNr4cj_2do-zAdLyV083vE__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
$(function() {
  $.scrollDepth( {
    gtmOverride:true,
    userTiming: false,
    pixelDepth: false
  });
  });
//--><!]]>
</script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__kEscKj8kQAkmRx4D3CM3uBnu_-lInoKfyp_-si7vzHI__4RACSFC4pzg2VCnKmcjEsIgzEz7SH2dpieMocGZQf-0__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"imore2","theme_token":"8B6vEX-Y7bJSPPZ_9UH5bWxD6aJitsQ9I19-M8gv1YA","jquery_version":"1.10","css":{"sites\/all\/themes\/mbn2\/css\/normalize.css":1,"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"sites\/all\/modules\/cache_consistent\/css\/cache_consistent.css":1,"modules\/comment\/comment.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/mollom\/mollom.css":1,"modules\/node\/node.css":1,"sites\/all\/modules\/picture\/picture_wysiwyg.css":1,"modules\/search\/search.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/video_filter\/video_filter.css":1,"sites\/all\/modules\/workflow\/workflow_admin_ui\/workflow_admin_ui.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/panels\/css\/panels.css":1,"sites\/all\/modules\/rate\/rate.css":1,"sites\/all\/modules\/mbn_share\/css\/mbn_share.css":1,"sites\/all\/modules\/visor_region\/css\/visor_region.css":1,"0":1,"https:\/\/cdnjs.cloudflare.com\/ajax\/libs\/fancybox\/3.1.25\/jquery.fancybox.min.css":1,"sites\/all\/modules\/mbn_common\/mbn_common.css":1,"sites\/all\/modules\/mbn_common\/css\/site_footer.css":1,"sites\/all\/libraries\/mediaelementjs\/mediaelementplayer.min.css":1,"sites\/all\/themes\/mbn2_twig\/css\/base-im.css":1,"sites\/all\/modules\/mbn_filter_tokens\/mbn_filter_tokens.css":1,"sites\/all\/modules\/mbn_notify\/follow\/follow.css":1,"sites\/all\/themes\/mbn2_twig\/css\/article-im.css":1,"sites\/all\/modules\/gpt\/gpt.css":1,"sites\/all\/themes\/mbn2_twig\/css\/custom-im.css":1,"sites\/all\/themes\/mbn2\/css\/global.css":1,"sites\/all\/themes\/mbn2\/css\/global-node.css":1,"sites\/imore.com\/themes\/imore2\/css\/legacy.css":1},"js":{"sites\/all\/modules\/picture\/picturefill\/picturefill.min.js":1,"sites\/all\/modules\/picture\/picture.min.js":1,"sites\/all\/modules\/jquery_update\/replace\/jquery\/1.10\/jquery.min.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/jquery_update\/replace\/ui\/external\/jquery.cookie.js":1,"sites\/all\/modules\/jquery_update\/replace\/misc\/jquery.form.min.js":1,"misc\/ajax.js":1,"sites\/all\/modules\/jquery_update\/js\/jquery_update.js":1,"sites\/all\/modules\/fb_instant_articles\/modules\/fb_instant_articles_display\/js\/admin.js":1,"sites\/all\/themes\/mbn2_twig\/js\/header-top.js":1,"sites\/all\/themes\/mbn2_twig\/js\/header-drawer.js":1,"sites\/all\/themes\/mbn2_twig\/js\/article-comments.js":1,"sites\/all\/modules\/mbn_filter_tokens\/mbn_filter_tokens.js":1,"sites\/all\/modules\/mbn_share\/js\/mbn_share.js":1,"sites\/all\/modules\/visor_region\/js\/visor_region.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"sites\/all\/libraries\/spe\/spe-store.js":1,"sites\/all\/libraries\/fontfaceobserver\/fontfaceobserver.js":1,"sites\/all\/libraries\/jquery.appear-0.3.7\/jquery.appear.js":1,"sites\/all\/libraries\/jquery.plugins\/jquery.cookie.min.js":1,"https:\/\/cdnjs.cloudflare.com\/ajax\/libs\/fancybox\/3.1.25\/jquery.fancybox.min.js":1,"sites\/all\/libraries\/jquery.plugins\/jquery.backgroundSize.min.js":1,"sites\/all\/libraries\/galleria\/galleria-1.5.7.min.js":1,"sites\/all\/modules\/mbn_common\/js\/mbn_common.js":1,"sites\/all\/modules\/mbn_common\/js\/mbn_common_footer.js":1,"sites\/all\/libraries\/mediaelementjs\/mediaelement-and-player.min.js":1,"misc\/progress.js":1,"sites\/all\/modules\/visor_header2\/js\/header.js":1,"sites\/all\/modules\/mbn_notify\/follow\/follow.js":1,"sites\/all\/modules\/mbn_notify\/mbn_notify.js":1,"sites\/all\/libraries\/waypoints-4.0.0\/jquery.waypoints.js":1,"sites\/all\/themes\/mbn2_twig\/js\/article.js":1,"sites\/all\/themes\/mbn2_twig\/js\/sidebar.js":1,"sites\/all\/modules\/gpt\/gpt.js":1,"sites\/all\/libraries\/jquery.scrolldepth\/jquery.scrolldepth.min.js":1,"sites\/all\/themes\/mbn2_twig\/js\/font-loader.js":1}},"video_filter":{"url":{"ckeditor":"\/video_filter\/dashboard\/ckeditor"},"instructions_url":"\/video_filter\/instructions","modulepath":"sites\/all\/modules\/video_filter"},"mbn_common":{"cookie_domain":".imore.com","author":"Rene Ritchie"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip","trackDomainMode":"1"}});
//--><!]]>
</script>
<script type='text/javascript' src='https://passport.mobilenations.com/js/cluetip/jquery.cluetip.min.js?v41'></script>
<script type='text/javascript' src='https://passport.mobilenations.com/content/topbar/nationsbar.js?v41'></script>
<script type='text/javascript'>
  var tmntag = tmntag || {};
  tmntag.cmd = tmntag.cmd || [];
  tmntag.adunitRenderedCmd = tmntag.adunitRenderedCmd || [];

  (function() {
    var tmnhead = document.createElement('script');
    tmnhead.async = true;
    tmnhead.type = 'text/javascript';
    tmnhead.src = ('https:'==document.location.protocol?'https:':'http:')+'//ads.servebom.com/tmnhead.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(tmnhead, node);
  })();
  tmntag.cmd.push(function(){
    tmntag.target(targeting);
    tmntag.placement('3358'); // [tmnp.iMore/article_infinitescroll DESKTOP]
    tmntag.start();
  });
  </script></head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-44675 node-type-article node-format-article section-article cc-us im geo-US mona45">
<div id="skip-link">
<a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
</div>
<script>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</script> <div class="region region-site-header">
<div class="top-header top-header--default">
<div class="top-header-inner">
<div class="top-header-inner2">
<button class="top-header__drawer-toggle ir js-header-drawer-toggle js-header-drawer-toggle--nav">
<i class="fa fa-bars"></i>
</button>
<a href="/" rel="index" class="top-header__brand ir "></a>
<div class="top-header__offer">
<span class="top-header__offer-label js-offer-toggle">Order</span>
<span class="top-header__offer-body"><a href="http://aos.prf.hn/click/camref:1100lcZ8/pubref:imore/destination:https://www.apple.com/shop/buy-iphone/iphone-x" target="_blank">iPhone X</a> | <a href="http://aos.prf.hn/click/camref:1100lcZ8/pubref:imore/destination:https://www.apple.com/shop/buy-iphone/iphone-8" target="_blank">iPhone 8</a> | <a href="http://aos.prf.hn/click/camref:1100lcZ8/pubref:imore/destination:https://www.apple.com/shop/buy-watch/apple-watch&quot;" target="_blank">Apple Watch Series 3</a> | DEAL: <a href="https://www.mintsim.com?utm_source=dim&amp;utm_medium=content&amp;utm_content=UUimUdUbU88&amp;utm_campaign=mn-mintsim&amp;cid=aff-_-mobilenations-_-dim-_-UUimUdUbU88-_-content&amp;tid=mobilenations&amp;subid=UUimUdUbU88">BUY 3 Months, GET 3 Free. Unlimited Text, Calls</a></span>
</div>
<nav class="top-header__navigation">
<ul class="top-header__navigation-list">
<li class="top-header__navigation-item top-header__navigation-item--forum">
<a href="http://forums.imore.com"><i class="fa fa-comments"></i><span>Forums</span></a>
</li>
<li class="top-header__navigation-item top-header__navigation-item--shop">
<a href="http://store.imore.com"><i class="fa fa-shopping-cart fa-flip-horizontal"></i><span>Shop</span></a>
</li>
<li class="top-header__navigation-item top-header__navigation-item--search">
<button class="top-header__search-button js-top-header-search-toggle">
<i class="fa fa-search"></i>
<span>Toggle Search</span>
</button>
<form id="form-main-search" class="top-header__navigation-search-form" action="/search">
<button type="submit"></button>
<input type="text" id="main-search" name="query" placeholder="Search...">
</form>
</li>
</ul>
</nav>
</div>
</div>
</div> </div>
<div id='ctBoc'> 
<div id="page-wrap">
<div class="page-header clearfix clearfixb">
<div class="region region-page-header">
<div id='Leaderboard_Header_ATF-wrap' class='netshelter-ad gpt'>
<div class='netshelter-ad-inner'><div class="adunit" id='purch_Y_L_1_1' data-clone-id="" adonis-marker><script type='text/javascript'>
        tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_L_1_1',false);});
      </script></div></div>
</div> </div>
</div>
<div id="page">
<main class="content" id="content" tabindex="0">
<div class="container">
<div class="clearfix">
<div class="element-invisible"><a id="main-content"></a></div>
<div class="region region-content">
<div id="block-system-main" class="block block-system">
<div class="content">
<article class="article article--normal node node-article node-promoted node-cat-news node-cat-macs node-cat-security node-tag-macos-high-sierra node-tag-high-sierra not-ajaxed" id="article-44675" data-nid="44675" data-url="/macos-has-root-bug" data-canonical-url="https://www.imore.com/macos-has-root-bug">
<div class="row">
<header class="article-header col-3of3 ">
<span class="tag article-header__tag">Security</span>
<h1 class="article-header__title">macOS High Sierra has a critical 'root' security bug — here's what you need to do right now</h1>
<span class="article-header__intro">A critical flaw has been discovered in macOS High Sierra that lets an attacker with physical access to your Mac login as 'root' simply by leaving the password field blank and trying multiple times in a row. Here's how to "fix" it right now.</span>
<div class="article-header__details">
<div class="article-header__authors">
<span class="article-header__author">
<a href="/author/Rene%20Ritchie">Rene Ritchie</a>
</span> </div>
<time class="article-header__time" datetime="2017-11-28T16:37:56-05:00" title="Tue, 28 Nov 2017 16:37:56 -0500">
28 Nov 2017
</time>
<button class="article-header__comments js-comments-jump">
<i class="fa fa-comments" aria-hidden="true"></i>
2
</button>
</div>
</header>
</div> <div class="row row--no-wrap">
<div class="article-body col-3of3 col-2of3@tablet">
<div class="field field-name-body field-type-text-with-summary field-label-hidden"><div class="field-items"><div class="field-item even" property="content:encoded"><div class="article-body__section article-body__section--wide"><p><img src="https://www.imore.com/sites/imore.com/files/styles/xlarge_wm_brw/public/field/image/2016/11/macbook-pro-touch-id-setup.jpg?itok=P34M346m" width="1600" height="1200" alt="macOS has a critical 'root' security bug &mdash; what you need to do right now" class="image-xlarge_wm_brw aligncenter image-xlarge"></p></div><div class="article-body__section article-body__section--narrow">
<p class="article-body__drop-character">This is a zero day exploit. Lemi Orhan Ergin tweeted to Apple's support account that he had discovered a way to log into a Mac running High Sierra by using the superuser "root" and then clicking the login button repeatedly.</p>
<blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr" xml:lang="en">Dear <a href="https://twitter.com/AppleSupport?ref_src=twsrc%5Etfw">@AppleSupport</a>, we noticed a *HUGE* security issue at MacOS High Sierra. Anyone can login as "root" with empty password after clicking on login button several times. Are you aware of it <a href="https://twitter.com/Apple?ref_src=twsrc%5Etfw">@Apple</a>?</p>&mdash; Lemi Orhan Ergin (@lemiorhan) <a href="https://twitter.com/lemiorhan/status/935578694541770752?ref_src=twsrc%5Etfw">November 28, 2017</a></blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p>Ergin should absolutely have disclosed this to Apple and given the company a chance to patch it before it went public, but that's a bandaid on an axe wound at this point. The bug should never have gotten into the wild.</p>
<p>The "root" account is <a href="https://support.apple.com/en-us/HT204012">supposed to be disabled by default on macOS</a> but, for whatever reason, it's not on High Sierra. Instead, root access is available and, worse, available without a password. So, anybody who has physical access to your Mac and enters "root" can blast their way through pretty much any and all security and gain complete control over the machine.</p>
<p>It looks setting the "root" password "fixes" the problem:</p>
<ol><li>Click on Apple (&#63743;) at the far left of the menubar.</li>
<li>Click on <strong>System Preferences</strong>.</li>
<li>Click on <strong>Users and Groups</strong>.</li>
<li>Click on the <strong>Lock</strong> (&#128274;) icon. </li>
<li>Enter your <strong>Password</strong>.</li>
<li>Click on **Login Options*.</li>
<li>Click on <strong>Join</strong> or <strong>Edit</strong>.</li>
<li>Click on <strong>Open Directory Utility</strong>.</li>
<li>Click on the <strong>Lock</strong> (&#128274;) icon. </li>
<li>Enter your <strong>Password</strong>.</li>
<li>Click on <strong>Edit</strong> in the menubar.</li>
<li>Click on **Enable Root User*.</li>
<li>Enter and confirm your <strong>Root User Password</strong>. (Make it a strong, unique one!)</li>
</ol><p>Do not disable the Root User. That just blanks the password and allows the exploit to work again.</p>
<blockquote class="twitter-tweet" data-conversation="none" data-lang="en"><p lang="en" dir="ltr" xml:lang="en">FWIW, we, <a href="https://twitter.com/danielpunkass?ref_src=twsrc%5Etfw">@danielpunkass</a>, and <a href="https://twitter.com/dmoren?ref_src=twsrc%5Etfw">@dmoren</a> all confirmed that if you disable the root account, the flaw resets the password to blank again.</p>&mdash; Dan Frakes (@DanFrakes) <a href="https://twitter.com/DanFrakes/status/935618834886623232?ref_src=twsrc%5Etfw">November 28, 2017</a></blockquote>
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p>Apple needs to fix this stat. In the meantime, share this information with everyone you know who uses a Mac on High Sierra and make sure they test and validate that "root" access is blocked before you let them resume their day.</p>
<p></p> <div class="article-body__tabs article-body__tabs--devicebox">
<h2 class="article-body__tabs-title">
<a href="/macos-sierra">macOS High Sierra</a>
</h2>
<div class="article-body__tabs-container">
<div class="article-body__tabs-tab article-body__tabs-tab--1">
<h2 class="article-body__tabs-tab-title">Main</h2>
<div class="article-body__tabs-tab-body">
<p><a href="/macos-sierra"><img src="https://admin.imore.com/sites/imore.com/files/field/image/2017/06/macos-high-sierra-preview-hero.jpg" alt="macOS Sierra" height="1536" width="2048"></a></p>
<ul><li><a href="/macos-high-sierra">macOS High Sierra Review</a></li>
<li><a href="/macos-high-sierra-faq">macOS High Sierra FAQ</a></li>
<li><a href="http://forums.imore.com/macos-high-sierra/">macOS High Sierra Help Forum</a></li>
</ul></div>
</div>
</div>
</div>
<p></p><div>
<style>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</style></div>
</div>
<div id="purch_N_C_0_2-wrap" class="netshelter-ad gpt">
<div class="netshelter-ad-inner"><div class="adunit" id="purch_N_C_0_2" data-clone-id="" adonis-marker><script type='text/javascript'>
        tmntag.cmd.push(function(){ tmntag.adTag('purch_N_C_0_2',false);});
      </script></div></div>
</div></div></div></div>
</div>
<aside class="sidebar col-3of3 col-1of3@tablet" role="complementary">
<div class="sidebar__section">
<div id='purch_Y_R_1_1-wrap' class='netshelter-ad gpt'>
<div class='netshelter-ad-inner'><div class="adunit" id='purch_Y_R_1_1' data-clone-id="" adonis-marker><script type='text/javascript'>
        tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_R_1_1',false);});
      </script></div></div>
</div>
</div>
<div class="sidebar__section">
<div id='div-gpt-ad-2603350-5-5a1dda968108e'>
<script>
googletag.cmd.push(function() {
  gptadslots.push(googletag.defineSlot('/25586680/imore/news', [[300,285],[300,600],[300,700],[320,50],[320,100],[300,250]], 'div-gpt-ad-2603350-5-5a1dda968108e')
  .setTargeting('adunit', ['store_visor_side_bar_ad'])
  .defineSizeMapping(mapping2() )
  .addService(googletag.pubads()));
});
googletag.cmd.push(function() { 
  googletag.display('div-gpt-ad-2603350-5-5a1dda968108e'); 
});
</script>
</div>
</div>
<div class="sidebar__section">
<div id='purch_Y_R_0_1-wrap' class='netshelter-ad gpt'>
<div class='netshelter-ad-inner'><div class="adunit" id='purch_Y_R_0_1' data-clone-id="" adonis-marker><script type='text/javascript'>
        tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_R_0_1',false);});
      </script></div></div>
</div>
</div>
</aside> </div>
<div class="row">
<footer class="article-footer col-3of3">
<button class="article-footer__comments-toggle js-comments-toggle">
<span>View</span><span>Close</span> Comments (2)
</button>
<ul class="article-footer-tags">
<li><a href="/category/news">News</a></li>
<li><a href="/tag/macos-high-sierra">macOS high sierra</a></li>
</ul>
</footer> </div>
<div class="row">
<section class="article-comments" id="article-comments-44675">
</section>
</div>
<div class="row">
<div class="article-bio col-3of3 col-2of3@tablet">
<img class="article-bio__avatar" data-luid='28' src="https://passport.mobilenations.com/avatars/000/000/000/100x100_42.jpg?r=9" />
<div class="article-bio__bio">
<h3 class="article-bio__name">Rene Ritchie</h3>
<p>Rene Ritchie has been covering the personal technology industry for a decade. Apple analyst and tech critic. Video and podcast host. Explainer. Fact-checker. Futurist. Follow him @reneritchie on<a href="https://twitter.com/reneritchie">Twitter</a>, <a href="https://instagram.com/reneritchie">Instagram</a>, and <a href="https://www.facebook.com/thereneritchie/">Facebook</a>.</p>
</div>
</div> </div>
<div class="row">
<section class="article-thrifter col-3of3">
<style type='text/css'>

.thrifter-offers {
  max-width: 1021px;
  margin:25px auto 15px;
  padding:0px;
  font:normal 12px/16px helvetica,tahoma;background-color:#fff;margin:10px auto
  overflow:hidden;
  transition: all 0.3s;
}

.thrifter-offers h3{
  font-family:helvetica,tahoma, sans-serif;
  font-size:16px;
  font-weight:bold;
  margin: 15px 0;
}

.thrifter-offers:after {
  content: "";
  display: table;
  clear: both;
}

.thrifter-offers__offer{
  position:relative;
  display:inline-block;
  text-decoration:none;
  float:left;
  width:24.18%;
  margin-bottom: 15px;
  height:auto;
  background-size: 100% auto;
  background-position:50% -20px;
  background-repeat:no-repeat;
  box-sizing:border-box;
  -moz-box-sizing:border-box;
  overflow:hidden;
  color:#000;
}

/*.thrifter-offers a .thrifter-save{
display:block;
position:absolute;
right:-60px;top:-5px;
padding:24px 50px 0px;
text-align:center;
transform: rotate(45deg);
background-color:rgba(204,0,0,0.9);
color:white;
font-weight:bold;
font-size:14px;
line-height:25px;
}*/

.thrifter-offers__offer-info{
  display:block;
  box-sizing:border-box;
  -moz-box-sizing:border-box;
  margin-top:65%;
  width:100%;
  padding:5px 5px 5px;
  overflow:hidden;
  background-color: white;
}

.thrifter-offers__offer-title{
  display:block;
  font-weight:bold;
  font-size:14px;
  line-height:16px;
  margin-bottom:5px;
}

.thrifter-offers__offer-price{
  display:inline-block;
  font-weight:bold;
  font-size:16px;
}

.thrifter-offers__offer-price--retail{
  color:#999;
  font-size:13px;
  margin-right:10px;
  text-decoration:line-through;
}


/*
  .thrifter-offers a{
    width:48.91304%;
    margin-left: 2.17392%;
  }
  .thrifter-offers a:nth-child(2n+1){
    margin-left: 0;
    clear: left;
  }
  .thrifter-offers a:nth-child(n+3){
    display: inline-block;
  }

*/

@media (max-width: 440px) {

  .thrifter-offers__offer{
    width:48.91304%;
    margin-left: 2.17392%;
    background-position:50% -20px;
  }
  .thrifter-offers__offer:nth-child(2n+1){
    margin-left: 0;
    clear: left;
  }
  .thrifter-offers__offer:nth-child(n+3){
    display: inline-block;
    display:none;
  }
}


@media (min-width: 441px) {
  .thrifter-offers__offer,
  .thrifter-offers__offer:nth-child(2n+1){
    width:24.18478%;
    margin-left: 1.08696%;
    clear: none;
  }
 
  .thrifter-offers__offer:nth-child(4n+1){
    margin-left: 0;
  }
}
</style>
<div id='thrifter-offers'></div>
<script type='text/javascript'>
(function() {
  if(typeof jQuery == 'undefined'){
    var script = document.createElement('script');
    script.type = 'text/javascript';
    script.src = '/sites/all/modules/jquery_update/replace/jquery/1.10/jquery.min.js?v=1.10.2';
    document.getElementsByTagName('head')[0].appendChild(script);
  }
  
  jQuery(function($){
    renderThrifterOffers();
  });
  
  function renderThrifterOffers(){
    $offers = $('#thrifter-offers:first');
    $offers.addClass('thrifter-offers')
    $offers.attr('id', $offers.attr('id') + '-' + (Math.floor(Math.random() * 1000000)));
    
    $.post('https://www.thrifter.com/deal-api?total=4')
      .done(buildOffers)
      .fail(hideOffers);
    
    function buildOffers(data){
      var deals = [];
      $.each(data, function(k,deal){
        if (deal.price == null || deal.price == '0.00'){
          deal_price_html = '';
          deal.name = deal.title;
        }else{
          deal_price_html="<span class='thrifter-offers__offer-price thrifter-offers__offer-price--retail'>$"+ deal.street_price + "</span><span class='thrifter-offers__offer-price'>$"+ deal.price + "</span>";
        }
        deal_html = "<a class='thrifter-offers__offer' href='"+deal.full_url+"?utm_campaign=mn-thrifter&utm_medium=mbn_offers&utm_source=im' rel='noskim nofollow' target='_blank' style='background-image:url("+ deal.field_image_crop+ ");'>";
        deal_html+= "<span class='thrifter-offers__offer-info'><span class='thrifter-offers__offer-title'>"+deal.name+"</span>"+ deal_price_html + "</span></a>";  
        deals.push(deal_html);
      });
      
      $offers.append('<h3>Best of Black Friday</h3><div>' + deals.join(' ') + '</div></div>');
    }
    
    function hideOffers(){
      $offers.remove()
    }
  }
})();
</script>
</section>
</div>
<img src="https://dev.visualwebsiteoptimizer.com/c.gif?experiment_id=1&ACCOUNT_ID=315429&GOAL_ID=200&COMBINATION=2&UUID=&CACHE=1873413126" />
</article>
<button class="btn btn--load-more js-load-more " aria-label="Load more articles in this section"><span>Load More</span><i class="fa fa-refresh fa-spin fa-lg fa-fw"></i></button>
</div>
</div>
<section class="mn_mbn_share">
<a class="fb-share" href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.imore.com%2Fmacos-has-root-bug?utm_source=im%26utm_medium=facebook%26utm_campaign=social_share%26utm_content=UUimUdUnU44675" onClick="ga('send', 'event', 'Social Sharing', 'click', 'Facebook');" target="_blank"></a>
<a class="tw-share" href="https://twitter.com/intent/tweet?text=High+Sierra+&#039;root&#039;+vulnerability+%E2%80%94+do+this+right+now!+%7C+via+%40iMore&amp;url=https%3A%2F%2Fwww.imore.com%2Fmacos-has-root-bug?utm_source=im%26utm_medium=twitter%26utm_campaign=social_share%26utm_content=UUimUdUnU44675" onClick="ga('send', 'event', 'Social Sharing', 'click', 'Twitter');" target="_blank"></a>
<a class="gp-share" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.imore.com%2Fmacos-has-root-bug?utm_source=im%26utm_medium=googleplus%26utm_campaign=social_share%26utm_content=UUimUdUnU44675" onClick="ga('send', 'event', 'Social Sharing', 'click', 'GooglePlus');" target="_blank"></a>
<a class="ml-share hidden-xs" href="mailto:?subject=High%20Sierra%20%26%23039%3Broot%26%23039%3B%20vulnerability%20%E2%80%94%20do%20this%20right%20now%21&amp;body=https%3A%2F%2Fwww.imore.com%2Fmacos-has-root-bug?utm_source=im%26utm_medium=email%26utm_campaign=social_share%26utm_content=UUimUdUnU44675" onClick="ga('send', 'event', 'Social Sharing', 'click', 'eMail');" target="_blank"></a>
<a class="tx-share visible-xs" href="sms:?&amp;body=High%20Sierra%20%26%23039%3Broot%26%23039%3B%20vulnerability%20%E2%80%94%20do%20this%20right%20now%21 - https%3A%2F%2Fwww.imore.com%2Fmacos-has-root-bug?utm_source=im%26utm_medium=sms%26utm_campaign=social_share%26utm_content=UUimUdUnU44675" onClick="ga('send', 'event', 'Social Sharing', 'click', 'Text');" target="_blank"></a>
<a class="mr-share" href="#" target="_blank"></a>
<a class="rd-share h" href="https://reddit.com/submit?title=High+Sierra+&#039;root&#039;+vulnerability+%E2%80%94+do+this+right+now!&amp;url=https%3A%2F%2Fwww.imore.com%2Fmacos-has-root-bug?utm_source=im%26utm_medium=reddit%26utm_campaign=social_share%26utm_content=UUimUdUnU44675" onClick="ga('send', 'event', 'Social Sharing', 'click', 'Reddit');" target="_blank"></a>
<a class="pt-share h" href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.imore.com%2Fmacos-has-root-bug?utm_source=im%26utm_medium=pinterest%26utm_campaign=social_share%26utm_content=UUimUdUnU44675" onClick="ga('send', 'event', 'Social Sharing', 'click', 'Pinterest');" target="_blank"></a>
</section>
</div>
</div>
</div>
</main>
<div class="clear"></div>
<div id="banneradspace" align='center'>
<div id='Leaderboard_Footer_BTF-wrap' class='netshelter-ad gpt'>
<div class='netshelter-ad-inner'><div class="adunit" id='purch_Y_L_0_1' data-clone-id="" adonis-marker><script type='text/javascript'>
        tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_L_0_1',false);});
      </script></div></div>
</div> </div> 
</div> 
</div> 
</div> 
<div class="region region-site-footer">
<nav class="header-drawer js-header-drawer" aria-hidden="true" tabindex="-1">
<div class="header-drawer__inner">
<div class="header-drawer__nav">
<ul class="header-drawer__navigation-list header-drawer__navigation-list--nav">
<li class="header-drawer__navigation-item header-drawer__navigation-item--nav header-drawer__navigation-item--nav-nav">
<button class="header-drawer__navigation-button header-drawer__navigation-button--nav ir js-header-drawer-toggle js-header-drawer-toggle--nav">
<i class="fa fa-bars"></i>
</button>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--nav header-drawer__navigation-item--nav-forum">
<button class="ir js-header-drawer-toggle header-drawer__navigation-button--nav js-header-drawer-toggle--forum">
<i class="fa fa-comments"></i>
</button>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--nav header-drawer__navigation-item--nav-shop">
<button class="header-drawer__navigation-button header-drawer__navigation-button--nav ir js-header-drawer-toggle js-header-drawer-toggle--shop">
<i class="fa fa-shopping-cart fa-flip-horizontal"></i>
</button>
</li>
</ul>
</div>
<div class="header-drawer__topics">
<ul class="header-drawer__navigation-list header-drawer__navigation-list--superhub">
<li class="header-drawer__navigation-item header-drawer__navigation-item--superhub">
<a href="/rumors" class="header-drawer__navigation-link header-drawer__navigation-link--superhub">
Rumors
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--superhub">
<a href="/iphone" class="header-drawer__navigation-link header-drawer__navigation-link--superhub">
iPhone
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--superhub">
<a href="/ipad" class="header-drawer__navigation-link header-drawer__navigation-link--superhub">
iPad
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--superhub">
<a href="/apple-watch" class="header-drawer__navigation-link header-drawer__navigation-link--superhub">
Watch
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--superhub">
<a href="/apple-tv" class="header-drawer__navigation-link header-drawer__navigation-link--superhub">
TV
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--superhub">
<a href="/mac" class="header-drawer__navigation-link header-drawer__navigation-link--superhub">
Mac
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--superhub">
<a href="/how-to" class="header-drawer__navigation-link header-drawer__navigation-link--superhub">
How To
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--superhub">
<a href="/apps" class="header-drawer__navigation-link header-drawer__navigation-link--superhub">
Apps & Games
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--superhub">
<a href="/accessories" class="header-drawer__navigation-link header-drawer__navigation-link--superhub">
Accessories
</a>
</li>
</ul>
<h3 class="header-drawer__navigation-title">Other Categories</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--section">
<li class="header-drawer__navigation-item header-drawer__navigation-item--section">
<a href="https://forums.imore.com" class="header-drawer__navigation-link header-drawer__navigation-link--section">
Forums
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--section">
<a href="/analysis" class="header-drawer__navigation-link header-drawer__navigation-link--section">
Analysis
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--section">
<a href="/reviews" class="header-drawer__navigation-link header-drawer__navigation-link--section">
Reviews
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--section">
<a href="/deals" class="header-drawer__navigation-link header-drawer__navigation-link--section">
Deals
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--section">
<a href="/newsletter" class="header-drawer__navigation-link header-drawer__navigation-link--section">
Newsletter
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--section">
<a href="/contests" class="header-drawer__navigation-link header-drawer__navigation-link--section">
 Contests
</a>
</li>
</ul>
</div>
<div class="header-drawer__sites">
<ul class="header-drawer__navigation-list header-drawer__navigation-list--sites">
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites ac">
<a href="http://www.androidcentral.com" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
Android Central
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites wp">
<a href="http://www.windowscentral.com" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
Windows Central
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites im">
<a href="http://www.imore.com" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
iMore
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites cb">
<a href="http://crackberry.com" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
CrackBerry
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites vr">
<a href="http://www.vrheads.com" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
VRHeads
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites mm">
<a href="http://youtube.com/c/themrmobile?sub_confirmation=1" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
MrMobile
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites md">
<a href="https://www.youtube.com/channel/UCDxRn03fR0V8M7lms_YYXOQ?sub_confirmation=1" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
Modern Dad
</a>
</li>
</ul>
</div>
<div class="header-drawer__forum">
<h3 class="header-drawer__navigation-title">Forums and Discussions</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--forum">
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iMore Forums
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ask-question/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Ask a Question
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/search.php?do=getnew&utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
New Posts
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/activity.php?sortby=popular&show=all&time=week&utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Trending Discussions
</a>
</li>
 <li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-8/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone 8
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-7-plus/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone 7 Plus
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-7/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone 7
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ipad/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPad
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ios-11/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iOS 11
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ios-10/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iOS 10
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/apple-watch-series-2/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apple Watch Series 2
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/apple-watch/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apple Watch
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/macbook-pro/?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
MacBook Pro
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-apps-games/" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apps & Games
</a>
</li>
</ul>
</div>
<div class="header-drawer__shop">
<h3 class="header-drawer__navigation-title">Shop</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--shop">
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/deals.htm?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
 HOT ACCESSORY DEAL$
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://digitaloffers.imore.com" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Digital Offers
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Best sellers
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-new.htm?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
New releases
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-cases.htm?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Cases and covers
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/cradles.htm?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Chargers and cables
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-batteries.htm?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Battery packs
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-screen-protectors.htm?utm_medium=navbar&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Screen Protectors
</a>
</li>
</ul>
</div>
<div class="header-drawer__dev">
<h3 class="header-drawer__navigation-title">Dev Center</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--dev">
</ul>
</div>
<div class="header-drawer__tools">
<div class="header-drawer__passport">

<span class="header-drawer__passport-links">
<span class="fa-stack fa-lg">
<i class="fa fa-circle fa-stack-2x"></i>
<i class="fa fa-sign-in fa-stack-1x fa-inverse"></i>
</span>
<a href="https://passport.mobilenations.com/?u=eNpVjssOwiAQRf-FfW0pr3ZcXJr4Aeq-oUAqsYgBmpoY_12obtzdOZl7ZiRweEXALaBgtA1GpWEJM9pHoA2ga0qPCHW9ruvOOh_MTnlXO6l8rK4yVsH7VI3LVPYx_3cMTrPCSXZzI0atBSNY0VaPVNBe874TqqMNkZxs91wwRZtMiblhXQlZKVWy_l4GBmj2k90yzs8dzqfjcPE3k8kIzY-a58MG-e1YwAzjvhWMtvv3B-5cJ0jP">Log in</a>
or
<a href="https://passport.mobilenations.com/?u=eNpVjssOgjAURP-FPUKhD7gsTfxcMHVP-go0WkvaEkyM_26LbtzNncycuRwovAKgBgqvlfFaxnH192IIgGso5hiXXDBVtW3bwVjn9UE6W1kuXShnHkrvXFwsxTrlPKL_jNEqkv02salmQilGWiRxowRmuFe075jscN1y2u57UAQTdZapYWwWCcllNO6Rjy7zXCcTovb7XvrveDmfxqu76RQQUP9cXP1cXIzn35oBRBDqG0ZwM7w_5DlKHg,,">Sign up</a>
</span>

</div>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--social">
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
 <a href="https://google.com/+imore?utm_medium=burger&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fa fa-google-plus" aria-hidden="true"></i>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://www.twitter.com/imore?utm_medium=burger&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fa fa-twitter" aria-hidden="true"></i>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://www.facebook.com/imorecom?utm_medium=burger&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fa fa-facebook" aria-hidden="true"></i>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://www.youtube.com/subscription_center?add_user=imorevideo&utm_medium=burger&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fa fa-youtube-play" aria-hidden="true"></i>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://instagram.com/imoregram?utm_medium=burger&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fa fa-instagram" aria-hidden="true"></i>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="https://www.imore.com/rss.xml?utm_medium=burger&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fa fa-rss" aria-hidden="true"></i>
</a>
</li>
</ul>
<ul class="header-drawer__navigation-list header-drawer__navignation-list--footer">
<li class="header-drawer__navigation-item header-drawer__nagigation-item--footer">
<a href="mailto:news@imore.com" class="header-drawer__navigation-link header-drawer__navigation-link--footer">
<i class="fa fa-paper-plane"></i><span>Tip us on News</span>
</a>
</li>
</ul>
</div>
</div>
</nav>
<footer class="footer">
<section class="footer__brand">
<div class="container">
<a href="https://www.mobilenations.com/" class="footer__logo">Mobile Nations</a>
<strong class="footer__tagline">
<span>500M</span>
Consumers Reached Yearly
</strong>
</div>
</section>
<section class="footer__copyright">
<div class="container">
<ul class="footer__nav">
<li class="footer__nav-item">Copyright 2017 Mobile Nations</li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/terms-conditions">Terms and Conditions</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/privacy-policy">Privacy Policy</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/privacy-policy#your-choices">Your Ad Choices</a></li>
<li class="footer__nav-item">Careers: <a href="http://breaksclusive.recruiterbox.com/">Writer</a> | <a href="https://mobilenations.recruiterbox.com/">Dev</a></li>
<li class="footer__nav-item"><a href="https://wrightsmedia.com/sites/mobilenations/">Licensing</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/external-links">External Links Disclosure</a></li>
</ul>
<a href="http://purch.com/advertise/" class="footer__partner-logo">
<span>Advertising Partner</span>
</a>
</div>
</section>
</footer>

</div>
<script type="text/javascript"> 
      try{
        (function(){ 
          var cb = new Date().getTime(); 
          var s = document.createElement("script"); 
          s.defer = true; 
          s.src = "//tag.crsspxl.com/s1.js?d=2127&cb="+cb; 
          var s0 = document.getElementsByTagName("script")[0]; 
          s0.parentNode.insertBefore(s, s0); 
        })();
      }catch(e){}
    </script><script type="text/javascript">
  var spe_url = document.domain;
  var spe_url_array = new Array;
  spe_url_array = spe_url.split(".");
  spe_url_array.reverse();
  var spe_root_url = spe_url_array[1] + '.' + spe_url_array[0];

  if (spe_url_array[2]) {
    var spe_segments = spe_url_array[1] + '.' + spe_url_array[2];
  } else {
    var spe_segments = spe_url_array[1];
  }

</script>
<script type="text/javascript">
  var _qevents = _qevents || [];

  (function() {
  var elem = document.createElement('script');
  elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
  elem.async = true;
  elem.type = "text/javascript";
  var scpt = document.getElementsByTagName('script')[0];
  scpt.parentNode.insertBefore(elem, scpt);
  })();


  _qevents.push({
    qacct:"p-ebutdjFEkjMk-",
    labels: spe_segments
  },
  {
    qacct:"p-8bC03lZwjgqy2",
    labels: spe_segments
  }
  );
</script>
<noscript>
<div style="display:none;">
  <img src="//pixel.quantserve.com/pixel?a.1=p-ebutdjFEkjMk-&a.2=p-8bC03lZwjgqy2" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035753" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035753&cv=2.0&cj=1" />
</noscript>
<script>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</script><script>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</script>
<script type="text/javascript">
        window._taboola = window._taboola || [];
        _taboola.push({flush: true});
        </script><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1082324575168159&ev=PageView&noscript=1" /><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1082324575168159&ev=ViewContent&noscript=1" /><div id='fb-root'></div>
<script type='text/javascript'>
      var fbAsyncInitOrg = window.fbAsyncInit;
      window.fbAsyncInit = function() {
        if(typeof(fbAsyncInitOrg)=='function') fbAsyncInitOrg();
        FB.init({
          appId: '213678485361751',
          version: 'v2.7',
          status: true,
          cookie: true,
          xfbml: true});
      };
      (function() {
        var e = document.createElement('script');
        e.type = 'text/javascript';
        e.src = document.location.protocol +
                '//connect.facebook.net/en_US/all.js';
        e.async = true;
        document.getElementById('fb-root').appendChild(e);
      }());
      </script>
<script type='text/javascript'>
          $('a[href*="//itunes.apple.com"],a[href*="//itun.es"],a[href*="//rover.ebay.com"],a[href*="7293438-11365093"]').addClass('norewrite');
        </script>
<script type='text/javascript'>
        var vglnk = { key: '8ed1f879e224588da0398abad3c283a2' };

        (function(d, t) {
          var s = d.createElement(t); s.type = 'text/javascript'; s.async = true;
          s.src = '//cdn.viglink.com/api/vglnk.js';
          var r = d.getElementsByTagName(t)[0]; r.parentNode.insertBefore(s, r);
        }(document, 'script'));
        </script><script>
        $('.glade').each(function() {
          var data = $(this).data('json');
          $.extend(data.targeting,window.targeting);
          $(this).attr('data-json', JSON.stringify(data));
          $(this).data('json',data);
        });  
      </script>
<script src='https://securepubads.g.doubleclick.net/static/glade.js' async=''></script><script>
  PARSELY = { };
</script>

<div id="parsely-root" style="display: none">
<div id="parsely-cfg" data-parsely-site="imore.com"></div>
</div>
<script>
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>

<div id="fb-root"></div>
<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId: "213678485361751",
      xfbml: true,
      version    : 'v2.6'
    });

    FB.Event.subscribe('xfbml.ready', function(msg) {   // Log all the ready events so we can deal with them later
      var events = fbroot.data('ready-events');
      if( typeof(events) === 'undefined') events = [];
      events.push(msg);
      fbroot.data('ready-events',events);
    });

    var fbroot = $('#fb-root').trigger('facebook:init');
  };
</script>

<script async='async' type='text/javascript' src='//www.lightboxcdn.com/vendor/d74ebc7c-6bfa-42bd-b88b-9240b4878523/lightbox_inline.js'></script>
 <script type="text/javascript">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</script> <div class="adunit" id="purch_Y_O_1_1" data-dimensions='1x1'><script type='text/javascript'>
        tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_O_1_1',false);});
      </script></div> <div class="adunit" id="purch_Y_P_1_1" data-dimensions='1x1'><script type='text/javascript'>
        tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_P_1_1',false);});
      </script></div><script type="text/javascript">

  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  var spe_root_url = document.domain.match(/[^\.]+\.[^\.]+$/)[0];
  ga('create', 'UA-4245582-4', "." + spe_root_url, 'global', {
    allowLinker: true
  });
  ga("global.set", "dimension1", "full");
  ga("global.set", "dimension2", "News");
  ga("global.set", "dimension3", "true");
  ga("global.set", "dimension4", "C:article,S:standard,B:w400");
  ga('global.require', 'linkid');
  ga('global.require', 'linker');
  ga('global.linker:autoLink', ["crackberry.com","androidcentral.com","imore.com","windowscentral.com","mobilenations.com","vrheads.com","thrifter.com","teslacentral.com"]);
  ga('global.send', 'pageview');
  setTimeout("ga('global.send','event','NoBounce','Over 20 seconds')",20000);
</script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__stCTuOekKWy-hCZJ2VsJT3UYeGWQSRT0P2QgtaDEUjw__RJ9xi9wU_oAnYHhFY0XWtFBkVimQ6UfUNThk7quaoZA__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js" async="async"></script>
<script type="text/javascript" src="https://www.imore.com/sites/imore.com/files/advagg_js/js__bViWhUebjeLEtZHLFlNw2VCoGL3DRdULWZ79AYKUZMI__O4A57Sv5pz88_XnltO_gB5wHXvKWgKesy_ZA-iNCclg__K6uRlKbVvb_jcKkSOO8DX7ari5paWjlyesM1MzcrRwA.js" async="async"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
$('audio').mediaelementplayer();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','twitter-wjs');
//--><!]]>
</script>
</body>
</html>
