<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/terms/" xmlns:foaf="http://xmlns.com/foaf/0.1/" xmlns:og="http://ogp.me/ns#" xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#" xmlns:sioc="http://rdfs.org/sioc/ns#" xmlns:sioct="http://rdfs.org/sioc/types#" xmlns:skos="http://www.w3.org/2004/02/skos/core#" xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
<head profile="http://www.w3.org/1999/xhtml/vocab">
<!--[if IE]><![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="x-dns-prefetch-control" content="on" />
<link rel="dns-prefetch" href="//www.imore.com" />
<!--[if IE 9]>
<link rel="prefetch" href="//www.imore.com" />
<![endif]-->
<script>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</script><script>
    /* Check for email addresses in fragment...if found, then completely remove it*/
    if(window.location.hash.match(/(.*?)([\w.+-]+(@|%40)[a-z\d.-]+\.[a-z]{2,})([^a-z\d.-].*|$)/i)) {
      window.location.hash = "";
    }
  </script><meta name="msapplication-tooltip" content="iMore" />
<meta property="og:site_name" content="iMore" />
<meta property="article:published_time" content="2018-05-03T16:51:57-04:00" />
<meta property="article:section" content="article" />
<meta property="article:tag" content="Apps" />
<meta property="article:tag" content="News" />
<meta property="article:tag" content="Twitter" />
<link rel="alternate" href="android-app://com.imore.app/https/www.imore.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log" />
<meta name="viewport" content="width=1024" />
<link rel="amphtml" href="https://www.imore.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log?amp" />
<meta name="terms" content="Apps,News,Twitter" />
<meta name="msapplication-name" content="iMore" />
<meta name="msapplication-navbutton-color" content="#f8d509" />
<meta property="og:image" content="https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/07/072216-twitter-verification-hero.jpg?itok=y-tUICsh" />
<meta name="msapplication-TileColor" content="#f8d509" />
<meta name="msapplication-square70x70logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/tiny.png" />
<meta name="msapplication-square150x150logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/square.png" />
<meta name="msapplication-wide310x150logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/wide.png" />
<meta name="msapplication-square310x310logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/large.png" />
<meta name="msapplication-notification" content="frequency=30;polling-uri=https://www.imore.com/live-tile/0;polling-uri2=https://www.imore.com/live-tile/1;polling-uri3=https://www.imore.com/live-tile/2;polling-uri4=https://www.imore.com/live-tile/3;polling-uri5=https://www.imore.com/live-tile/4; cycle=1" />
<meta name="theme-color" content="#ffd600" />
<link rel="apple-touch-icon" sizes="57x57" href="https://www.imore.com/sites/imore.com/files/images/icons/apple-touch-57x57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="https://www.imore.com/sites/imore.com/files/images/icons/apple-touch-72x72.png" />
<link rel="apple-touch-icon" sizes="114x114" href="https://www.imore.com/sites/imore.com/files/images/icons/apple-touch-114x114.png" />
<script type="application/ld+json">
    {
    "@context": "http://schema.org",
    "mainEntityOfPage": "https://www.imore.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log",
    "@type": "NewsArticle",
    "headline": "Twitter asks users to change passwords after bug exposed them on internal log",
    "url": "https://www.imore.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log",
    "datePublished": "2018-05-03T20:51:57+0000",
    "dateCreated": "2018-05-03T20:51:57+0000",
    "dateModified": "2018-05-03T20:51:57+0000",
    "author": {
        "@type": "Person",
        "name": "Dan Thorp-Lancaster"
    },
    "creator": "Dan Thorp-Lancaster",
    "thumbnailUrl": "https://www.imore.com/sites/imore.com/files/styles/thumbnail/public/field/image/2016/07/072216-twitter-verification-hero.jpg?itok=XrKor0Dj",
    "keywords": [
        "twitter"
    ],
    "articleSection": "News",
    "image": [
        "https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/07/072216-twitter-verification-hero.jpg?itok=y-tUICsh"
    ],
    "publisher": {
        "@type": "Organization",
        "name": "iMore",
        "logo": {
            "@type": "ImageObject",
            "url": "https://www.imore.com/sites/imore.com/files/im-amp-logo_0.png",
            "width": null,
            "height": null
        }
    }
}
  </script><meta property="og:type" content="article" />
<meta property="og:url" content="https://www.imore.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log" />
<link href="//passport.mobilenations.com" rel="dns-prefetch" />
<script type="text/javascript">
    var parsely_google = {
    "@context": "http://schema.org",
    "mainEntityOfPage": "https://www.imore.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log",
    "@type": "NewsArticle",
    "headline": "Twitter asks users to change passwords after bug exposed them on internal log",
    "url": "https://www.imore.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log",
    "datePublished": "2018-05-03T20:51:57+0000",
    "dateCreated": "2018-05-03T20:51:57+0000",
    "dateModified": "2018-05-03T20:51:57+0000",
    "author": {
        "@type": "Person",
        "name": "Dan Thorp-Lancaster"
    },
    "creator": "Dan Thorp-Lancaster",
    "thumbnailUrl": "https://www.imore.com/sites/imore.com/files/styles/thumbnail/public/field/image/2016/07/072216-twitter-verification-hero.jpg?itok=XrKor0Dj",
    "keywords": [
        "twitter"
    ],
    "articleSection": "News",
    "image": [
        "https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/07/072216-twitter-verification-hero.jpg?itok=y-tUICsh"
    ],
    "publisher": {
        "@type": "Organization",
        "name": "iMore",
        "logo": {
            "@type": "ImageObject",
            "url": "https://www.imore.com/sites/imore.com/files/im-amp-logo_0.png",
            "width": null,
            "height": null
        }
    }
};
  </script><meta name="msvalidate.01" content="21BE5B9D4A670657156555D9E8E78D8D" />
<meta property="fb:pages" content="230016313741478" />

<script>
    !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
    n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
    document,'script','https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1674633419534068');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=1674633419534068&ev=PageView&noscript=1"
    /></noscript>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/mobilenations1-network/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script><link href="//www.windowscentral.com" rel="dns-prefetch" />
<link href="//www.androidcentral.com" rel="dns-prefetch" />
<link href="//crackberry.com" rel="dns-prefetch" />
<link href="//www.imore.com" rel="dns-prefetch" />
<link href="//www.vrheads.com" rel="dns-prefetch" />
<link href="//www.thrifter.com" rel="dns-prefetch" />
<link href="//www.modmy.com" rel="dns-prefetch" />
<link href="//www.cordcutters.com" rel="dns-prefetch" />
<link href="//forums.imore.com" rel="dns-prefetch" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@iMore" />
<meta name="twitter:title" content="Twitter asks users to change passwords after bug exposed them on internal log" />
<meta name="twitter:domain" content="https://www.imore.com" />
<meta name="twitter:image" content="https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/07/072216-twitter-verification-hero.jpg?itok=y-tUICsh" />
<meta name="twitter:app:name:googleplay" content="iMore" />
<meta name="twitter:app:id:googleplay" content="com.imore.app" />
<meta name="twitter:app:url:googleplay" content="https://www.imore.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log" />
<meta name="twitter:creator:id" content="436336169" />
<meta name="twitter:description" content="Twitter is asking users to reset their passwords after a bug in its hashing process caused them to be stored in an unmasked state on an internal log." />
<meta property="og:title" content="Twitter asks users to change passwords after bug exposed them on internal log" />
<meta property="og:description" content="Twitter is asking users to reset their passwords after a bug in its hashing process caused them to be stored in an unmasked state on an internal log." />
<meta name="description" content="Twitter is asking users to reset their passwords after a bug in its hashing process caused them to be stored in an unmasked state on an internal log." />
<link rel="image_src" href="https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2016/07/072216-twitter-verification-hero.jpg?itok=y-tUICsh" />
<link rel="canonical" href="https://www.windowscentral.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log" />
<title>Twitter asks users to change passwords after bug exposed them on internal log | iMore</title>
<link rel="alternate" type="application/rss+xml" title="iMore RSS" href="/rss.xml" />
<link type="text/css" rel="stylesheet" href="/sites/imore.com/files/advagg_css/css__2QnIKliR-_L8BBlwuFSAh3UxeDVoLA4xv-CV-7YV6e8__Bb4gicMab0WMg0dwzYudjl9_8OWcsKICDlKgSztQHE0__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.css" media="all" />
<style type="text/css" media="all">
/* <![CDATA[ */
.async-hide{opacity:0 !important}

/* ]]> */
</style>
<link type="text/css" rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.1.25/jquery.fancybox.min.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/imore.com/files/advagg_css/css__C9NntCaVunhL9_EZeGGjw0ECLU4xkoNiINiNF5i3nKo___97fpjJFpkW5XIr0AuLFGcbYsvS0yq2vlDYo0WJ_i0k__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/imore.com/files/advagg_css/css__emDGL7ELG26TbATw8aEDLbN8OgFOe5nAFtOjEDSOdic__2F8raJe7tXJ3ilJyU4UGTzxyqb2__rF_HsrCereMH5U__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.css" media="screen" />
<link rel='stylesheet' type='text/css' href='https://passport.mobilenations.com/css/profile-popup.css?v41' />
<link rel='stylesheet' type='text/css' href='https://passport.mobilenations.com/js/cluetip/jquery.cluetip.css?v41' />
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__q4ZluDEr7yHOp8TDo4l-cypOrRNOvxyaxrSrBudwQ2E__LOGJbIpGkynalCSfcR1h34ImWYBGTa_dPChPTpArKqg__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var vwoArticle = true;
//--><!]]>
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__UW4URQsON5h-xjwepC-HoW32RCC10thhh4f0DQ1P8z4__BH7phz4H4FiBY2e6OAdxmTaSy7zZZj56fMa81KOwqRY__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__52ZGpB_C6NP-K_0i-Kq9dylmkXA4U-taF9wS9maDsOI__1oI38DsOeIfPg_RP8R8fdcP0GyyrwOBszS6tlxx0I3U__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
$ = jQuery;
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var _vwo_code=(function(){
var account_id=315429,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
//--><!]]>
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__kyxhTyx1CsJNcz2J5747UYzW5Iu_N8U5cv1t_BoIi5M__nIYBMEbg4VeTNftTjXAykj7SczRfi1LLiwiz9HMIdwI__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-2017486-7", {"cookieDomain":".imore.com"});ga("set", "dimension1", "full");ga("set", "dimension2", "article");ga("set", "dimension3", "true");ga("set", "dimension4", "C:article,S:legacy,B:w300");ga('require', 'linkid');ga("send", "pageview");setTimeout("ga('send','event','NoBounce','Over 20 seconds')",20000);
//--><!]]>
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__XtkK5Cb8BZxIDJldA3NdtN7G_81D7PKCkk54HCZVtiA__0UwW45_zKgbsvJqfhu9oDCho7xAo4MNAfcf5QNldsws__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js"></script>
<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.1.25/jquery.fancybox.min.js"></script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__TVYqXtaCXvxXnYs-pUdkGoDE2EUXscxjIhbNs1mfung__ZtfyJ4y3Cd3oNLxVckk3w_OVUiNgnvCu9Hwmni6yq-4__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js"></script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__Ls7xyOQwv3P3pY93ObUOTbwkdG05i2DK4T9rFTLcTVE__JXQqSgi5bfiMbxpfeId2Jt8JPa_HqLUoi3eOfGHLvWk__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js" defer="defer"></script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__pydajIqUZaN0SOV3RX_rZqz6lTMDkJ_5AkjWUECKULU__Wyq24gtdDD29IQPEpvTZIiAkOwHrIy2e65WWjG5jrOc__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  $(function() {
    if(!$.lazyLoadXT) { // If the library didn't load, maybe adblockers are enabled?  Just show all imgs
      $('img.lazy').each(function() {
        $(this).attr('src',$(this).attr('data-src'));
      });
    }
  });
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      if (typeof(mbn_config) === 'undefined') var mbn_config = {};
      mbn_config = $.extend(true, mbn_config, {"pp_register":"https:\/\/passport.mobilenations.com\/?u=eNpVj0tPwzAQhP9KlQOCg9s8mrS4qpBAqsSBC_Qe-bFNrNZ25LUVJMR_Zx24cNv9NDs7I3jHv5BXNS8CaBNAxT6FW3EgtiM4xjgh32zmeV4b6wOslbebOJsYITCBV2QJISBTo3ADsEkgzj5oZOKSFTINDD5cJ4-gWRzBMuMIO3FjNz88pWh79CkoOF5cMLRMwUG4y9RSmGQXuuxK2EmYwR1PRPjqPMLrNHoHz2SzujdvlOxhCd39L9Jb3WbeUBdZql2jmxrkpZXQNlKo6rHSJey7Zr8tIeu2vEATl5EujM0DWQoVjXd52Wf_wSC1WP6VvHj5eD_1Z38FEkhe_lFqbYL4PTO8aut2W-66uj18_1wwyN99Zg,,","pp_login":"https:\/\/passport.mobilenations.com\/?u=eNpVj0tPwzAQhP9KlQOCg5tXnRRXFRJIlThwgd4jPzaJ1diO_FCQEP-dTeDCbfbT7O4MZw37CqysWOZBaQ8ydslP2QlZi3CMcQ4sz5dl2WvjPOylM3lcXHSM4AkPt0BSXDAfiBy5HYDMPITFeRUI71eHSAOBz9kFUCSOYIi2iC2fyOSGpxRNF1xc8hLOPYASyVvwdys1GCaZjW6z5GbmerDnCxK2u47wOo_OwjOe2d3rN0z2sIVu_hfpjKIrr7GLKGRbq7oC0VMBtBZcXJaPpSrg2NTHQwGr78CyoOMmcUObVeBJLqN2dh0oy_Cl3nRZsOzl4_3SXd0NkAhW_FGsrD3_3dGspBU9FG1T0dP3Dzj1fBc,","pp_social":{"fb":"https:\/\/passport.mobilenations.com\/?u=eNpVj0tPwzAQhP9KlQOCg9s8mqS4qpBAqsSBC_Qe-bFJrNZ25LUVJMR_ZxO4cNv9NLM7I3jDv5AXJc8CaBNAxS6FW3Yk1hIcY5yQ73bzPG-N9QG2yttdnE2MEJjAK7KEEJCpUbgB2CQQZx80MtEvCpkGBp-TR9AsjmCZcYSduLGbH55StB36FBScelwwLVNwEO4WailMsitddyXsJMzgTmdcInxzGeF1Gr2DZzqzuTdvlOxhDd38L9JZXS-8oi4yV22lqxJkX0uoKylU8VjoHA5NddjnsOj2PEMT15Ecxi4DnRQqGu_WB4QRfdcLBdL768pynr18vJ-7i78CqSTP_yhVN0H8eg0v6rLe521T1sfvH0z4fxo,","gp":"https:\/\/passport.mobilenations.com\/?u=eNpVj0tPwzAQhP9K1QOCg9s8mqR1VSGBVIkDF-g98mObWI3tyGsrSIj_zibAgdvup5ndGcFr_ok8L_g6gDYBVGxTGNZHYg3BPsYR-XY7TdPGWB9go7zdxsnECIEJvCFLCAGZ6oXrgI0CcfJBIxPXWSFTx-Bj9AiaxR4sM46wEwMbfPeYom3Rp6DgdAXQMgUH4W6mlsIku9BlV8KOwnTudCbCV5ceXsbeO3iiM6t780rJHpbQ9f9cIq3V1cxL6lwiM9WUuixAXisJVSmFyg-5zmBfl_tdBrNux9do4jKSw9h5oJNCRePd8iAjBfq2874b4I88v7-d24u_AWkkz34pFTdB_DgNz6ui2mVNXVTHr29GEH5b","ms":"https:\/\/passport.mobilenations.com\/?u=eNpVj0tPwzAQhP9KlQOCg9s8mqS4qpBAqsSBC_Qe-bFJrNZ25LUVJMR_ZxO4cNv9NLM7I3jDv5AXJc8CaBNAxS6FW3Yk1hIcY5yQ73bzPG-N9QG2yttdnE2MEJjAK7KEEJCpUbgB2CQQZx80MtEvCpkGBp-TR9AsjmCZcYSduLGbH55StB36FBScelwwLVNwEO4WailMsitddyXsJMzgTmdcInxzGeF1Gr2DZzqzuTdvlOxhDd38L9JZXS-8oi4yV22lqxJkX0uoKylU8VjoHA5NddjnsOj2PEMT15Ecxi4DnRQqGu_WBxUp0HfWqODR93GFOc9ePt7P3cVfgWSS53-Uupsgfs2GF3VZ7_O2Kevj9w_f33-3","tw":"https:\/\/passport.mobilenations.com\/?u=eNpVkE1rwzAMhv9KyWFsB7f5aJLWpQw2KOywy9Z78IeamNZ2sGwyGPvvU7JedpMeXknvK8Eb_o28KHkWQJtcMCp2KdyyA7GW4BDjiHyzmaZpbawPsFbebuJkYoTABF6RJYSATA3C9cBGgTj5oJGJy6yQqWfwNXoEzeJcMJYZR9iJG7v5_jlF26FPQcHxAqBlCg7Cw0wtmUl2oUuvhB2F6d3xRISvzgO8jYN38EJrVo_mnZw9Laab_0E6q-uZV5RF5qqtdFWCvNQS6koKVewLncOuqXbbHGbdlmdo4lLShLFzQSuFisa75UBBCvTd_QULynn2-vlx6s7-CiSSPL9TSm6C-Bs1vKjLepu3TVkffn4B1ol-8g,,"},"user":{"pdevice":null,"puid":null,"cuid":"","optin":null,"geo":"US","member":"false"},"site":{"site":"im","name":"iMore","cookie_domain":".imore.com","push_host":"https:\/\/push.mobilenations.com","push_manage_host":"https:\/\/www.imore.com","push_manage_page":"\/follow\/","dev":0}});
      
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if(typeof mbn_config === 'undefined') var mbn_config = {};
  mbn_config = $.extend(true, mbn_config, {"style":"full","site_abbr":"im","mobile":false,"domain":"imore.com","subdomain":"*","platform":"d","show_sidebar":true,"node_type":"article","nid":"46512","section":"article","pp_login":"https:\/\/passport.mobilenations.com\/?u=eNpVjsFuwyAQRP-FO7EhQOTNMVI_oO3dXCKwsVGMsVgsV6r674W2l95mRzP7xoKBTwIhgWX0IaMr454XdiUYzsDmUjaCrjuO4xRiynhyKXblCKVg5paexHfCTNzNdp2Qb5boSNkTt4-WuO8Tx48tEXpeZow8rNVe7cKXNDWIMP_BY_S6-ec6yA_o5cVpo5Xxg1a9kEIqYZRQOIiHaDkFjELBJmsjxCbqS-tKSGs7NLCKCj9a9MBub68v43t6YnXu0P-5dWPI9rcTQGhZaRcj9fXrG2moXFz6","pp_register":"https:\/\/passport.mobilenations.com\/?u=eNpVjsFuwyAQRP_Fd2JDgNSbY6V-QNu7RWBjoxhjsVhUqvrvhbaX3mZHM_vGgIZPAi6gS-h8QpunI63dlWA8Q7fkvBP0fSnl5ENMeLIx9Ln4nDExQw9iB2FcImYXs83IdkNUYnLEzL0lbsfM8GOPhI7lBQPzW7U3s7I1zg3C9X_wFJxq_rkOciM6cbFKK6ndqOTABReSa8kljvzOW05CRz5jk7XhQxP1pbHZx60dT-3_7Klif3gDdM9vry_Te3xgDdxg-HPrTJ_Mb80DV6ICL1qo69c3nDteSQ,,","user":{"pdevice":"","puid":""},"themes":{"full":"\/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log?utm_source=feedburner\u0026utm_medium=feed\u0026utm_campaign=Feed%3A+TheIphoneBlog+%28iMore%29\u0026style=default","mobile":"\/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log?utm_source=feedburner\u0026utm_medium=feed\u0026utm_campaign=Feed%3A+TheIphoneBlog+%28iMore%29\u0026style=mobile"}});
  
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

  // Taboola NEWSROOM SCRIPT 
  window._newsroom = window._newsroom || [];  
    !function (e, f, u) {
      e.async = 1;
      e.src = u; f.parentNode.insertBefore(e, f);
    }(document.createElement('script'),document.getElementsByTagName('script')[0], '//c2.taboola.com/nr/mobilenations1-imore/newsroom.js');
    // END NEWSROOM SCRIPT
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  var tmntag = tmntag || {};
  tmntag.cmd = tmntag.cmd || [];
  tmntag.adunitRenderedCmd = tmntag.adunitRenderedCmd || [];

  (function() {
    var tmnhead = document.createElement('script');
    tmnhead.async = true;
    tmnhead.type = 'text/javascript';
    tmnhead.src = ('https:'==document.location.protocol?'https:':'http:')+'//ads.servebom.com/tmnhead.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(tmnhead, node);
  })();
  tmntag.cmd.push(function(){
    tmntag.target(targeting);
    tmntag.placement('3358'); // [tmnp.iMore/article_infinitescroll DESKTOP]
    tmntag.start();
  });
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

    googletag.cmd.push(function() {
      googletag.pubads().setTargeting("site","im").setTargeting("site_contentid","im-46512").setTargeting("category",["news","apps"]).setTargeting("pageid","46512").setTargeting("tag",["twitter"]).setTargeting("ctype","Article").setTargeting("stype","Edito");
      
    });
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  targeting = {};
  targeting['stype'] = 'Edito';
  targeting['ctype'] = 'Article';
  targeting['requestSource'] = 'GPT';

  var terms = $('meta[name=terms]');
  if(terms.length) {
    terms = terms.attr("content");

    var kw = $.map(terms.split(","), function(s) {
      s = s.toLowerCase();
      s = s.replace(/[^0-9a-zA-Z ]/g,"");
      s = s.replace(/ /g,"_");
      s = s.replace(/_+/g,"_");
      s = s.replace(/^_/,"");
      s = s.replace(/_$/,"");
      return s;
    });
    if(kw.length) targeting['kwvt'] = kw.slice(0);
    kw.push('im-46512');
    if(kw.length) targeting['kw'] = kw;
  }
//--><!]]>
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__kEscKj8kQAkmRx4D3CM3uBnu_-lInoKfyp_-si7vzHI__4RACSFC4pzg2VCnKmcjEsIgzEz7SH2dpieMocGZQf-0__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"mbn2_twig","theme_token":"XhRVfkzCVJsluQ4YKYqvukdXZATZJPc6U1spxx4JTyo","jquery_version":"1.10","css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"sites\/all\/modules\/cache_consistent\/css\/cache_consistent.css":1,"modules\/comment\/comment.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"sites\/all\/modules\/mollom\/mollom.css":1,"modules\/node\/node.css":1,"sites\/all\/modules\/picture\/picture_wysiwyg.css":1,"modules\/search\/search.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/video_filter\/video_filter.css":1,"sites\/all\/modules\/workflow\/workflow_admin_ui\/workflow_admin_ui.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/panels\/css\/panels.css":1,"sites\/all\/modules\/rate\/rate.css":1,"sites\/all\/modules\/purch\/purch.css":1,"0":1,"https:\/\/cdnjs.cloudflare.com\/ajax\/libs\/fancybox\/3.1.25\/jquery.fancybox.min.css":1,"sites\/all\/modules\/mbn_common\/mbn_common.css":1,"sites\/all\/modules\/mbn_common\/css\/site_footer.css":1,"sites\/all\/libraries\/mediaelementjs\/mediaelementplayer.min.css":1,"sites\/all\/themes\/mbn2_twig\/css\/base-im.css":1,"sites\/all\/modules\/mbn_filter_tokens\/mbn_filter_tokens.css":1,"sites\/all\/modules\/mbn_notify\/follow\/follow.css":1,"sites\/all\/themes\/mbn2_twig\/css\/article-im.css":1,"sites\/all\/themes\/mbn2_twig\/css\/custom-im.css":1,"sites\/all\/themes\/mbn2\/css\/global.css":1,"sites\/all\/themes\/mbn2\/css\/global-node.css":1},"js":{"sites\/all\/modules\/picture\/picturefill\/picturefill.min.js":1,"sites\/all\/modules\/picture\/picture.min.js":1,"sites\/all\/modules\/jquery_update\/replace\/jquery\/1.10\/jquery.min.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/jquery_update\/replace\/ui\/external\/jquery.cookie.js":1,"sites\/all\/modules\/jquery_update\/replace\/misc\/jquery.form.min.js":1,"misc\/ajax.js":1,"sites\/all\/modules\/jquery_update\/js\/jquery_update.js":1,"sites\/all\/modules\/fb_instant_articles\/modules\/fb_instant_articles_display\/js\/admin.js":1,"sites\/all\/themes\/mbn2_twig\/js\/header-top.js":1,"sites\/all\/themes\/mbn2_twig\/js\/header-drawer.js":1,"sites\/all\/themes\/mbn2_twig\/js\/article-comments.js":1,"sites\/all\/modules\/affiliate_links\/affiliate_links.js":1,"sites\/all\/modules\/affiliate_links\/affiliate_links_xuuid.js":1,"sites\/all\/modules\/gpt\/gpt.js":1,"sites\/all\/modules\/mbn_filter_tokens\/mbn_filter_tokens.js":1,"sites\/all\/themes\/mbn2_twig\/js\/share.js":1,"sites\/all\/modules\/purch\/purch.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"sites\/all\/libraries\/spe\/spe-store.js":1,"sites\/all\/modules\/mbn_common\/js\/youtube.js":1,"sites\/all\/libraries\/fontfaceobserver\/fontfaceobserver.js":1,"sites\/all\/libraries\/jquery.appear-0.3.7\/jquery.appear.js":1,"sites\/all\/libraries\/jquery.plugins\/jquery.cookie.min.js":1,"https:\/\/cdnjs.cloudflare.com\/ajax\/libs\/fancybox\/3.1.25\/jquery.fancybox.min.js":1,"sites\/all\/libraries\/jquery.plugins\/jquery.backgroundSize.min.js":1,"sites\/all\/libraries\/galleria\/galleria-1.5.7.min.js":1,"sites\/all\/modules\/mbn_common\/js\/mbn_common.js":1,"sites\/all\/modules\/mbn_common\/js\/mbn_common_footer.js":1,"sites\/all\/libraries\/mediaelementjs\/mediaelement-and-player.min.js":1,"misc\/progress.js":1,"sites\/all\/modules\/visor_header2\/js\/header.js":1,"sites\/all\/modules\/mbn_notify\/follow\/follow.js":1,"sites\/all\/modules\/mbn_notify\/mbn_notify.js":1,"sites\/all\/libraries\/waypoints-4.0.0\/jquery.waypoints.js":1,"sites\/all\/themes\/mbn2_twig\/js\/article.js":1,"sites\/all\/themes\/mbn2_twig\/js\/sidebar.js":1,"sites\/all\/libraries\/jquery.lazyloadxt\/jquery.lazyloadxt.min.js":1,"sites\/all\/themes\/mbn2_twig\/js\/font-loader.js":1}},"video_filter":{"url":{"ckeditor":"\/video_filter\/dashboard\/ckeditor"},"instructions_url":"\/video_filter\/instructions","modulepath":"sites\/all\/modules\/video_filter"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip","trackDomainMode":1},"mbn_common":{"author":"Dan Thorp-Lancaster"}});
//--><!]]>
</script>
<script type='text/javascript' src='https://passport.mobilenations.com/js/cluetip/jquery.cluetip.min.js?v41'></script>
<script type='text/javascript' src='https://passport.mobilenations.com/content/topbar/nationsbar.js?v41'></script>
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-46512 node-type-article node-format-article section-article cc-us im geo-US mona45">
<div id="skip-link">
<a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
</div>
<script>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</script> <div class="region region-site-header">
<div class="header-top header-top--default   header-top--navagation-items-2">
<div class="header-top-inner">
<div class="header-top-inner2">
<button class="header-top__drawer-toggle ir js-header-drawer-toggle js-header-drawer-toggle--nav">
<i class="fas fa-bars"></i>
</button>
<a href="/" rel="index" class="header-top__brand ir "></a>
<nav class="header-top__navigation">
<ul class="header-top__navigation-list">
<li class="header-top__navigation-item">
<a href="https://forums.imore.com/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-top__navigation-link">
<i class="fas fa-comments"></i><span>Forums</span>
</a>
</li>
<li class="header-top__navigation-item">
<a href="https://store.imore.com/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-top__navigation-link">
<i class="fas fa-shopping-cart fa-flip-horizontal"></i><span>Shop</span>
</a>
</li>
<li class="header-top__navigation-item header-top__navigation-item--search">
<button class="header-top__search-button js-header-top-search-toggle">
<i class="fas fa-search"></i>
<span>Toggle Search</span>
</button>
<form id="form-main-search" class="header-top__navigation-search-form" action="/search">
<button type="submit"></button>
<input type="text" id="main-search" name="query" placeholder="Search...">
</form>
</li>
</ul>
</nav>
</div>
</div>
</div>
<section class="block block-topic" aria-hidden="true">
<ul class="block-topic__topics-list">
<li class="block-topic__topics-item">
<a href="https://www.imore.com/ipad-6" title="iPad (6th Gen)" class="block-topic__topics-btn">
iPad (6th Gen)
</a>
</li>
<li class="block-topic__topics-item">
<a href="https://forums.imore.com?utm_source=im&utm_medium=topicbar&utm_campaign=navigation" title="Forums" class="block-topic__topics-btn">
Forums
</a>
</li>
<li class="block-topic__topics-item">
<a href="/iphone-x" title="iPhone X" class="block-topic__topics-btn">
iPhone X
</a>
</li>
<li class="block-topic__topics-item">
<a href="/iphone-8" title="iPhone 8" class="block-topic__topics-btn">
iPhone 8
</a>
</li>
<li class="block-topic__topics-item">
<a href="/apple-watch-series-3-faq" title="Apple Watch Series 3" class="block-topic__topics-btn">
Apple Watch Series 3
</a>
</li>
<li class="block-topic__topics-item">
<a href="/apple-tv-4k" title="Apple TV 4K" class="block-topic__topics-btn">
Apple TV 4K
</a>
</li>
<li class="block-topic__topics-item">
<a href="/ios-11" title="iOS 11" class="block-topic__topics-btn">
iOS 11
</a>
</li>
<li class="block-topic__topics-item">
<a href="https://www.imore.com/pokemon-go" title="Pokemon Go" class="block-topic__topics-btn">
Pokemon Go
</a>
</li>
<li class="block-topic__topics-item">
<a href="/macos-high-sierra" title="macOS High Sierra" class="block-topic__topics-btn">
macOS High Sierra
</a>
</li>
<li class="block-topic__topics-item">
<a href="/ipad-pro" title="Apple iPad Pro" class="block-topic__topics-btn">
iPad Pro
</a>
</li>
</ul>
<div class="block-topic__pencil-ad"><div id='topic-pencil-rt-wrap' class='crumb-ad adunit-wrap adunit-gpt'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='topic-pencil-rt'>
<script>
        googletag.cmd.push(function() {
          gptadslots.push(googletag.defineSlot('/25586680/imore/article', ["fluid",[386,50]], 'topic-pencil-rt').defineSizeMapping(gpt_defaultsizemappings.mapping1())
             .setTargeting('adunit',"header_pencil_ad").setTargeting('site',"im")
            .addService(googletag.pubads()));
        });
        googletag.cmd.push(function() { 
          googletag.display('topic-pencil-rt'); 
        });
      </script>
</div></div>
</div></div>
</section> </div>
<div id='ctBoc'> 
<div id="page-wrap">
<div class="page-header clearfix clearfixb">
<div class="region region-page-header">
<div id='Leaderboard_Header_ATF-wrap-5aeb8b2909097' class='adunit-wrap adunit-purch'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='purch_Y_L_1_1' data-clone-id='' adonis-marker></div>
<script type='text/javascript'>
    if(typeof(tmntag) !== 'undefined'){
      tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_L_1_1',false);});
    }
  </script></div>
</div> </div>
</div>
<div id="page">
<main class="content" id="content" tabindex="0">
<div class="container">
<div class="clearfix">
<div class="element-invisible"><a id="main-content"></a></div>
<div class="region region-content">
<div id="block-system-main" class="block block-system">
<div class="content">
<article class="article article--normal node node-article node-promoted node-cat-news node-cat-apps node-tag-twitter not-ajaxed" id="article-46512" data-nid="46512" data-url="/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log" data-canonical-url="https://www.imore.com/twitter-asks-users-change-passwords-after-bug-exposed-them-internal-log">
<div class="row">
<header class="article-header col-3of3 ">
<span class="article-header__tag">Ruh Roh</span>
<h1 class="article-header__title">Twitter asks users to change passwords after bug exposed them on internal log</h1>
<span class="article-header__intro">The bug in Twitter's hashing process has since been fixed.</span>
<div class="article-header__details">
<div class="article-header__authors">
<span class="article-header__author">
<a href="/author/Dan%20Thorp-Lancaster">Dan Thorp-Lancaster</a>
</span> </div>
<time class="article-header__time" datetime="2018-05-03T16:51:57-04:00" title="Thu, 03 May 2018 16:51:57 -0400">
3 May 2018
</time>
<button class="article-header__comments js-comments-jump">
<i class="fas fa-comments" aria-hidden="true"></i>
0
</button>
</div>
</header>
</div> <div class="row row--no-wrap">
<div class="article-body col-3of3 col-2of3@tablet">
<div class="article-body__section article-body__section--wide"><p><img src="https://www.imore.com/sites/all/themes/mbn2_twig/assets/images/16x9.png" width="1600" height="1021" alt="Twitter asks users to change passwords after bug exposed them on internal log" class="image-xlarge lazy" data-src="/sites/imore.com/files/styles/xlarge/public/field/image/2016/07/072216-twitter-verification-hero.jpg?itok=NZgmRbVT"><noscript><img src="https://www.imore.com/sites/imore.com/files/styles/xlarge/public/field/image/2016/07/072216-twitter-verification-hero.jpg?itok=NZgmRbVT" width="1600" height="1021" alt="Twitter asks users to change passwords after bug exposed them on internal log" class="image-xlarge"></noscript></p></div><div class="article-body__section article-body__section--narrow narrow">
<p class="article-body__drop-character"><a href="/twitter">Twitter</a> today asked <a href="https://blog.twitter.com/official/en_us/topics/company/2018/keeping-your-account-secure.html">all of its users</a> to consider changing their passwords after discovering a bug that caused them to be stored "unmasked in an internal log." </p>
<p>According to Twitter, the bug has been corrected and it has seen "no indication of breach or misuse by anyone" after an investigation.</p>
</div><div class="article-body__section article-body__section--wide"><blockquote class="twitter-tweet" data-cards="hidden" data-lang="en"><p lang="en" dir="ltr" xml:lang="en">We recently found a bug that stored passwords unmasked in an internal log. We fixed the bug and have no indication of a breach or misuse by anyone. As a precaution, consider changing your password on all services where you've used this password. <a href="https://t.co/RyEDvQOTaZ">https://t.co/RyEDvQOTaZ</a></p>&mdash; Twitter Support (@TwitterSupport) <a href="https://twitter.com/TwitterSupport/status/992132808192634881?ref_src=twsrc%5Etfw">May 3, 2018</a></blockquote></div><div class="article-body__section article-body__section--narrow narrow">
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p>The bug itself is related to the hashing function Twitter uses to mask passwords. Twitter says passwords were written to an internal log before the hashing process was completed, leaving them exposed. From Twitter:</p>
</div><div class="article-body__section article-body__section--wide"><blockquote>
<p>We mask passwords through a process called hashing using a function known as bcrypt, which replaces the actual password with a random set of numbers and letters that are stored in Twitter's system. This allows our systems to validate your account credentials without revealing your password. This is an industry standard.</p>
<p>Due to a bug, passwords were written to an internal log before completing the hashing process. We found this error ourselves, removed the passwords, and are implementing plans to prevent this bug from happening again.</p>
</blockquote></div><div class="article-body__section article-body__section--narrow narrow">
<p>Out of caution, Twitter users should reset their password for the service, as well as those for any services using the same password. Now would also be a good time to <a href="/how-set-two-factor-authentication-twitter">start using two-factor authentication</a> if you aren't already.</p>
</div><div id='InArticle_BTF3-wrap-5aeb8b2909da8' class='adunit-wrap adunit-purch'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='purch_N_C_0_2' data-clone-id='' adonis-marker></div>
<script type='text/javascript'>
    if(typeof(tmntag) !== 'undefined'){
      tmntag.cmd.push(function(){ tmntag.adTag('purch_N_C_0_2',false);});
    }
  </script></div>
</div>
</div>
<aside class="sidebar col-3of3 sidebar--fixed col-1of3@tablet" role="complementary">
<div class="sidebar__section">
<div id='Inline_300_ATF_1-wrap-5aeb8b2909be4' class='adunit-wrap adunit-purch'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='purch_Y_R_1_1' data-clone-id='' adonis-marker></div>
<script type='text/javascript'>
    if(typeof(tmntag) !== 'undefined'){
      tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_R_1_1',false);});
    }
  </script></div>
</div>
</div>
<div class="sidebar__section">
<div id='GPT_5aeb8b2909b55-wrap' class='adunit-wrap adunit-gpt'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='GPT_5aeb8b2909b55'>
<script>
        googletag.cmd.push(function() {
          gptadslots.push(googletag.defineSlot('/25586680/imore/article', [[300,285],[300,600],[300,700],[320,50],[320,100],[300,250]], 'GPT_5aeb8b2909b55').defineSizeMapping(gpt_defaultsizemappings.mapping2())
             .setTargeting('adunit',"sidebar_ad").setTargeting('site',"im")
            .addService(googletag.pubads()));
        });
        googletag.cmd.push(function() { 
          googletag.display('GPT_5aeb8b2909b55'); 
        });
      </script>
</div></div>
</div>
</div>
<div class="sidebar__section">
<div id='Inline_300_BTF_2-wrap-5aeb8b2909c75' class='adunit-wrap adunit-purch'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='purch_Y_R_0_1' data-clone-id='' adonis-marker></div>
<script type='text/javascript'>
    if(typeof(tmntag) !== 'undefined'){
      tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_R_0_1',false);});
    }
  </script></div>
</div>
</div>
</aside> </div>
<div class="row">
<footer class="article-meta col-3of3">
<button class="article-meta__comments-toggle js-comments-toggle">
<span>View</span><span>Close</span> Comments (0)
</button>
<ul class="article-meta-tags">
<li><a href="/category/news">News</a></li>
<li><a href="/tag/twitter">Twitter</a></li>
</ul>
</footer> </div>
<div class="row">
<section class="article-comments" id="article-comments-46512">
</section>
</div>
<div class="row">
<section class="article-footer article-footer--taboola col-3of3">
<div id="taboola-below-article-thumbnails-46512"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'thumbnails-a',
    container: 'taboola-below-article-thumbnails-46512',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script> </section>
</div>
<img class="article-vwo-pixel" src="https://dev.visualwebsiteoptimizer.com/c.gif?experiment_id=1&ACCOUNT_ID=315429&GOAL_ID=200&COMBINATION=2&UUID=&CACHE=924093646" />
</article>
<button class="btn btn--load-more js-load-more " aria-label="Load more articles in this section"><span>Load More</span><i class="fas fa-sync-alt fa-spin fa-lg"></i></button>
</div>
</div>
<section class="share">
<ul class="share__list">
<li class="share__item share__item--facebook">
<a class="share__link" href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.imore.com%2Ftwitter-asks-users-change-passwords-after-bug-exposed-them-internal-log?utm_source=im%26utm_medium=facebook%26utm_campaign=social_share%26utm_content=" data-platform="Facebook" target="_blank">
<i class="fab fa-facebook-f fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--twitter">
<a class="share__link" href="https://twitter.com/intent/tweet?text=Twitter+asks+users+to+change+passwords+after+internal+bug+exposed+them+%7C+via+%40&amp;url=https%3A%2F%2Fwww.imore.com%2Ftwitter-asks-users-change-passwords-after-bug-exposed-them-internal-log?utm_source=im%26utm_medium=twitter%26utm_campaign=social_share%26utm_content=" data-platform="Twitter" target="_blank">
<i class="fab fa-twitter fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--google-plus">
<a class="share__link" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.imore.com%2Ftwitter-asks-users-change-passwords-after-bug-exposed-them-internal-log?utm_source=im%26utm_medium=googleplus%26utm_campaign=social_share%26utm_content=" data-platform="GooglePlus" target="_blank">
<i class="fab fa-google-plus-g fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--email">
<a class="share__link" href="mailto:?subject=Twitter%20asks%20users%20to%20change%20passwords%20after%20internal%20bug%20exposed%20them&amp;body=https%3A%2F%2Fwww.imore.com%2Ftwitter-asks-users-change-passwords-after-bug-exposed-them-internal-log?utm_source=im%26utm_medium=email%26utm_campaign=social_share%26utm_content=" data-platform="Email" target="_blank">
<i class="far fa-envelope fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--text">
<a class="share__link share__link--text" href="sms:?&amp;body=Twitter%20asks%20users%20to%20change%20passwords%20after%20internal%20bug%20exposed%20them - https%3A%2F%2Fwww.imore.com%2Ftwitter-asks-users-change-passwords-after-bug-exposed-them-internal-log?utm_source=im%26utm_medium=sms%26utm_campaign=social_share%26utm_content=" data-platform="Text" target="_blank">
<i class="fas fa-comment-dots fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--more">
<a class="share__link js-share-expand" href="#" target="_blank">
<i class="far fa-ellipsis-h fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--reddit share__item--hidden">
<a class="share__link" href="https://reddit.com/submit?title=Twitter+asks+users+to+change+passwords+after+internal+bug+exposed+them&amp;url=https%3A%2F%2Fwww.imore.com%2Ftwitter-asks-users-change-passwords-after-bug-exposed-them-internal-log?utm_source=im%26utm_medium=reddit%26utm_campaign=social_share%26utm_content=" data-platform="Reddit" target="_blank">
<i class="fab fa-reddit-alien fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--pinterest share__item--hidden">
<a class="share__link" href="http://pinterest.com/pin/create/button/?url=<?=$url?>?utm_source=im%26utm_medium=pinterest%26utm_campaign=social_share%26utm_content=" data-platform="Pinterest" target="_blank">
<i class="fab fa-pinterest-p fa-lg fa-fw"></i>
</a>
</li>
</ul>
</section> </div>
</div>
</div>
</main>
<div class="clear"></div>
<div id="banneradspace" align='center'>
<div id='Leaderboard_Footer_BTF-wrap-5aeb8b290fbae' class='adunit-wrap adunit-purch'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='purch_Y_L_0_1' data-clone-id='' adonis-marker></div>
<script type='text/javascript'>
    if(typeof(tmntag) !== 'undefined'){
      tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_L_0_1',false);});
    }
  </script></div>
</div> </div> 
</div> 
</div> 
</div> 
<div class="region region-site-footer">
<nav class="header-drawer header-drawer--secondary js-header-drawer" aria-hidden="true" tabindex="-1">
<div class="header-drawer__inner">
<div class="header-drawer__nav">
<ul class="header-drawer__navigation-list header-drawer__navigation-list--nav">
<li class="header-drawer__navigation-item header-drawer__navigation-item--nav header-drawer__navigation-item--nav-nav">
<button class="header-drawer__navigation-button header-drawer__navigation-button--nav ir js-header-drawer-toggle js-header-drawer-toggle--nav">
<i class="fas fa-bars"></i>
</button>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--nav header-drawer__navigation-item--nav-forum">
<button class="ir js-header-drawer-toggle header-drawer__navigation-button--nav js-header-drawer-toggle--forum">
<i class="fas fa-comments"></i>
</button>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--nav header-drawer__navigation-item--nav-shop">
<button class="header-drawer__navigation-button header-drawer__navigation-button--nav ir js-header-drawer-toggle js-header-drawer-toggle--shop">
<i class="fas fa-shopping-cart fa-flip-horizontal"></i>
</button>
</li>
</ul>
</div>
<div class="header-drawer__topics">
<ul class="header-drawer__navigation-list header-drawer__navigation-list--main">
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/rumors" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Rumors
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/iphone" class="header-drawer__navigation-link header-drawer__navigation-link--main">
iPhone
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/ipad" class="header-drawer__navigation-link header-drawer__navigation-link--main">
 iPad
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/apple-watch" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Watch
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/apple-tv" class="header-drawer__navigation-link header-drawer__navigation-link--main">
TV
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/mac" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Mac
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/how-to" class="header-drawer__navigation-link header-drawer__navigation-link--main">
How To
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/apps" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Apps & Games
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/accessories" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Accessories
</a>
</li>
</ul>
<h3 class="header-drawer__navigation-title">Other Categories</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--secondary">
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="https://forums.imore.com?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Forums
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/analysis" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Analysis
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/reviews" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Reviews
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/deals" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Deals
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/newsletter" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Newsletter
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/contests" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Contests
</a>
</li>
</ul>
</div>
<div class="header-drawer__sites">
<ul class="header-drawer__navigation-list header-drawer__navigation-list--sites">
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites ac">
<a href="http://www.androidcentral.com?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
Android Central
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites wp">
<a href="http://www.windowscentral.com?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
Windows Central
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites im">
<a href="http://www.imore.com" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
iMore
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites cb">
<a href="http://crackberry.com?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
CrackBerry
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites cc">
<a href="http://www.cordcutters.com?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
CordCutters
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites mm">
<a href="http://youtube.com/c/themrmobile?utm_source=im&utm_medium=drawer&utm_campaign=navigation&sub_confirmation=1" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
MrMobile
</a>
</li>
</ul>
</div>
<div class="header-drawer__forum">
<h3 class="header-drawer__navigation-title">Forums and Discussions</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--forum">
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iMore Forums
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ask-question/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Ask a Question
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/search.php?utm_source=im&utm_medium=navbar&utm_campaign=navigation&do=getnew" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
New Posts
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/activity.php?utm_source=im&utm_medium=navbar&utm_campaign=navigation&sortby=popular&show=all&time=week" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Trending Discussions
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/rumored-apple-hardware/?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Rumored Hardware
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-x/?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone X
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-8/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone 8
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-7-plus/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone 7 Plus
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-7/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone 7
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ipad/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPad
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ios-11/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iOS 11
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ios-10/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iOS 10
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/apple-watch-series-2/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apple Watch Series 2
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/apple-watch-series-3/?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apple Watch Series 3
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/apple-watch/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apple Watch
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/macbook-pro/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
MacBook Pro
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-apps-games/?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apps & Games
</a>
</li>
</ul>
</div>
<div class="header-drawer__shop">
<h3 class="header-drawer__navigation-title">Shop</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--shop">
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/deals.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
HOT ACCESSORY DEAL$
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://digitaloffers.imore.com?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Digital Offers
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Best sellers
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-new.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
New releases
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-cases.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Cases and covers
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/cradles.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Chargers and cables
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-batteries.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Battery packs
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-screen-protectors.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Screen Protectors
</a>
</li>
</ul>
</div>
<div class="header-drawer__dev">
<h3 class="header-drawer__navigation-title">Dev Center</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--dev">
</ul>
</div>
<div class="header-drawer__tools">
<div class="header-drawer__passport">

<span class="header-drawer__passport-links">
<span class="fa-stack fa-lg">
<i class="fas fa-circle fa-stack-2x"></i>
<i class="fas fa-sign-in-alt fa-stack-1x fa-inverse"></i>
</span>
<a href="https://passport.mobilenations.com/?u=eNpVjsFuwyAQRP-FO7EhQOTNMVI_oO3dXCKwsVGMsVgsV6r674W2l95mRzP7xoKBTwIhgWX0IaMr454XdiUYzsDmUjaCrjuO4xRiynhyKXblCKVg5paexHfCTNzNdp2Qb5boSNkTt4-WuO8Tx48tEXpeZow8rNVe7cKXNDWIMP_BY_S6-ec6yA_o5cVpo5Xxg1a9kEIqYZRQOIiHaDkFjELBJmsjxCbqS-tKSGs7NLCKCj9a9MBub68v43t6YnXu0P-5dWPI9rcTQGhZaRcj9fXrG2moXFz6">Log in</a>
or
<a href="https://passport.mobilenations.com/?utm_source=im&utm_medium=signup&utm_campaign=passport&u=eNpVjsFuwyAQRP_Fd2JDgNSbY6V-QNu7RWBjoxhjsVhUqvrvhbaX3mZHM_vGgIZPAi6gS-h8QpunI63dlWA8Q7fkvBP0fSnl5ENMeLIx9Ln4nDExQw9iB2FcImYXs83IdkNUYnLEzL0lbsfM8GOPhI7lBQPzW7U3s7I1zg3C9X_wFJxq_rkOciM6cbFKK6ndqOTABReSa8kljvzOW05CRz5jk7XhQxP1pbHZx60dT-3_7Klif3gDdM9vry_Te3xgDdxg-HPrTJ_Mb80DV6ICL1qo69c3nDteSQ%2C%2C">Sign up</a>
</span>

</div>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--social">
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="https://google.com/+imore?utm_source=im&utm_medium=burger&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-google-plus-g"></i><span>g+</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://www.twitter.com/imore?utm_source=im&utm_medium=burger&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-twitter"></i><span>t</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://www.facebook.com/imorecom?utm_source=im&utm_medium=burger&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-facebook-f"></i><span>f</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://www.youtube.com/subscription_center?utm_source=im&utm_medium=burger&utm_campaign=navigation&add_user=imorevideo" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-youtube"></i><span>y</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://instagram.com/imoregram?utm_source=im&utm_medium=burger&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-instagram"></i><span>i</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="https://www.imore.com/rss.xml?utm_medium=burger&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fas fa-rss"></i><span>r</span>
</a>
</li>
</ul>
<ul class="header-drawer__navigation-list header-drawer__navignation-list--cta">
<li class="header-drawer__navigation-item header-drawer__nagigation-item--cta">
<a href="mailto:imoretips@imore.com" class="header-drawer__navigation-link header-drawer__navigation-link--cta">
<i class="fas fa-paper-plane"></i><span>Tip us on News</span>
</a>
</li>
</ul>
</div>
</div>
</nav>
<footer class="footer">
<section class="footer__brand">
<div class="container">
<a href="https://www.mobilenations.com/" class="footer__logo">Mobile Nations</a>
<strong class="footer__tagline">
<span>500M</span>
Consumers Reached Yearly
</strong>
</div>
</section>
<section class="footer__copyright">
<div class="container">
<ul class="footer__nav">
<li class="footer__nav-item">Copyright 2018 Mobile Nations</li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/terms-conditions">Terms and Conditions</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/privacy-policy">Privacy Policy</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/privacy-policy#your-choices">Your Ad Choices</a></li>
<li class="footer__nav-item">Careers: <a href="http://breaksclusive.recruiterbox.com/">Writer</a> | <a href="https://mobilenations.recruiterbox.com/">Dev</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/licensing-reprints/">Licensing</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/external-links">External Links Disclosure</a></li>
</ul>
<a href="http://purch.com/advertise/" class="footer__partner-logo">
<span>Advertising Partner</span>
</a>
</div>
</section>
</footer>

</div>
<script>
        $('.glade').each(function() {
          var data = $(this).data('json');
          $.extend(data.targeting,window.targeting);
          $(this).attr('data-json', JSON.stringify(data));
          $(this).data('json',data);
        });  
      </script>
<script src='https://securepubads.g.doubleclick.net/static/glade.js' async=''></script> <script type="text/javascript" src="http://tags.crwdcntrl.net/c/12464/cc.js?ns=_cc12464" id="LOTCC_12464"></script>
<script type="text/javascript" language="javascript">_cc12464.bcp();</script> <script>
  (function (w,d,t) {
  _ml = w._ml || {};
  _ml.eid = '58180';
  var s, cd, tag; s = d.getElementsByTagName(t)[0]; cd = new Date();
  tag = d.createElement(t); tag.async = 1;
  tag.src = 'https://ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth();
  s.parentNode.insertBefore(tag, s);
  })(window,document,'script');
  </script><div id='GPT_5aeb8b29184ec-wrap' class='adunit-wrap adunit-gpt'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='GPT_5aeb8b29184ec'>
<script>
        googletag.cmd.push(function() {
          gptadslots.push(googletag.defineOutOfPageSlot('/25586680/imore/article', 'GPT_5aeb8b29184ec')
             .setTargeting('adunit',"interstitial").setTargeting('site',"im")
            .addService(googletag.pubads()));
        });
        googletag.cmd.push(function() { 
          googletag.display('GPT_5aeb8b29184ec'); 
        });
      </script>
</div></div>
</div>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N9VHS7"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N9VHS7');</script>
<script type="text/javascript">
  var spe_url = document.domain;
  var spe_url_array = new Array;
  spe_url_array = spe_url.split(".");
  spe_url_array.reverse();
  var spe_root_url = spe_url_array[1] + '.' + spe_url_array[0];

  if (spe_url_array[2]) {
    var spe_segments = spe_url_array[1] + '.' + spe_url_array[2];
  } else {
    var spe_segments = spe_url_array[1];
  }

</script>
<script type="text/javascript">
  var _qevents = _qevents || [];

  (function() {
  var elem = document.createElement('script');
  elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
  elem.async = true;
  elem.type = "text/javascript";
  var scpt = document.getElementsByTagName('script')[0];
  scpt.parentNode.insertBefore(elem, scpt);
  })();


  _qevents.push({
    qacct:"p-ebutdjFEkjMk-",
    labels: spe_segments
  },
  {
    qacct:"p-8bC03lZwjgqy2",
    labels: spe_segments
  }
  );
</script>
<noscript>
<div style="display:none;">
  <img src="//pixel.quantserve.com/pixel?a.1=p-ebutdjFEkjMk-&a.2=p-8bC03lZwjgqy2" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035753" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035753&cv=2.0&cj=1" />
</noscript>
<script>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</script><script>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</script>
<script type="text/javascript">
        window._taboola = window._taboola || [];
        _taboola.push({flush: true});
        </script><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1765793593738454&ev=PageView&noscript=1" /><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1765793593738454&ev=ViewContent&noscript=1" /><script type="text/javascript"> 
      try{
        (function(){ 
          var cb = new Date().getTime(); 
          var s = document.createElement("script"); 
          s.defer = true; 
          s.src = "//tag.crsspxl.com/s1.js?d=2127&cb="+cb; 
          var s0 = document.getElementsByTagName("script")[0]; 
          s0.parentNode.insertBefore(s, s0); 
        })();
      }catch(e){}
    </script>
<script type='text/javascript'>
          $('a[href*="//itunes.apple.com"],a[href*="//itun.es"],a[href*="//rover.ebay.com"],a[href*="7293438-11365093"]').addClass('norewrite');
        </script>
<script type='text/javascript'>
        var vglnk = { key: '8ed1f879e224588da0398abad3c283a2' };

        (function(d, t) {
          var s = d.createElement(t); s.type = 'text/javascript'; s.async = true;
          s.src = '//cdn.viglink.com/api/vglnk.js';
          var r = d.getElementsByTagName(t)[0]; r.parentNode.insertBefore(s, r);
        }(document, 'script'));
        </script><script>
  PARSELY = { };
</script>

<div id="parsely-root" style="display: none">
<div id="parsely-cfg" data-parsely-site="imore.com"></div>
</div>
<script>
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>

<div id="fb-root"></div>
<script>
  (function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.7";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));

  var fbAsyncInitOrg = window.fbAsyncInit;
  window.fbAsyncInit = function() {
    if(typeof(fbAsyncInitOrg)=='function') fbAsyncInitOrg();
    FB.init({
      appId: "213678485361751",
      xfbml: true,
      version    : 'v2.7'
    });

    FB.Event.subscribe('xfbml.ready', function(msg) {   // Log all the ready events so we can deal with them later
      var events = fbroot.data('ready-events');
      if( typeof(events) === 'undefined') events = [];
      events.push(msg);
      fbroot.data('ready-events',events);
    });

    var fbroot = $('#fb-root').trigger('facebook:init');
  };
</script>

<script async='async' type='text/javascript' src='//www.lightboxcdn.com/vendor/d74ebc7c-6bfa-42bd-b88b-9240b4878523/lightbox_inline.js'></script>
<div class='adunit' id='purch_Y_O_1_1' data-dimensions='1x1'></div><div class='adunit' id='purch_Y_P_1_1'></div> <script type="text/javascript">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</script> <script type="text/javascript" async defer src="http://ps.eyeota.net/pixel?pid=1mpv4m0&t=ajs&sid=imore&interest=news"></script><script type="text/javascript">

  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  var spe_root_url = document.domain.match(/[^\.]+\.[^\.]+$/)[0];
  ga('create', 'UA-4245582-4', "." + spe_root_url, 'global', {
    allowLinker: true
  });
  ga("global.set", "dimension1", "full");
  ga("global.set", "dimension2", "News");
  ga("global.set", "dimension3", "true");
  ga("global.set", "dimension4", "C:article,S:legacy,B:w300");
  ga('global.require', 'linkid');
  ga('global.require', 'linker');
  ga('global.linker:autoLink', ["crackberry.com","androidcentral.com","imore.com","windowscentral.com","mobilenations.com","vrheads.com","thrifter.com","teslacentral.com"]);
  ga('global.send', 'pageview');
  setTimeout("ga('global.send','event','NoBounce','Over 20 seconds')",20000);
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__fCruuIeVMFV8Xga1V6YtXH_t4d4qyL1HV2HmXQ1N_Zk__y3uJNjMrk-UUz9riUnY4jl6wIVGTcQKJb32xDfioJfc__jm2hKTGc75TG8STVEazRGCIoIhKVew6q1EZrc6CBMlM.js" async="async"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
$('audio').mediaelementplayer();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','twitter-wjs');
//--><!]]>
</script>
</body>
</html>
