<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" version="XHTML+RDFa 1.0" dir="ltr" xmlns:content="http://purl.org/rss/1.0/modules/content/" xmlns:dc="http://purl.org/dc/terms/" xmlns:foaf="http://xmlns.com/foaf/0.1/" xmlns:og="http://ogp.me/ns#" xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#" xmlns:sioc="http://rdfs.org/sioc/ns#" xmlns:sioct="http://rdfs.org/sioc/types#" xmlns:skos="http://www.w3.org/2004/02/skos/core#" xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
<head profile="http://www.w3.org/1999/xhtml/vocab">
<!--[if IE]><![endif]-->
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta http-equiv="x-dns-prefetch-control" content="on" />
<link rel="dns-prefetch" href="//www.imore.com" />
<!--[if IE 9]>
<link rel="prefetch" href="//www.imore.com" />
<![endif]-->
<script>
    /* Check for email addresses in fragment...if found, then completely remove it*/
    if(window.location.hash.match(/(.*?)([\w.+-]+(@|%40)[a-z\d.-]+\.[a-z]{2,})([^a-z\d.-].*|$)/i)) {
      window.location.hash = "";
    }
  </script> <script type="application/ld+json">
    {
    "@context": "http://schema.org",
    "mainEntityOfPage": "https://www.imore.com/wwdc-2018-so-much-more-keynote",
    "@type": "NewsArticle",
    "headline": "WWDC 2018: So much more than a keynote",
    "url": "https://www.imore.com/wwdc-2018-so-much-more-keynote",
    "datePublished": "2018-06-08T16:12:27+0000",
    "dateCreated": "2018-06-08T16:12:27+0000",
    "dateModified": "2018-06-08T16:20:08+0000",
    "author": {
        "@type": "Person",
        "name": "Rene Ritchie"
    },
    "creator": "Rene Ritchie",
    "thumbnailUrl": "https://www.imore.com/sites/imore.com/files/styles/thumbnail/public/field/image/2018/06/wwdc-2018-iphone.jpg?itok=X9SZRy6t",
    "keywords": [
        "wwdc",
        "wwdc 2018"
    ],
    "articleSection": "Opinion",
    "image": [
        "https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2018/06/wwdc-2018-iphone.jpg?itok=LNOIsloQ"
    ],
    "publisher": {
        "@type": "Organization",
        "name": "iMore",
        "logo": {
            "@type": "ImageObject",
            "url": "https://www.imore.com/sites/imore.com/files/im-amp-logo_0.png",
            "width": null,
            "height": null
        }
    }
}
  </script><meta name="msapplication-tooltip" content="iMore" />
<meta property="article:section" content="article" />
<meta property="article:tag" content="Opinion" />
<meta property="article:tag" content="WWDC" />
<meta property="article:tag" content="Vector" />
<meta property="article:tag" content="Industry Analysis" />
<meta property="article:tag" content="WWDC 2018" />
<link rel="alternate" href="android-app://com.imore.app/https/www.imore.com/wwdc-2018-so-much-more-keynote" />
<meta name="viewport" content="width=1024" />
<link rel="amphtml" href="https://www.imore.com/wwdc-2018-so-much-more-keynote?amp" />
<meta name="msapplication-name" content="iMore" />
<meta name="msapplication-navbutton-color" content="#f8d509" />
<meta name="msvalidate.01" content="21BE5B9D4A670657156555D9E8E78D8D" />
<meta name="msapplication-TileColor" content="#f8d509" />
<meta name="msapplication-square70x70logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/tiny.png" />
<meta name="msapplication-square150x150logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/square.png" />
<meta name="msapplication-wide310x150logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/wide.png" />
<meta name="msapplication-square310x310logo" content="https://www.imore.com/sites/imore.com/files/images/tiles/large.png" />
<meta name="msapplication-notification" content="frequency=30;polling-uri=https://www.imore.com/live-tile/0;polling-uri2=https://www.imore.com/live-tile/1;polling-uri3=https://www.imore.com/live-tile/2;polling-uri4=https://www.imore.com/live-tile/3;polling-uri5=https://www.imore.com/live-tile/4; cycle=1" />
<meta name="theme-color" content="#ffd600" />
<meta name="terms" content="Opinion,WWDC,Vector,Industry Analysis,WWDC 2018" />
<link rel="apple-touch-icon" sizes="57x57" href="https://www.imore.com/sites/imore.com/files/images/icons/apple-touch-57x57.png" />
<link rel="apple-touch-icon" sizes="72x72" href="https://www.imore.com/sites/imore.com/files/images/icons/apple-touch-72x72.png" />
<link rel="apple-touch-icon" sizes="114x114" href="https://www.imore.com/sites/imore.com/files/images/icons/apple-touch-114x114.png" />
<meta property="article:published_time" content="2018-06-08T12:12:27-04:00" />
<meta property="og:site_name" content="iMore" />
<meta property="og:type" content="article" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="fb:pages" content="230016313741478" />

<script>
    !function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
    n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
    document,'script','https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '1674633419534068');
    fbq('track', 'PageView');
    </script>
<noscript><img height="1" width="1" style="display:none"
    src="https://www.facebook.com/tr?id=1674633419534068&ev=PageView&noscript=1"
    /></noscript>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/mobilenations1-network/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script><link href="//www.windowscentral.com" rel="dns-prefetch" />
<link href="//www.androidcentral.com" rel="dns-prefetch" />
<link href="//crackberry.com" rel="dns-prefetch" />
<link href="//www.imore.com" rel="dns-prefetch" />
<link href="//www.vrheads.com" rel="dns-prefetch" />
<link href="//www.thrifter.com" rel="dns-prefetch" />
<link href="//www.modmy.com" rel="dns-prefetch" />
<link href="//www.cordcutters.com" rel="dns-prefetch" />
<link href="//forums.imore.com" rel="dns-prefetch" />
<link href="//passport.mobilenations.com" rel="dns-prefetch" />
<meta name="twitter:site" content="@iMore" />
<meta name="twitter:title" content="WWDC 2018: So much more than a keynote" />
<meta name="twitter:domain" content="https://www.imore.com" />
<meta name="twitter:image" content="https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2018/06/wwdc-2018-iphone.jpg?itok=LNOIsloQ" />
<meta name="twitter:app:name:googleplay" content="iMore" />
<meta name="twitter:app:id:googleplay" content="com.imore.app" />
<meta name="twitter:app:url:googleplay" content="https://www.imore.com/wwdc-2018-so-much-more-keynote" />
<meta name="twitter:creator:id" content="10194392" />
<meta name="twitter:description" content="Once the spotlight leaves the keynote stage, it shifts to developers, and the real WWDC begins." />
<meta property="og:title" content="WWDC 2018: So much more than a keynote" />
<meta property="og:description" content="Once the spotlight leaves the keynote stage, it shifts to developers, and the real WWDC begins." />
<meta property="og:url" content="https://www.imore.com/wwdc-2018-so-much-more-keynote" />
<meta property="og:image" content="https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2018/06/wwdc-2018-iphone.jpg?itok=LNOIsloQ" />
<meta name="description" content="Once the spotlight leaves the keynote stage, it shifts to developers, and the real WWDC begins." />
<link rel="image_src" href="https://www.imore.com/sites/imore.com/files/styles/large/public/field/image/2018/06/wwdc-2018-iphone.jpg?itok=LNOIsloQ" />
<link rel="canonical" href="https://www.imore.com/wwdc-2018-so-much-more-keynote" />
<title>WWDC 2018: So much more than a keynote | iMore</title>
<link rel="alternate" type="application/rss+xml" title="iMore RSS" href="/rss.xml" />
<link type="text/css" rel="stylesheet" href="/sites/imore.com/files/advagg_css/css__mIXYJfy8z9-kQANJD2bs8TONudwFWE5gBpBjUD1b4JM__tWerGaJHFEkjsTCOR5pJxYvHTGlwQFNHV6FYbXJawFc__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.css" media="all" />
<style type="text/css" media="all">
/* <![CDATA[ */
.async-hide{opacity:0 !important}

/* ]]> */
</style>
<link type="text/css" rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.1.25/jquery.fancybox.min.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/imore.com/files/advagg_css/css__C9NntCaVunhL9_EZeGGjw0ECLU4xkoNiINiNF5i3nKo__uIOxBsRst78RvQxOQzoYLP6d_s0nfsuWQ-se116w7es__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.css" media="all" />
<link type="text/css" rel="stylesheet" href="/sites/imore.com/files/advagg_css/css__emDGL7ELG26TbATw8aEDLbN8OgFOe5nAFtOjEDSOdic__2F8raJe7tXJ3ilJyU4UGTzxyqb2__rF_HsrCereMH5U__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.css" media="screen" />
<link rel='stylesheet' type='text/css' href='https://passport.mobilenations.com/css/profile-popup.css?v41' />
<link rel='stylesheet' type='text/css' href='https://passport.mobilenations.com/js/cluetip/jquery.cluetip.css?v41' />
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__ylYFckzD6I-hIS2fSrkgdOuhRGy6qJ9mCP9zsuSfPmA__talCaqG1HXIxJHCQFMFATq82oDC8GO-NeuD3Vn1hliA__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__52ZGpB_C6NP-K_0i-Kq9dylmkXA4U-taF9wS9maDsOI__1oI38DsOeIfPg_RP8R8fdcP0GyyrwOBszS6tlxx0I3U__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
$ = jQuery;
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var _vwo_code=(function(){
var account_id=315429,
settings_tolerance=2000,
library_tolerance=1500,
use_existing_jquery=false,
f=false,d=document;return{use_existing_jquery:function(){return use_existing_jquery;},library_tolerance:function(){return library_tolerance;},finish:function(){if(!f){f=true;var a=d.getElementById('_vis_opt_path_hides');if(a)a.parentNode.removeChild(a);}},finished:function(){return f;},load:function(a){var b=d.createElement('script');b.src=a;b.type='text/javascript';b.innerText;b.onerror=function(){_vwo_code.finish();};d.getElementsByTagName('head')[0].appendChild(b);},init:function(){settings_timer=setTimeout('_vwo_code.finish()',settings_tolerance);this.load('//dev.visualwebsiteoptimizer.com/j.php?a='+account_id+'&u='+encodeURIComponent(d.URL)+'&r='+Math.random());var a=d.createElement('style'),b='body{opacity:0 !important;filter:alpha(opacity=0) !important;background:none !important;}',h=d.getElementsByTagName('head')[0];a.setAttribute('id','_vis_opt_path_hides');a.setAttribute('type','text/css');if(a.styleSheet)a.styleSheet.cssText=b;else a.appendChild(d.createTextNode(b));h.appendChild(a);return settings_timer;}};}());_vwo_settings_timer=_vwo_code.init();
//--><!]]>
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__kyxhTyx1CsJNcz2J5747UYzW5Iu_N8U5cv1t_BoIi5M__qqChy4qn9Ri8ePNHRsszl4LjR0nsnZgT2tQXOgDcDmI__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i["GoogleAnalyticsObject"]=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,"script","https://www.google-analytics.com/analytics.js","ga");ga("create", "UA-2017486-7", {"cookieDomain":".imore.com"});ga("set", "dimension1", "full");ga("set", "dimension2", "article");ga("set", "dimension3", "true");ga("set", "dimension4", "C:article,S:legacy,B:w1000");ga('require', 'linkid');ga("send", "pageview");setTimeout("ga('send','event','NoBounce','Over 20 seconds')",20000);
//--><!]]>
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__XtkK5Cb8BZxIDJldA3NdtN7G_81D7PKCkk54HCZVtiA__0UwW45_zKgbsvJqfhu9oDCho7xAo4MNAfcf5QNldsws__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.js"></script>
<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/fancybox/3.1.25/jquery.fancybox.min.js"></script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__TVYqXtaCXvxXnYs-pUdkGoDE2EUXscxjIhbNs1mfung__z9EL_o0SfP-9z5zz8061RWj_MJ6Gjndo_8qpTruc3aw__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.js"></script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__Ls7xyOQwv3P3pY93ObUOTbwkdG05i2DK4T9rFTLcTVE__JXQqSgi5bfiMbxpfeId2Jt8JPa_HqLUoi3eOfGHLvWk__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.js" defer="defer"></script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__pydajIqUZaN0SOV3RX_rZqz6lTMDkJ_5AkjWUECKULU__B8y_8iSY06Qi5JLuWkiTsODXQPMSzUTh1IOxdhCSOUM__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  $(function() {
    if(!$.lazyLoadXT) { // If the library didn't load, maybe adblockers are enabled?  Just show all imgs
      $('img.lazy').each(function() {
        $(this).attr('src',$(this).attr('data-src'));
      });
    }
  });
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      if (typeof(mbn_config) === 'undefined') var mbn_config = {};
      mbn_config = $.extend(true, mbn_config, {"pp_register":"https:\/\/passport.mobilenations.com\/?u=eNpVjs1ugzAQhF8l4lA1BxIwYPBGUaVUitRDL23uyJgNWIkx8o9oVfXda9Neepv5dnd2OFD4spATSAz20qBwrTf35BBYkUMyOjdb2O-XZdlJpQ3uhFbB9VwiJVnepFanyosxjaP0hp-TdvjknWqt9kbg8YrYd95MaB5cIlXhh1crXb3gauZymI7nQGBzGfFlHvWEp7seNo_yNaRu1y70f79W9VXkRehdU9qUVBBKyrznpCszRitkQXSE1VcW90pIrHQYZbiQKooQyYWTeoqmifmDtA7N-i-D5Pn97dxe9A3DQgfZH8WPWRr-eyYhr0hTsrpmxeH7B6xoa3c,","pp_login":"https:\/\/passport.mobilenations.com\/?u=eNpVjs1OwzAQhF-l8gHBIW3sJE68VYUEUiUOXFyg98hxto3VOo4cWwEh3h07cOE28-3PjAQOXzNQBsRhrx0q3wZ3I_vICgpk8H6aYbdblmWrjXW4VdZE16uM5bTJZpuZoIYsjbIrfo7W42Pwpp1tcAoPZ8S-C25Ed5eoiRnBrHT1SppJ6st4OEYCm9OAL9NgR3y62cvmXr_Grw9rF_6_X2v6KvFcIvauOW9KrhhnJe0l68pcXPAKRRQdE_VZpL0SyKw9JhkvtElcIr6Uyms7JlMBiZF61TQH8vz-dmxP9oqRdJD_UfyYtJO_NxpoxZpS1LUo9t8_UoFqKA,,","pp_social":{"fb":"https:\/\/passport.mobilenations.com\/?u=eNpVjk9PhDAQxb_KhoPRA7tQoNBuNiaabOLBi-6dlDIsDVuG9E_QGL-7LXrx9uY38-Y9wSn_sjxcJzwx0CsD0rXe3JJjYEXOk9G5xfLDYV3XvdJoYC9Rh6mXKcnyJrWYai_HNK7SCT5ndPDonW4teiPhNFww9J03M5i7SHXI8Hqj2yyFXoS6zqdzIHx3GeFlGXGGpxted_fqNXx92LrQ__1a3VeRF6F3TWlTUkkoKfNekK7MGK2ABdERVg8s3pU8scpBlMGhdBThpZBO4bwFBGwttoOQ0CFOG8t48vz-dm4vOEG46nj2R-FjUUb8ehXPK9KUrK5Zcfz-AdZtbSs,","gp":"https:\/\/passport.mobilenations.com\/?u=eNpVjs1ugzAQhF8l4lClBxIwxGBHUaVWitRDL23uyJgNWMEs8o9oVfXda9P20Nvst7M7Izjln5bnhFwnBjplQLrGmzE5BlbkPBmcmy3f75dl2SmNBnYSdZg6mZIsr1OLqfZySOMqvcHHhA4evNONRW8knK5cMF3rzQTmLlIdMrxe6TpLoWeh-ul0DoRvLgM8zwNO8Dhiv9mql_D1fu1C__drdHeIvAi9K0rrkkpCSZl3grRlxugBWBAtYdWVRV_JE6scRBkulI5cIrwU0imc1oAsOCw2PWI_wh95ens9Nxe8QfC0PPul8D4rI34uFc8PpC5ZVbHi-PUN84dsbA,,","ms":"https:\/\/passport.mobilenations.com\/?u=eNpVj09vgzAMxb9KxWHqDrQQIJBU1aRNqrTDLlvvKARTojYY5Y_YNO27L6G77Pb887P9LDjl35bnhFwnBnplQLrWm1tyCKzIeTI6N1u-3y_LslMaDewk6lD1MiVZ3qQWU-3lmMZWeoWvCR08eadbi95IOA5cMH3nzQTmIVIdbni90rWWQs9CXabjKRC-OY_wOo84wfMNL5utegtbH9cs9H--VvdV5EXIXVPalFQSSsq8F6QrM0YrYEF0hNUDi76SXCdWOYgyTCgdRVgppFM43Z8NDoutVtKgxcGtMOPJy8f7qT3jFYKt49kfhc9ZGXEfVjyvSFOyumbF4ecXV2JtyA,,","tw":"https:\/\/passport.mobilenations.com\/?u=eNpVj8tOwzAQRX-lygLBXCJt4iRO7KpCAqkSCzbQfeTY08ZqHUd-KCDEvzMObNjdOfO4dwSn_MvzkvDMgdIOZOiju2V7ZFXJszGE2fPdblmWrTbWwVZag5WSOSnKLvc2N1GOeWrlV_icbIDHGEzvbXQSDmdcMDVEN4G7S9SgRzQrXWspzCz0ZTockfDNaYSXebQTPN3sZXOvX_Hqw5qF_s_XG9UkXmHultKuppJQUpdKkKEuGG2AoRgIa88szdU88zpAkrihTRJ4Usig7bQa4K_e2z4sOgRwKyp49vz-duxP9go4NPDij8LHrJ34XdW8bEhXs7Zl1f77B3IObQM,"},"user":{"pdevice":null,"puid":null,"cuid":"","optin":null,"geo":"US","member":"false"},"site":{"site":"im","name":"iMore","cookie_domain":".imore.com","push_host":"https:\/\/push.mobilenations.com","push_manage_host":"https:\/\/www.imore.com","push_manage_page":"\/follow\/","dev":0}});
      
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if(typeof mbn_config === 'undefined') var mbn_config = {};
  mbn_config = $.extend(true, mbn_config, {"style":"full","site_abbr":"im","mobile":false,"domain":"imore.com","subdomain":"*","platform":"d","show_sidebar":true,"node_type":"article","nid":"46936","section":"article","pp_login":"https:\/\/passport.mobilenations.com\/?u=eNpVjkEOwiAQXDD_wh0tlLa4Hk18gHpvgG6VtIgBTDXGv0urF2-7s5nJKqjhFYFxIAE7G9Ck9h5Gso1QZXZJ6RZhvZ6maWWdD7gy3uWtM5QXTNLoqbubC51PdMDn1VwnnF1W__da11UzL3MTZa20MoXUrO9NVwkpDHKUnJeaSb74Aki031Q2rJuHnFQmWX9dngMy-rNdZlZcMNkdD_v25AfMREPxo_i42aC-jgVWcSk2TbMpt-8P-NlNig,,","pp_register":"https:\/\/passport.mobilenations.com\/?u=eNpVjcsOgjAQRf-FfZGWVxmWJn6AulwnpQzSYKlpa9AY_91W3Libe2fOGQEVvBxQBonFQVmUvrvba9I6KEM3eX9zsNut65oqbSym0uiQBklYRjlxhui7nEhcXJEZn4vxGFla_fs6PZSxz4MTeSV6ITPe03GUQ1nwQlwiQ85Y3lPOvnwBiVObKhBKxyEohfTKLDHw6L8o59F-_2WQ7E_HQ3c2M4aDHrJfi4-bsmLDFNCS8aKp6yZv3x_85k7Z","user":{"pdevice":"","puid":""},"themes":{"full":"\/wwdc-2018-so-much-more-keynote?utm_source=feedburner\u0026utm_medium=feed\u0026utm_campaign=Feed%3A+TheIphoneBlog+%28iMore%29\u0026style=default","mobile":"\/wwdc-2018-so-much-more-keynote?utm_source=feedburner\u0026utm_medium=feed\u0026utm_campaign=Feed%3A+TheIphoneBlog+%28iMore%29\u0026style=mobile"}});
  
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

  // Taboola NEWSROOM SCRIPT 
  window._newsroom = window._newsroom || [];  
    !function (e, f, u) {
      e.async = 1;
      e.src = u; f.parentNode.insertBefore(e, f);
    }(document.createElement('script'),document.getElementsByTagName('script')[0], '//c2.taboola.com/nr/mobilenations1-imore/newsroom.js');
    // END NEWSROOM SCRIPT
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  var tmntag = tmntag || {};
  tmntag.cmd = tmntag.cmd || [];
  tmntag.adunitRenderedCmd = tmntag.adunitRenderedCmd || [];

  (function() {
    var tmnhead = document.createElement('script');
    tmnhead.async = true;
    tmnhead.type = 'text/javascript';
    tmnhead.src = ('https:'==document.location.protocol?'https:':'http:')+'//ads.servebom.com/tmnhead.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(tmnhead, node);
  })();
  tmntag.cmd.push(function(){
    tmntag.target(targeting);
    tmntag.placement('2513'); // [tmnp.iMore/review_infinitescroll DESKTOP]
    tmntag.start();
  });
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

    googletag.cmd.push(function() {
      googletag.pubads().setTargeting("site","im").setTargeting("site_contentid","im-46936").setTargeting("category",["opinion","industry-analysis","vector"]).setTargeting("pageid","46936").setTargeting("tag",["wwdc","wwdc-2018"]).setTargeting("ctype","Article").setTargeting("stype","Edito");
      
    });
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  targeting = {};
  targeting['stype'] = 'Edito';
  targeting['ctype'] = 'Article';
  targeting['requestSource'] = 'GPT';

  var terms = $('meta[name=terms]');
  if(terms.length) {
    terms = terms.attr("content");

    var kw = $.map(terms.split(","), function(s) {
      s = s.toLowerCase();
      s = s.replace(/[^0-9a-zA-Z ]/g,"");
      s = s.replace(/ /g,"_");
      s = s.replace(/_+/g,"_");
      s = s.replace(/^_/,"");
      s = s.replace(/_$/,"");
      return s;
    });
    if(kw.length) targeting['kwvt'] = kw.slice(0);
    kw.push('im-46936');
    if(kw.length) targeting['kw'] = kw;
  }
//--><!]]>
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__kEscKj8kQAkmRx4D3CM3uBnu_-lInoKfyp_-si7vzHI__4RACSFC4pzg2VCnKmcjEsIgzEz7SH2dpieMocGZQf-0__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.extend(Drupal.settings, {"basePath":"\/","pathPrefix":"","ajaxPageState":{"theme":"mbn2_twig","theme_token":"vKQZtLenx9tC5nUU0tZo0nELoiX9Gucuqv0qGfZCJto","jquery_version":"1.10","css":{"modules\/system\/system.base.css":1,"modules\/system\/system.menus.css":1,"modules\/system\/system.messages.css":1,"modules\/system\/system.theme.css":1,"sites\/all\/modules\/cache_consistent\/css\/cache_consistent.css":1,"modules\/comment\/comment.css":1,"sites\/all\/modules\/date\/date_api\/date.css":1,"sites\/all\/modules\/date\/date_popup\/themes\/datepicker.1.7.css":1,"modules\/field\/theme\/field.css":1,"modules\/node\/node.css":1,"sites\/all\/modules\/picture\/picture_wysiwyg.css":1,"modules\/search\/search.css":1,"modules\/user\/user.css":1,"sites\/all\/modules\/video_filter\/video_filter.css":1,"sites\/all\/modules\/workflow\/workflow_admin_ui\/workflow_admin_ui.css":1,"sites\/all\/modules\/views\/css\/views.css":1,"sites\/all\/modules\/ckeditor\/css\/ckeditor.css":1,"sites\/all\/modules\/ctools\/css\/ctools.css":1,"sites\/all\/modules\/panels\/css\/panels.css":1,"sites\/all\/modules\/rate\/rate.css":1,"sites\/all\/modules\/purch\/purch.css":1,"0":1,"https:\/\/cdnjs.cloudflare.com\/ajax\/libs\/fancybox\/3.1.25\/jquery.fancybox.min.css":1,"sites\/all\/modules\/mbn_common\/mbn_common.css":1,"sites\/all\/modules\/mbn_common\/css\/site_footer.css":1,"sites\/all\/libraries\/mediaelementjs\/mediaelementplayer.min.css":1,"sites\/all\/themes\/mbn2_twig\/css\/base-im.css":1,"sites\/all\/modules\/mbn_filter_tokens\/mbn_filter_tokens.css":1,"sites\/all\/modules\/mbn_notify\/follow\/follow.css":1,"sites\/all\/themes\/mbn2_twig\/css\/article-im.css":1,"sites\/all\/themes\/mbn2_twig\/css\/custom-im.css":1,"sites\/all\/themes\/mbn2\/css\/global.css":1,"sites\/all\/themes\/mbn2\/css\/global-node.css":1},"js":{"sites\/all\/modules\/picture\/picturefill\/picturefill.min.js":1,"sites\/all\/modules\/picture\/picture.min.js":1,"sites\/all\/modules\/jquery_update\/replace\/jquery\/1.10\/jquery.min.js":1,"misc\/jquery.once.js":1,"misc\/drupal.js":1,"sites\/all\/modules\/jquery_update\/replace\/ui\/external\/jquery.cookie.js":1,"sites\/all\/modules\/jquery_update\/replace\/misc\/jquery.form.min.js":1,"misc\/ajax.js":1,"sites\/all\/modules\/jquery_update\/js\/jquery_update.js":1,"sites\/all\/modules\/fb_instant_articles\/modules\/fb_instant_articles_display\/js\/admin.js":1,"sites\/all\/themes\/mbn2_twig\/js\/header-top.js":1,"sites\/all\/themes\/mbn2_twig\/js\/header-drawer.js":1,"sites\/all\/themes\/mbn2_twig\/js\/article-comments.js":1,"sites\/all\/modules\/affiliate_links\/affiliate_links.js":1,"sites\/all\/modules\/affiliate_links\/affiliate_links_xuuid.js":1,"sites\/all\/modules\/gpt\/gpt.js":1,"sites\/all\/modules\/mbn_filter_tokens\/mbn_filter_tokens.js":1,"sites\/all\/themes\/mbn2_twig\/js\/share.js":1,"sites\/all\/modules\/purch\/purch.js":1,"sites\/all\/modules\/google_analytics\/googleanalytics.js":1,"sites\/all\/libraries\/spe\/spe-store.js":1,"sites\/all\/modules\/mbn_common\/js\/youtube.js":1,"sites\/all\/libraries\/fontfaceobserver\/fontfaceobserver.js":1,"sites\/all\/libraries\/jquery.appear-0.3.7\/jquery.appear.js":1,"sites\/all\/libraries\/jquery.plugins\/jquery.cookie.min.js":1,"https:\/\/cdnjs.cloudflare.com\/ajax\/libs\/fancybox\/3.1.25\/jquery.fancybox.min.js":1,"sites\/all\/libraries\/jquery.plugins\/jquery.backgroundSize.min.js":1,"sites\/all\/libraries\/galleria\/galleria-1.5.7.min.js":1,"sites\/all\/modules\/mbn_common\/js\/mbn_common.js":1,"sites\/all\/modules\/mbn_common\/js\/mbn_common_footer.js":1,"sites\/all\/libraries\/mediaelementjs\/mediaelement-and-player.min.js":1,"misc\/progress.js":1,"sites\/all\/modules\/visor_header2\/js\/header.js":1,"sites\/all\/modules\/mbn_notify\/follow\/follow.js":1,"sites\/all\/modules\/mbn_notify\/mbn_notify.js":1,"sites\/all\/libraries\/waypoints-4.0.0\/jquery.waypoints.js":1,"sites\/all\/themes\/mbn2_twig\/js\/article.js":1,"sites\/all\/themes\/mbn2_twig\/js\/sidebar.js":1,"sites\/all\/libraries\/jquery.lazyloadxt\/jquery.lazyloadxt.min.js":1,"sites\/all\/themes\/mbn2_twig\/js\/font-loader.js":1}},"video_filter":{"url":{"ckeditor":"\/video_filter\/dashboard\/ckeditor"},"instructions_url":"\/video_filter\/instructions","modulepath":"sites\/all\/modules\/video_filter"},"googleanalytics":{"trackOutbound":1,"trackMailto":1,"trackDownload":1,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip","trackDomainMode":1},"mbn_common":{"author":"Rene Ritchie"}});
//--><!]]>
</script>
<script type='text/javascript' src='https://passport.mobilenations.com/js/cluetip/jquery.cluetip.min.js?v41'></script>
<script type='text/javascript' src='https://passport.mobilenations.com/content/topbar/nationsbar.js?v41'></script>
</head>
<body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-46936 node-type-article node-format-review section-article cc-us im geo-US mona45">
<div id="skip-link">
<a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
</div>
<div class="region region-site-header">
<div class="header-top header-top--default   header-top--navagation-items-2">
<div class="header-top-inner">
<div class="header-top-inner2">
<button class="header-top__drawer-toggle ir js-header-drawer-toggle js-header-drawer-toggle--nav">
<i class="fas fa-bars"></i>
</button>
<a href="/" rel="index" class="header-top__brand ir "></a>
<nav class="header-top__navigation">
<ul class="header-top__navigation-list">
<li class="header-top__navigation-item">
<a href="https://forums.imore.com/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-top__navigation-link">
<i class="fas fa-comments"></i><span>Forums</span>
</a>
</li>
<li class="header-top__navigation-item">
<a href="https://store.imore.com/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-top__navigation-link">
<i class="fas fa-shopping-cart fa-flip-horizontal"></i><span>Shop</span>
</a>
</li>
<li class="header-top__navigation-item header-top__navigation-item--search">
<button class="header-top__search-button js-header-top-search-toggle">
<i class="fas fa-search"></i>
<span>Toggle Search</span>
</button>
<form id="form-main-search" class="header-top__navigation-search-form" action="/search">
<button type="submit"></button>
<input type="text" id="main-search" name="query" placeholder="Search...">
</form>
</li>
</ul>
</nav>
</div>
</div>
</div>
<section class="block block-topic" aria-hidden="true">
<ul class="block-topic__topics-list">
<li class="block-topic__topics-item">
<a href="https://www.imore.com/ipad-6" title="iPad (6th Gen)" class="block-topic__topics-btn">
iPad (6th Gen)
</a>
</li>
<li class="block-topic__topics-item">
<a href="https://forums.imore.com?utm_source=im&utm_medium=topicbar&utm_campaign=navigation" title="Forums" class="block-topic__topics-btn">
Forums
</a>
</li>
<li class="block-topic__topics-item">
<a href="/iphone-x" title="iPhone X" class="block-topic__topics-btn">
iPhone X
</a>
</li>
<li class="block-topic__topics-item">
<a href="/iphone-8" title="iPhone 8" class="block-topic__topics-btn">
iPhone 8
</a>
</li>
<li class="block-topic__topics-item">
<a href="/apple-watch-series-3-faq" title="Apple Watch Series 3" class="block-topic__topics-btn">
Apple Watch Series 3
</a>
</li>
<li class="block-topic__topics-item">
<a href="/apple-tv-4k" title="Apple TV 4K" class="block-topic__topics-btn">
Apple TV 4K
</a>
</li>
<li class="block-topic__topics-item">
<a href="/ios-11" title="iOS 11" class="block-topic__topics-btn">
iOS 11
</a>
</li>
<li class="block-topic__topics-item">
<a href="https://www.imore.com/pokemon-go" title="Pokemon Go" class="block-topic__topics-btn">
Pokemon Go
</a>
</li>
<li class="block-topic__topics-item">
<a href="/macos-high-sierra" title="macOS High Sierra" class="block-topic__topics-btn">
macOS High Sierra
</a>
</li>
<li class="block-topic__topics-item">
<a href="/ipad-pro" title="Apple iPad Pro" class="block-topic__topics-btn">
iPad Pro
</a>
</li>
<li class="block-topic__topics-item">
<a href="https://www.androidcentral.com/amazon-prime-day-2018?utm_source=im&utm_medium=topicblock&utm_campaign=navigation" title="Amazon Prime Day 2018" class="block-topic__topics-btn">
Amazon Prime Day 2018
</a>
</li>
</ul>
<div class="block-topic__pencil-ad"><div id='topic-pencil-rt-wrap' class='crumb-ad adunit-wrap adunit-gpt'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='topic-pencil-rt'>
<script>
        googletag.cmd.push(function() {
          gptadslots.push(googletag.defineSlot('/25586680/imore/article', ["fluid",[386,50]], 'topic-pencil-rt').defineSizeMapping(gpt_defaultsizemappings.mapping1())
             .setTargeting('adunit',"header_pencil_ad").setTargeting('site',"im")
            .addService(googletag.pubads()));
        });
        googletag.cmd.push(function() { 
          googletag.display('topic-pencil-rt'); 
        });
      </script>
</div></div>
</div></div>
</section> </div>
<div id='ctBoc'> 
<div id="page-wrap">
<div class="page-header clearfix clearfixb">
<div class="region region-page-header">
<div id='Leaderboard_Header_ATF-wrap-5b1ab22121036' class='adunit-wrap adunit-purch'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='purch_Y_L_1_1' data-clone-id='' adonis-marker></div>
<script type='text/javascript'>
    if(typeof(tmntag) !== 'undefined'){
      tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_L_1_1',false);});
    }
  </script></div>
</div> </div>
</div>
<div id="page">
<main class="content" id="content" tabindex="0">
<div class="container">
<div class="clearfix">
<div class="element-invisible"><a id="main-content"></a></div>
<div class="region region-content">
<div id="block-system-main" class="block block-system">
<div class="content">
<article class="article article--centered article--review node node-article node-promoted node-cat-opinion node-cat-industry-analysis node-cat-vector node-tag-wwdc node-tag-wwdc-2018 not-ajaxed" id="article-46936" data-nid="46936" data-url="/wwdc-2018-so-much-more-keynote" data-site="im">
<div class="row">
<header class="article-header col-3of3 ">
<span class="article-header__tag">Vector</span>
<h1 class="article-header__title">WWDC 2018: So much more than a keynote</h1>
<span class="article-header__intro">Once the spotlight leaves the keynote stage, it shifts to developers, and the real WWDC begins.</span>
<div class="article-header__details">
<div class="article-header__authors">
<span class="article-header__author">
<a href="/author/Rene%20Ritchie">Rene Ritchie</a>
</span> </div>

<time class="article-header__time" datetime="2018-06-08T12:12:27-04:00" title="Fri, 08 Jun 2018 12:12:27 -0400">
8 Jun 2018
</time>
<button class="article-header__comments js-comments-jump">
<i class="fas fa-comments" aria-hidden="true"></i>
0
</button>
</div>
</header>
</div>
<div class="row">
<div class="article-body col-3of3 col-3of3@desktop">
<div class="article-body__section article-body__section--wide"><p><img src="https://www.imore.com/sites/all/themes/mbn2_twig/assets/images/4x3.png" width="1600" height="1200" alt="" class="image-xlarge_wm_brw image-xlarge lazy" data-src="/sites/imore.com/files/styles/xlarge_wm_brw/public/field/image/2018/06/wwdc-2018-iphone.jpg?itok=YONIqf1G"><noscript><img src="https://www.imore.com/sites/imore.com/files/styles/xlarge_wm_brw/public/field/image/2018/06/wwdc-2018-iphone.jpg?itok=YONIqf1G" width="1600" height="1200" alt="" class="image-xlarge_wm_brw  image-xlarge"></noscript></p></div><div class="article-body__section article-body__section--narrow narrow">
<p class="article-body__drop-character">I know it can be confusing for people who see <a href="/wwdc-2018">WWDC</a> only through the lens of product events, and wonder why crowds are congregating the day before and tweeting up to a week later, but Apple's World Wide Developer Conference has never been just about the keynote. That's the gala, not the gold. Once the lights go out on the keynote stage, customers change the channel on the internet, and reporters race off to file their hottest of takes, the developers, designers, and auteurs get down to the business of making better apps. And that's when the real WWDC kicks off.</p>
<h2>The staff</h2>
<p>Walking up the steps of the San Jose McEnery Convention Center &mdash;&nbsp;Apple brought WWDC home from dense isolation of San Francisco last year &mdash; the first thing that hits you are the orange shirts. Staff, they say, and they're everywhere. Worn by the amazing people from Apple Retail, they're constantly on point, ready to answer questions, guide you on your way, or help in any way they can, from well before the venue opens until well after it closes. Being kind and considerate for the long, in the bright sun and shadowy halls takes not only endurance but a real love of purpose, and while they're often unsung, they're continuously heroes.</p>
<p>(That's especially true of the ones you see year after year, motivating, inspiring, and making sure you start or end your day with smile. They're an amazing team &mdash;&nbsp;all my admiration and thanks!)</p>
<h2>The AR Gaming Lounge</h2>
</div><div class="article-body__section article-body__section--wide"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr" xml:lang="en">The one where <a href="https://twitter.com/ijustine?ref_src=twsrc%5Etfw">@ijustine</a> totally kicked my ass at multiplayer <a href="https://twitter.com/hashtag/ARKit?src=hash&amp;ref_src=twsrc%5Etfw">#ARKit</a> slingshot. <a href="https://twitter.com/hashtag/ios12?src=hash&amp;ref_src=twsrc%5Etfw">#ios12</a> <a href="https://t.co/KehqD4OnYe">pic.twitter.com/KehqD4OnYe</a></p>&mdash; Rene Ritchie (@reneritchie) <a href="https://twitter.com/reneritchie/status/1003782864826068993?ref_src=twsrc%5Etfw">June 4, 2018</a></blockquote></div><div class="article-body__section article-body__section--narrow narrow">
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p>This year, entering through the main doors dropped you not only into the main lobby by right in from of the new AR Game Lounge. Apple didn't just introduce ARKit 2.0 with shared experiences at WWDC 2018, the company built a sample slingshot game and set up three tables for developers to try it out.</p>
<p>More and more challenging layouts were added to the game over the course of the week as well, and the lines of developers waiting to try it out were often long.</p>
<p>Each player got an iPad to "see" into the AR game world and an Apple staff member had a third game pad to broadcast the world onto a TV so everyone could enjoy the action.</p>
<p>It made the sample code into a sample experience and one that sold the potential of AR gaming in a way not simple presentation ever could.</p>
<p>(Now Pok&eacute;mon Go needs to hurry up and add ARKit 2.0 PvP battles already!)</p>
<p>Winners of the slingshot game got an ARKit pin for their collections. Apple started giving out pins last year. A semi-randomized pack at sign-in and then individual pins for attention different sessions, labs, and social mixers.</p>
<p>Just like emoji prompt cheers from crowds and updates from users, pins prompt interaction from attendees. It may sound small and silly but it's our collective love of exactly that that makes us so wonderfully human. I'm glad and amazed Apple both figured that out and was savvy enough to repeat it.</p>
<h2>The download centers</h2>
<p>Both in front of the AR Game Lounge and down the stairs on the right were long tables with power and ethernet &mdash; both USB-C and Thunderbolt 2 pre-dongled. macOS Mojave is a non-trivial download so, if you wanted it, Apple wanted you to get it wired.</p>
<p>It's terrifically functional, but it's also sneakily communal. I know open work spaces get a lot negative attention but, in a venue like this, sitting beside a clutch of like-minded downloaders quickly leads to introductions, exchanges, and new acquaintances from all over the world.</p>
<p>Even at the speed of ethernet, the downloads take a while, and so you inevitably spend that time trading stories about where you're from, what you do, and then, of course, how you're going to use all the new bits Apple just announced and, come the fall, will ship.</p>
<p>You'd think after a day or two the download centers would be empty, but no. People are always looking for a place to sit, a session to view or review online, or a repository to download from or upload to. But I think they're also looking for more of those serendipitous encounters. The one with people they'd never otherwise meet, who have similar backgrounds, interests, and goals but profoundly different life experiences and points of view.</p>
<p>And that lasts long after the progress bars and installations have finished.</p>
<h2>The sessions and the labs</h2>
<p>Up the stairs are the sessions and the labs. The sessions are fantastic. Getting to see the people who helped make new and updated frameworks present them on stage is beyond illuminating. They provide the context and clarity that anyone who rushed to get a hot take out on day one can't even come close to by celestial measures.</p>
<p>Apple's evangelism team, speaker trainers, and the presenters work tirelessly for weeks to prepare, to whittle down complex subjects to beguilingly simple, approachable slides and explanations. And it's terrific to see the seasoned pros, the ones who always seem to be expounding on the coolest new technologies year after year, and the new presenters who, often with the bulk of their teams encouraging them from the front row, take their first steps out onto the stage and in front of the packed hall of developers.</p>
<p>Teaching is an incredible way to learn, and I imagine going through the process of distilling something down to a WWDC talk is an incredible way to encapsulate a year or severals work.</p>
<p>The evangelism team has always done an amazing job of planning out the sessions, from the schedule to the speakers, from conception to presentation. Over the last few years, though, they've really been stepping it up and not just in terms of having to handle the sheer quantity that comes from having four platforms in the field instead of just one or two. And that's especially true of design sessions, which have gone from the few and far between to some of the most experimental, interesting, and pivotal of the event. Kudos to all involved.</p>
<p>Where the sessions are one to many and recorded and placed online so fast you can pretty much watch the same-day whether you're inside WWDC or out, the labs are the opposite.</p>
<p>Long after the executives have gone back to Apple Park, the engineers who write the frameworks, the human interface teams that makes Apple's own apps, and the editors and business managers who coordinate and curate the App Store fill up McEnery to help developers, designers, and app marketers solve their specific problems. By the hundreds if not thousands, it feels like.</p>
<p>Sometimes it's advising on new ideas. Sometimes it's troubleshooting issues. Sometimes it's being a second set of seasoned eyes and ears. But it's invaluable to everyone involved. When a developer gets help figuring out how to make their dreams into a reality, their interfaces clearer and easier to use, or their business approach sharper and more sustainable, the look on their face is like the sun has risen.</p>
<p>Same for the Apple engineers, designers, and editors. When they can help someone get over a hump or bump, and make something amazing with the tools or systems they've provided, it's like there's nothing better in the world.</p>
<p>These are two groups who share a symbiotic relationship but almost never get to interact outside of this one week a year. But it's this one week that reminds everyone that, despite sometimes not feeling prioritized or appreciated, we're all in this together.</p>
<h2>The meet-ups</h2>
</div><div class="article-body__section article-body__section--wide"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr" xml:lang="en">At the Women@WWDC get-together as <a href="https://twitter.com/EEhare?ref_src=twsrc%5Etfw">@EEhare</a> intros for four of the amazing WWDC scholarship winners. <a href="https://t.co/HZFNkOo9p1">pic.twitter.com/HZFNkOo9p1</a></p>&mdash; Serenity Caldwell @ WWDC (@settern) <a href="https://twitter.com/settern/status/1004381131351908352?ref_src=twsrc%5Etfw">June 6, 2018</a></blockquote></div><div class="article-body__section article-body__section--narrow narrow">
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p>Before the sessions and after, Apple coordinates some truly amazing meet ups. There are daily Women@WWDC breakfasts to connect developers who make incredible apps but who have also historically been underrepresented at conferences.</p>
<p>There are also meet ups for everything from Machine Learning to Augmented Reality, Health to Games, so developers in similar sectors and with similar interests can make and strengthen connections with their peers.</p>
<p>My favorite every year is the accessibility mixer. It's where people from the accessibility community, developers of accessibility apps, and Apple's accessibility team all get together to see what's new and, in many cases, what's miraculous.</p>
<p>This year, alongside Microsoft's incredible Seeing AI, and an overnight implementation of a Siri shortcuts "Read this&hellip;" feature, I got to see an iPhone X using ARKit's face detection to move the pointer and click and type across a Mac screen. Previously, that kind of accessibility technology would have cost a fortune in its own right. Now, thanks to Apple's TrueDepth camera and the ingenuity of a young, Italian developer, it will increasingly be available to everyone with an iPhone.</p>
</div><div class="article-body__section article-body__section--wide"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr" xml:lang="en">This is awesome. Viso uses iPhone X TrueDepth camera to let you navigate with facial movement and click with mouse movements. <a href="https://t.co/UVEOWKRHHe">pic.twitter.com/UVEOWKRHHe</a></p>&mdash; Rene Ritchie (@reneritchie) <a href="https://twitter.com/reneritchie/status/1004549390466347008?ref_src=twsrc%5Etfw">June 7, 2018</a></blockquote></div><div class="article-body__section article-body__section--narrow narrow">
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><h2>The community</h2>
</div><div class="article-body__section article-body__section--wide"><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr" xml:lang="en">Just podcasting with <a href="https://twitter.com/hashtag/WWDC?src=hash&amp;ref_src=twsrc%5Etfw">#WWDC</a> <a href="https://twitter.com/hashtag/ADA?src=hash&amp;ref_src=twsrc%5Etfw">#ADA</a> winners <a href="https://twitter.com/agenda?ref_src=twsrc%5Etfw">@Agenda</a>. NBD. :) <a href="https://t.co/ZBMVGNItPP">pic.twitter.com/ZBMVGNItPP</a></p>&mdash; Rene Ritchie (@reneritchie) <a href="https://twitter.com/reneritchie/status/1004085970386350081?ref_src=twsrc%5Etfw">June 5, 2018</a></blockquote></div><div class="article-body__section article-body__section--narrow narrow">
<script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script><p>The WWDC keynote is terrific. It gives the world a look at what's coming next. But there's so much more to the event than just the keynote, and getting to see it all is invaluable. It's a window into a deeper understanding not just of how Apple frames all its new bits but of how developers dig in and digest them, the next day and through the week. It's a cliche but it's true &mdash; what Apple provides is simply a starting point for what developers and designers create. It's a spark. Developers are the fire.</p>
<p>I know that's true for attendees but I also know it's going to inform everything I write from now until the fall and well beyond.</p>
<p>Thanks to everyone at Apple from the seemingly indefatigable events and evangelism teams, to the incredibly helpful marketing and PR teams, to all the engineers, designers, editors, retail, and support staff who don't just take the time to be at WWDC, but make the time ensure all the attendees leave as thrilled and empowered by the experience as possible.</p>
<p>And to everyone in the community who took the time to share their journeys and their apps with me, my colleagues, and peers all week, who make the tools we use and enable the work we do every day, ticket or no ticket, who shows up for coffee, drinks, at Next Door, Alt Conf, Layers, or just to hang out, thank you as well. Who, since the move from Moscone, have made the week extend beyond any one conference center and out across the city core &mdash; You don't just make WWDC. You are WWDC.</p>
<p>See you next year!</p>
<p></p> </div><div class="article-body__section article-body__section--wide"><div class="article-body__tabs article-body__tabs--devicebox">
<h2 class="article-body__tabs-title">
<a href="/wwdc">WWDC 2018</a>
</h2>
<div class="article-body__tabs-container">
<div class="article-body__tabs-tab article-body__tabs-tab--1">
<h2 class="article-body__tabs-tab-title">Main</h2>
<div class="article-body__tabs-tab-body">
<p><a href="/wwdc"><img src="https://www.imore.com/sites/all/themes/mbn2_twig/assets/images/16x9.png" alt="WWDC 2018" height="338" width="600" data-src="/sites/imore.com/files/styles/xlarge/public/field/image/2018/05/wwdc-team-2017-photo-san-jose.jpg" class="lazy"><noscript><img src="https://www.imore.com/sites/imore.com/files/styles/xlarge/public/field/image/2018/05/wwdc-team-2017-photo-san-jose.jpg" alt="WWDC 2018" height="338" width="600"></noscript></a></p>
<ul><li><a href="/wwdc">Everything at WWDC 2018</a></li>
<li><a href="/live">WWDC 2018 Liveblog</a></li>
<li><a href="/wwdc-2018">What to expect from WWDC 2018</a></li>
<li><a href="/best-events-attend-during-wwdc-week">Best events to attend</a></li>
<li><a href="/ipad-pro-3">iPad Pro 3</a></li>
<li><a href="/homepod-2">HomePod mini</a></li>
<li><a href="/ios-12">iOS 12</a></li>
<li><a href="/macos-10-14">macOS 10.14</a></li>
<li><a href="/watchos-5">watchOS 5</a></li>
<li><a href="/tvos-12">tvOS 12</a></li>
<li><a href="http://forums.imore.com/">Discussion forums</a></li>
</ul></div>
</div>
</div>
</div></div><div class="article-body__section article-body__section--narrow narrow">
<p></p><div>
<style>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</style></div>
<p></p> </div><div class="article-body__section article-body__section--wide"><div class="article-body__tabs article-body__tabs--devicebox">
<h2 class="article-body__tabs-title">
<a href="/vector">VECTOR | Rene Ritchie</a>
</h2>
<div class="article-body__tabs-container">
<div class="article-body__tabs-tab article-body__tabs-tab--1">
<h2 class="article-body__tabs-tab-title">Main</h2>
<div class="article-body__tabs-tab-body">
<div class="article-body__video"><div class="video_iframe"><iframe src="//www.youtube.com/embed/JB9hM4PgsO4?modestbranding=0&amp;html5=1&amp;rel=0&amp;autoplay=0&amp;wmode=opaque&amp;loop=0&amp;controls=1&amp;autohide=0&amp;showinfo=0&amp;theme=dark&amp;color=red&amp;enablejsapi=1" width="627" height="400" class="video-filter video-youtube vf-jb9hm4pgso4" frameborder="0" allowfullscreen="true"></iframe></div></div>

<ul><li>Video: <a href="http://www.youtube.com/vectorshow">YouTube</a></li>
<li>Podcast: <a href="http://applepodcasts.com/vector">Apple</a> | <a href="https://overcast.fm/itunes1313368831/vector">Overcast</a> | <a href="http://pca.st/vector">Pocket Casts</a> | <a href="http://vector.libsyn.com/rss">RSS</a></li>
<li>Column: <a href="/vector">iMore</a> | <a href="/vector/rss">RSS</a></li>
<li>Social: <a href="https://twitter.com/reneritchie">Twitter</a> | <a href="https://instagram.com/reneritchie">Instagram</a></li>
</ul></div>
</div>
</div>
</div></div><div class="article-body__section article-body__section--narrow narrow">
<p></p><div>
<style>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</style></div>
</div>
</div>
</div>
<div class="row">
<footer class="article-meta col-3of3">
<button class="article-meta__comments-toggle js-comments-toggle">
<span>View</span><span>Close</span> Comments (0)
</button>
<ul class="article-meta-tags">
<li><a href="/category/editorial">Opinion</a></li>
<li><a href="/tag/wwdc">WWDC</a></li>
</ul>
</footer> </div>
<div class="row">
<section class="article-comments" id="article-comments-46936">
</section>
</div>
<div class="row">
<div class="article-bio col-3of3 col-2of3@tablet">
<img class="article-bio__avatar" data-luid='28' src="https://passport.mobilenations.com/avatars/000/000/000/100x100_42.jpg?r=9" />
<div class="article-bio__bio">
<h3 class="article-bio__name">Rene Ritchie</h3>
<p>Rene Ritchie has been covering the personal technology industry for a decade. An outspoken analyst and critic, he writes at <a href="http://imore.com/vector">iMore.com/vector</a>, podcasts at <a href="http://applepodcasts.com/vector">applepodcasts.com/vector</a>, and you can find his show at <a href="http://youtube.com/vectorshow">youtube.com/vectorshow</a>. Follow him @reneritchie on <a href="https://twitter.com/reneritchie">Twitter</a> and<a href="https://instagram.com/reneritchie">Instagram</a>.</p>
</div>
</div> </div>
</article>
<button class="btn btn--load-more js-load-more " aria-label="Load more articles in this section"><span>Load More</span><i class="fas fa-sync-alt fa-spin fa-lg"></i></button>
</div>
</div>
<section class="share">
<ul class="share__list">
<li class="share__item share__item--facebook">
<a class="share__link" href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.imore.com%2Fwwdc-2018-so-much-more-keynote?utm_source=im%26utm_medium=facebook%26utm_campaign=social_share%26utm_content=" data-platform="Facebook" target="_blank">
<i class="fab fa-facebook-f fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--twitter">
<a class="share__link" href="https://twitter.com/intent/tweet?text=WWDC+2018:+So+much+more+than+a+keynote+%7C+via+%40iMore&amp;url=https%3A%2F%2Fwww.imore.com%2Fwwdc-2018-so-much-more-keynote?utm_source=im%26utm_medium=twitter%26utm_campaign=social_share%26utm_content=" data-platform="Twitter" target="_blank">
<i class="fab fa-twitter fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--google-plus">
<a class="share__link" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.imore.com%2Fwwdc-2018-so-much-more-keynote?utm_source=im%26utm_medium=googleplus%26utm_campaign=social_share%26utm_content=" data-platform="GooglePlus" target="_blank">
<i class="fab fa-google-plus-g fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--email">
<a class="share__link" href="mailto:?subject=WWDC%202018%3A%20So%20much%20more%20than%20a%20keynote&amp;body=https%3A%2F%2Fwww.imore.com%2Fwwdc-2018-so-much-more-keynote?utm_source=im%26utm_medium=email%26utm_campaign=social_share%26utm_content=" data-platform="Email" target="_blank">
<i class="far fa-envelope fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--text">
<a class="share__link share__link--text" href="sms:?&amp;body=WWDC%202018%3A%20So%20much%20more%20than%20a%20keynote - https%3A%2F%2Fwww.imore.com%2Fwwdc-2018-so-much-more-keynote?utm_source=im%26utm_medium=sms%26utm_campaign=social_share%26utm_content=" data-platform="Text" target="_blank">
<i class="fas fa-comment-dots fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--more">
<a class="share__link js-share-expand" href="#" target="_blank">
<i class="far fa-ellipsis-h fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--reddit share__item--hidden">
<a class="share__link" href="https://reddit.com/submit?title=WWDC+2018:+So+much+more+than+a+keynote&amp;url=https%3A%2F%2Fwww.imore.com%2Fwwdc-2018-so-much-more-keynote?utm_source=im%26utm_medium=reddit%26utm_campaign=social_share%26utm_content=" data-platform="Reddit" target="_blank">
<i class="fab fa-reddit-alien fa-lg fa-fw"></i>
</a>
</li>
<li class="share__item share__item--pinterest share__item--hidden">
<a class="share__link" href="http://pinterest.com/pin/create/button/?url=<?=$url?>?utm_source=im%26utm_medium=pinterest%26utm_campaign=social_share%26utm_content=" data-platform="Pinterest" target="_blank">
<i class="fab fa-pinterest-p fa-lg fa-fw"></i>
</a>
</li>
</ul>
</section> </div>
</div>
</div>
</main>
<div class="clear"></div>
<div id="banneradspace" align='center'>
<div id='Leaderboard_Footer_BTF-wrap-5b1ab2212bb4f' class='adunit-wrap adunit-purch'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='purch_Y_L_0_1' data-clone-id='' adonis-marker></div>
<script type='text/javascript'>
    if(typeof(tmntag) !== 'undefined'){
      tmntag.cmd.push(function(){ tmntag.adTag('purch_Y_L_0_1',false);});
    }
  </script></div>
</div> </div> 
</div> 
</div> 
</div> 
<div class="region region-site-footer">
<nav class="header-drawer header-drawer--secondary js-header-drawer" aria-hidden="true" tabindex="-1">
<div class="header-drawer__inner">
<div class="header-drawer__nav">
<ul class="header-drawer__navigation-list header-drawer__navigation-list--nav">
<li class="header-drawer__navigation-item header-drawer__navigation-item--nav header-drawer__navigation-item--nav-nav">
<button class="header-drawer__navigation-button header-drawer__navigation-button--nav ir js-header-drawer-toggle js-header-drawer-toggle--nav">
<i class="fas fa-bars"></i>
</button>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--nav header-drawer__navigation-item--nav-forum">
<button class="ir js-header-drawer-toggle header-drawer__navigation-button--nav js-header-drawer-toggle--forum">
<i class="fas fa-comments"></i>
</button>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--nav header-drawer__navigation-item--nav-shop">
<button class="header-drawer__navigation-button header-drawer__navigation-button--nav ir js-header-drawer-toggle js-header-drawer-toggle--shop">
<i class="fas fa-shopping-cart fa-flip-horizontal"></i>
</button>
</li>
</ul>
</div>
<div class="header-drawer__topics">
<ul class="header-drawer__navigation-list header-drawer__navigation-list--main">
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/rumors" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Rumors
</a>
</li>
 <li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/iphone" class="header-drawer__navigation-link header-drawer__navigation-link--main">
iPhone
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/ipad" class="header-drawer__navigation-link header-drawer__navigation-link--main">
iPad
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/apple-watch" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Watch
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/apple-tv" class="header-drawer__navigation-link header-drawer__navigation-link--main">
TV
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/mac" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Mac
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/how-to" class="header-drawer__navigation-link header-drawer__navigation-link--main">
How To
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/apps" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Apps & Games
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--main">
<a href="/accessories" class="header-drawer__navigation-link header-drawer__navigation-link--main">
Accessories
</a>
</li>
</ul>
<h3 class="header-drawer__navigation-title">Other Categories</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--secondary">
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="https://forums.imore.com?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Forums
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/analysis" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Analysis
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/reviews" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Reviews
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/deals" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Deals
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/newsletter" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Newsletter
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--secondary">
<a href="/contests" class="header-drawer__navigation-link header-drawer__navigation-link--secondary">
Contests
</a>
</li>
</ul>
</div>
<div class="header-drawer__sites">
<ul class="header-drawer__navigation-list header-drawer__navigation-list--sites">
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites ac">
<a href="http://www.androidcentral.com?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
Android Central
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites wp">
<a href="http://www.windowscentral.com?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
Windows Central
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites im">
<a href="http://www.imore.com" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
iMore
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites cb">
<a href="http://crackberry.com?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
CrackBerry
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites cc">
<a href="http://www.cordcutters.com?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
CordCutters
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--sites mm">
<a href="http://youtube.com/c/themrmobile?utm_source=im&utm_medium=drawer&utm_campaign=navigation&sub_confirmation=1" class="header-drawer__navigation-link header-drawer__navigation-link--sites">
MrMobile
</a>
</li>
</ul>
</div>
<div class="header-drawer__forum">
<h3 class="header-drawer__navigation-title">Forums and Discussions</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--forum">
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iMore Forums
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ask-question/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Ask a Question
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/search.php?utm_source=im&utm_medium=navbar&utm_campaign=navigation&do=getnew" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
New Posts
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/activity.php?utm_source=im&utm_medium=navbar&utm_campaign=navigation&sortby=popular&show=all&time=week" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Trending Discussions
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/rumored-apple-hardware/?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Rumored Hardware
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-x/?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone X
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-8/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone 8
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-7-plus/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone 7 Plus
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-7/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPhone 7
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ipad/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iPad
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ios-11/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iOS 11
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/ios-10/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
iOS 10
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/apple-watch-series-2/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apple Watch Series 2
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/apple-watch-series-3/?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apple Watch Series 3
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/apple-watch/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apple Watch
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/macbook-pro/?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
MacBook Pro
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--forum">
<a href="https://forums.imore.com/iphone-apps-games/?utm_source=im&utm_medium=drawer&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--forum">
Apps & Games
</a>
</li>
</ul>
</div>
<div class="header-drawer__shop">
<h3 class="header-drawer__navigation-title">Shop</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--shop">
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/deals.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
HOT ACCESSORY DEAL$
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://digitaloffers.imore.com?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Digital Offers
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Best sellers
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-new.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
New releases
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-cases.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Cases and covers
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/cradles.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Chargers and cables
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-batteries.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Battery packs
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--shop">
<a href="https://store.imore.com/apple-iphone-screen-protectors.htm?utm_source=im&utm_medium=navbar&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--shop">
Screen Protectors
</a>
</li>
</ul>
</div>
<div class="header-drawer__dev">
<h3 class="header-drawer__navigation-title">Dev Center</h3>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--dev">
</ul>
</div>
<div class="header-drawer__tools">
<div class="header-drawer__passport">

<span class="header-drawer__passport-links">
<span class="fa-stack fa-lg">
<i class="fas fa-circle fa-stack-2x"></i>
<i class="fas fa-sign-in-alt fa-stack-1x fa-inverse"></i>
</span>
<a href="https://passport.mobilenations.com/?u=eNpVjkEOwiAQXDD_wh0tlLa4Hk18gHpvgG6VtIgBTDXGv0urF2-7s5nJKqjhFYFxIAE7G9Ck9h5Gso1QZXZJ6RZhvZ6maWWdD7gy3uWtM5QXTNLoqbubC51PdMDn1VwnnF1W__da11UzL3MTZa20MoXUrO9NVwkpDHKUnJeaSb74Aki031Q2rJuHnFQmWX9dngMy-rNdZlZcMNkdD_v25AfMREPxo_i42aC-jgVWcSk2TbMpt-8P-NlNig,,">Log in</a>
or
<a href="https://passport.mobilenations.com/?utm_source=im&utm_medium=signup&utm_campaign=passport&u=eNpVjcsOgjAQRf-FfZGWVxmWJn6AulwnpQzSYKlpa9AY_91W3Libe2fOGQEVvBxQBonFQVmUvrvba9I6KEM3eX9zsNut65oqbSym0uiQBklYRjlxhui7nEhcXJEZn4vxGFla_fs6PZSxz4MTeSV6ITPe03GUQ1nwQlwiQ85Y3lPOvnwBiVObKhBKxyEohfTKLDHw6L8o59F-_2WQ7E_HQ3c2M4aDHrJfi4-bsmLDFNCS8aKp6yZv3x_85k7Z">Sign up</a>
</span>

</div>
<ul class="header-drawer__navigation-list header-drawer__navigation-list--social">
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="https://google.com/+imore?utm_source=im&utm_medium=burger&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-google-plus-g"></i><span>g+</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://www.twitter.com/imore?utm_source=im&utm_medium=burger&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-twitter"></i><span>t</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://www.facebook.com/imorecom?utm_source=im&utm_medium=burger&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-facebook-f"></i><span>f</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://www.youtube.com/subscription_center?utm_source=im&utm_medium=burger&utm_campaign=navigation&add_user=imorevideo" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-youtube"></i><span>y</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="http://instagram.com/imoregram?utm_source=im&utm_medium=burger&utm_campaign=navigation" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fab fa-instagram"></i><span>i</span>
</a>
</li>
<li class="header-drawer__navigation-item header-drawer__navigation-item--social">
<a href="https://www.imore.com/rss.xml?utm_medium=burger&utm_campaign=navigation&utm_source=im" class="header-drawer__navigation-link header-drawer__navigation-link--social">
<i class="fas fa-rss"></i><span>r</span>
</a>
</li>
</ul>
<ul class="header-drawer__navigation-list header-drawer__navignation-list--cta">
<li class="header-drawer__navigation-item header-drawer__nagigation-item--cta">
<a href="mailto:imoretips@imore.com" class="header-drawer__navigation-link header-drawer__navigation-link--cta">
<i class="fas fa-paper-plane"></i><span>Tip us on News</span>
</a>
 </li>
</ul>
</div>
</div>
</nav>
<footer class="footer">
<section class="footer__brand">
<div class="container">
<a href="https://www.mobilenations.com/" class="footer__logo">Mobile Nations</a>
<strong class="footer__tagline">
<span>500M</span>
Consumers Reached Yearly
</strong>
</div>
</section>
<section class="footer__copyright">
<div class="container">
<ul class="footer__nav">
<li class="footer__nav-item">Copyright 2018 Mobile Nations</li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/terms-conditions">Terms and Conditions</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/privacy-policy">Privacy Policy</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/privacy-policy#your-choices">Your Ad Choices</a></li>
<li class="footer__nav-item">Careers: <a href="http://breaksclusive.recruiterbox.com/">Writer</a> | <a href="https://mobilenations.recruiterbox.com/">Dev</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/licensing-reprints/">Licensing</a></li>
<li class="footer__nav-item"><a href="https://www.mobilenations.com/external-links">External Links Disclosure</a></li>
</ul>
<a href="http://purch.com/advertise/" class="footer__partner-logo">
<span>Advertising Partner</span>
</a>
</div>
</section>
</footer>

</div>
<script>
        $('.glade').each(function() {
          var data = $(this).data('json');
          $.extend(data.targeting,window.targeting);
          $(this).attr('data-json', JSON.stringify(data));
          $(this).data('json',data);
        });  
      </script>
<script src='https://securepubads.g.doubleclick.net/static/glade.js' async=''></script> <script type="text/javascript" async defer src="http://ps.eyeota.net/pixel?pid=1mpv4m0&t=ajs&sid=imore&interest=opinion"></script> <script type="text/javascript" src="http://tags.crwdcntrl.net/c/12464/cc.js?ns=_cc12464" id="LOTCC_12464"></script>
<script type="text/javascript" language="javascript">_cc12464.bcp();</script> <script>
  (function (w,d,t) {
  _ml = w._ml || {};
  _ml.eid = '58180';
  var s, cd, tag; s = d.getElementsByTagName(t)[0]; cd = new Date();
  tag = d.createElement(t); tag.async = 1;
  tag.src = 'https://ml314.com/tag.aspx?' + cd.getDate() + cd.getMonth();
  s.parentNode.insertBefore(tag, s);
  })(window,document,'script');
  </script><div id='GPT_5b1ab22134bd3-wrap' class='adunit-wrap adunit-gpt'>
<div class='adunit-wrap-inner'>
<div class='adunit' id='GPT_5b1ab22134bd3'>
<script>
        googletag.cmd.push(function() {
          gptadslots.push(googletag.defineOutOfPageSlot('/25586680/imore/article', 'GPT_5b1ab22134bd3')
             .setTargeting('adunit',"interstitial").setTargeting('site',"im")
            .addService(googletag.pubads()));
        });
        googletag.cmd.push(function() { 
          googletag.display('GPT_5b1ab22134bd3'); 
        });
      </script>
</div></div>
</div>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-N9VHS7"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-N9VHS7');</script>
<script type="text/javascript">
  var spe_url = document.domain;
  var spe_url_array = new Array;
  spe_url_array = spe_url.split(".");
  spe_url_array.reverse();
  var spe_root_url = spe_url_array[1] + '.' + spe_url_array[0];

  if (spe_url_array[2]) {
    var spe_segments = spe_url_array[1] + '.' + spe_url_array[2];
  } else {
    var spe_segments = spe_url_array[1];
  }

</script>
<script type="text/javascript">
  var _qevents = _qevents || [];

  (function() {
  var elem = document.createElement('script');
  elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
  elem.async = true;
  elem.type = "text/javascript";
  var scpt = document.getElementsByTagName('script')[0];
  scpt.parentNode.insertBefore(elem, scpt);
  })();


  _qevents.push({
    qacct:"p-ebutdjFEkjMk-",
    labels: spe_segments
  },
  {
    qacct:"p-8bC03lZwjgqy2",
    labels: spe_segments
  }
  );
</script>
<noscript>
<div style="display:none;">
  <img src="//pixel.quantserve.com/pixel?a.1=p-ebutdjFEkjMk-&a.2=p-8bC03lZwjgqy2" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "6035753" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=6035753&cv=2.0&cj=1" />
</noscript>
<script>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</script><script>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</script>
<script type="text/javascript">
        window._taboola = window._taboola || [];
        _taboola.push({flush: true});
        </script><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1765793593738454&ev=PageView&noscript=1" /><img height="1" width="1" style="display:none" src="https://www.facebook.com/tr?id=1765793593738454&ev=ViewContent&noscript=1" /><script type="text/javascript"> 
      try{
        (function(){ 
          var cb = new Date().getTime(); 
          var s = document.createElement("script"); 
          s.defer = true; 
          s.src = "//tag.crsspxl.com/s1.js?d=2127&cb="+cb; 
          var s0 = document.getElementsByTagName("script")[0]; 
          s0.parentNode.insertBefore(s, s0); 
        })();
      }catch(e){}
    </script>
<script type='text/javascript'>
          $('a[href*="//itunes.apple.com"],a[href*="//itun.es"],a[href*="//rover.ebay.com"],a[href*="7293438-11365093"]').addClass('norewrite');
        </script>
<script type='text/javascript'>
        var vglnk = { key: '8ed1f879e224588da0398abad3c283a2' };

        (function(d, t) {
          var s = d.createElement(t); s.type = 'text/javascript'; s.async = true;
          s.src = '//cdn.viglink.com/api/vglnk.js';
          var r = d.getElementsByTagName(t)[0]; r.parentNode.insertBefore(s, r);
        }(document, 'script'));
        </script><script>
  PARSELY = { };
</script>

<div id="parsely-root" style="display: none">
<div id="parsely-cfg" data-parsely-site="imore.com"></div>
</div>
<script>
(function(s, p, d) {
  var h=d.location.protocol, i=p+"-"+s,
      e=d.getElementById(i), r=d.getElementById(p+"-root"),
      u=h==="https:"?"d1z2jf7jlzjs58.cloudfront.net"
      :"static."+p+".com";
  if (e) return;
  e = d.createElement(s); e.id = i; e.async = true;
  e.src = h+"//"+u+"/p.js"; r.appendChild(e);
})("script", "parsely", document);
</script>

<div id="fb-root"></div>
<script>
  (function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.7";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));

  var fbAsyncInitOrg = window.fbAsyncInit;
  window.fbAsyncInit = function() {
    if(typeof(fbAsyncInitOrg)=='function') fbAsyncInitOrg();
    FB.init({
      appId: "213678485361751",
      xfbml: true,
      version    : 'v2.7'
    });

    FB.Event.subscribe('xfbml.ready', function(msg) {   // Log all the ready events so we can deal with them later
      var events = fbroot.data('ready-events');
      if( typeof(events) === 'undefined') events = [];
      events.push(msg);
      fbroot.data('ready-events',events);
    });

    var fbroot = $('#fb-root').trigger('facebook:init');
  };
</script>

<script async='async' type='text/javascript' src='//www.lightboxcdn.com/vendor/d74ebc7c-6bfa-42bd-b88b-9240b4878523/lightbox_inline.js'></script>
<div class='adunit' id='purch_Y_O_1_1' data-dimensions='1x1'></div><div class='adunit' id='purch_Y_P_1_1'></div><script>console.log("%cWe are hiring.  Interested in joining our team? \nhttps://mobilenations.recruiterbox.com/jobs/fk01u1z/", "padding: 20px 0; color: #222; line-height: 1.4em; font-size: 1.2em; font-family: Arial, Helvetica;");</script><script type="text/javascript">

  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  var spe_root_url = document.domain.match(/[^\.]+\.[^\.]+$/)[0];
  ga('create', 'UA-4245582-4', "." + spe_root_url, 'global', {
    allowLinker: true
  });
  ga("global.set", "dimension1", "full");
  ga("global.set", "dimension2", "Opinion");
  ga("global.set", "dimension3", "true");
  ga("global.set", "dimension4", "C:article,S:legacy,B:w1000");
  ga('global.require', 'linkid');
  ga('global.require', 'linker');
  ga('global.linker:autoLink', ["crackberry.com","androidcentral.com","imore.com","windowscentral.com","mobilenations.com","vrheads.com","thrifter.com","teslacentral.com"]);
  ga('global.send', 'pageview');
  setTimeout("ga('global.send','event','NoBounce','Over 20 seconds')",20000);
</script>
<script type="text/javascript" src="/sites/imore.com/files/advagg_js/js__fCruuIeVMFV8Xga1V6YtXH_t4d4qyL1HV2HmXQ1N_Zk__y3uJNjMrk-UUz9riUnY4jl6wIVGTcQKJb32xDfioJfc__YUvqFUO0PYkA5A9bMPyTPeXDCU4QC4T77YSGFghmgFQ.js" async="async"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
$('audio').mediaelementplayer();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document,'script','twitter-wjs');
//--><!]]>
</script>
</body>
</html>
