The latest version of ultrasn0w has just hit Cydia with support for unlocking additional devices under iOS 5.0.1. You'll need to have a compatible baseband in order for the unlock to work. Below is a list of compatible devices and basebands.

This version supports the following devices and basebands on iOS 5.0.1 -

  • iPhone 3GS - 04.26.08 - 05.11.07 - 05.12.01 - 05.13.04 - 06.15.00
  • iPhone 4 - 01.59.00

If you're planning on upgrading from an older firmware, make sure you preserve your baseband with a program like sn0wbreeze if you need an unlock. Then follow our guide on how to unlock your device via ultrasn0w on iOS 5.0.1. If you need more help, make sure you check out our jailbreak and unlock forums too.