iPhone 3.0: Case of the Missing or Incorrect App Icons

iPhone 3.0 Missing or Incorrect Icons

Way back in the elder days of iPhone 3.0 Beta 5, there was some discussion on Twitter about how apps would have an incorrect icon, or would be missing an icon altogether. Since the iPhone 3.0 betas were private and not public, TiPb didn't post about it as that's just not how we play cricket. Private betas will have bugs, get those bugs reported, and hopefully have those bugs fixed by the time the software goes into general availability.

However, TUAW highlights that this particular bug is still biting iPhone 3.0, even in the release version. Now, as then, if you have an app that's missing an icon or has the incorrect icon, you can try to reboot your iPhone, delete the app and download or sync it back on, or wait for Apple to fix it in a 3.0.x update.

Meanwhile, you can let us know the funniest app mishaps iPhone 3.0 is giving you in the comments below.

(Mine is the little AIM dude swiping my 1Passwords Pro!)

Rene Ritchie

Editor-in-Chief of iMore, co-host of Iterate, Debug, Review, The TV Show, Vector, ZEN & TECH, and MacBreak Weekly podcasts. Cook, grappler, photon wrangler. Follow him on Twitter and Google+.

More Posts

 

0
loading...
0
loading...
0
loading...
0
loading...

← Previously

The Competition: Sony Working on Playstation/PSP Phone?

Next up →

iPhone 3GS Jailbreak Software Delayed by Dev Team

Reader comments

iPhone 3.0: Case of the Missing or Incorrect App Icons

110 Comments
Sort by Rating

You know why that damn bug is still plaguing the official 3.0? Because everyone didn't frickin report it to Apple in DROVES! I was constantly telling developers on the beta to report the damn bugs many times but noooooo, many responded with a "it's a known bug that's already been reported" comment They were content on posting it on small, silly websites that Apple doesn't even know exist let alone pay attention to. Thanks all you helpful developers! You really don't know how to TEST software! Geez!

Yeah i called apple and made a support thing about this and they claimed they never heard of that problem before and to restore. So far so good after the restore and instead of using a backup i had to do a fresh install. Thank goodness for having a mac and all my info on it mainly because of switching phones like it was my job about a month ago. Some people might not be so lucky.

I had some issues with missing icons in the dev builds (which I reported), but never wrong icons and I haven't had a problem with the final release.

One more thing. I believe that there are quite a few tavrel insurance internet sites of reliable companies that allow you to enter your holiday details and have you the insurance quotes. You can also purchase the particular international tavrel cover policy on the web by using your current credit card. Everything you should do is to enter all tavrel details and you can see the plans side-by-side. Merely find the package that suits your financial budget and needs and use your credit card to buy the item. Travel insurance on the web is a good way to search for a reliable company with regard to international tavrel cover. Thanks for giving your ideas.

I keep getting this problem CONSTANTLY!
My fix for it is (without having to restore), is go to the 'Applications' tab for your iPhone in iTunes then untick the affected apps. Sync so that they're deleted on your iPhone. Tick the Apps again on iTunes and then resync.
With luck, the icons will be back to normal as they now are for me. Still though, this bug is very 'un-Apple-like'.

Although I haven't experienced this, I have found a couple of bugs. For instance, if you try to use the new email icon for podcasts in the iPod app, whatever you're listening to pauses playing as soon as you touch that icon. All I have to do to click my headphone remote to resume playing, but it shouldn't stop at all.
Another bug seems to be that 'copy' doesn't always seem to work well in some apps. For instance, I can't seem to copy more than a word at at time when on a 'reading' screen in Tweetie. Also, a lot of apps that previously ran fine are now lagging quite a bit. Perhaps those two are more of the app's compatibility with 3.0, but they're still problems that I hope get corrected soon.

Beat one for me was the 'Sit or Squat' app with the Bloomberg icon. Seemed appropriate with the market being in the toilet.
Fix for me was a restore

The following situation happened to me and here is how I found a fix: Went from 3G (jailbroken if it matters) to a 3GS. My Camera App icon was missing. It would not even come up with a spotlight search. There may have been more apps missing but this was the only one that concerned me and I started looking for a fix. Finally I went into settings, General, Reset, and did a Reset All Settings and that fixed it.
Hope this helps someone.

One reason that I lost a few icons (only temporarily) was that after upgrading to 3.0 I turned on the parental controls to block explicit apps - and several icons disappeared, including Tweetie (which is rated 4+), and the CCEL Devotional Bible (which is not rated at all, or wasn't at the time).
Turning off the parent controls brought all my icons back.

I want Tay that I feel bad for all that seem to be having so many problems with the new os and new phone. That being said, I feel extremely lucky that my new phone has been stellar! Or is it luck??? I wonder what the percentage of problems are coming from users that either had previously jailbroken, unlocked, or tried the mms hack/or some other hack?? Not a digg at JB'rs just a thought.

Just a quick note - if you had an icon disappear, you can still use Spotlight to find/launch it. This happened to me. I had thought it was due to the fact I turned my iPhone off while downloading the app.

What is the deal with Apple lately? It seems as if ever since Steve Jobs got sick.
they've gone to hell. Sticking backspace/delete keys, overheating Iphones. reports of a lot of Macs (including mine) simply dying with no recourse but return to the company. I didn't mind paying the big bucks for better quality. But if I wanted crap I would have bought elsewhere. Lately they've turned to #Crapple.

I have 2 apps with incorrect icons. TweetDeck shows up with the Style icon. Let's Golf shows up as Mini Piano.

Anthony is right. That's the quickest and easiest solution. I had the same problem right after the 3.0 release. First time I did a full restore. A day or so later...same problem. Since a full restore takes so long, I tried living with it for a couple days. Unbearable. Then decided to unsync the troublesome apps and resync. Worked like a charm. Unfortunately, unsyncing and resyncing Myst still took a lot of time, but still better than a restore. Hopefully, Apple fixes these issues soon.

My Photogene has a Speedtest. Only a resync would help. 3.0 needs fixing fast. It runs like dog after two weeks usage.

Ok, maybe this is just me.. but I've had this occurring for me before I had 3.0 installed on my iPhone. With 2.2.1 installed, the stocks icon disappeared (I didn't care about that), but many of my paid apps disappeared. It's always the same apps that disappear (Deal or no Deal, The Price is Right, The Oregon Trail, and Tetris). I try the re-sync method on iTunes, and it re-syncs them periodically, but after a day or so they disappear again. I have no idea how to fix this permanently..hopefully Apple is already working on a fix (doubt it.)

I intended to write you the itltle note to be able to thank you very much again about the pleasing advice you've provided above. It is really wonderfully open-handed with you to convey openly exactly what many people could possibly have offered for sale for an ebook in order to make some money on their own, notably considering the fact that you could possibly have tried it in the event you desired. Those good tips in addition worked like the fantastic way to be aware that someone else have the same desire just like mine to understand good deal more with respect to this problem. I know there are many more pleasurable opportunities in the future for individuals that scan your website.

I didn't have this problem with initially setting up the 3GS, but I have had this problem ever since installing a new app. It installs the app with an icon for another app entirely. Syncing and unsyncing the app fixes it, but the problem comes right back if I have to reset the phone for any reason. It's a pain, because doing that deletes all the data in the app. I am hoping for a fix soon, because it is aggravating.

I have a 32 3GS. My GPS is always a few blocks off, where my iPhone 3G was dead on, usually.
When I do a soft reset, all my icons go in alphabetical order. Way annoying.
I have phantom icons too.
My speaker sounds mildly distorted when it's up all the way, on occasion.
I'll probably have to return to the apple store sometime.

So let's see here where do I start, AT&T navigator is looking like black rss feed, whole food markets is looking like mobsters, im+ is looking like a fart app lol, google app looks like the halleluja button lol. I've tried rebooting and resyncing as well as redownloading and nothing seems to change. Please apple bring an update soon :)

I wanted to send you the liltte remark so as to thank you very much once again regarding the spectacular secrets you've featured on this page. It has been so seriously generous of you to allow openly what some people would have distributed for an e book to generate some cash on their own, precisely seeing that you might have done it in the event you considered necessary. The good tips likewise worked as a fantastic way to comprehend someone else have the same keenness really like mine to grasp more and more in regard to this problem. I'm certain there are numerous more enjoyable moments in the future for individuals that go through your website.

I have the Beejive icon on my Speedtest app, and the Topple icon on my Family Guy app. I did not pwn my 3GS, so to answer earless, I don't think Cydia is the reason. My question is though, is this only happening on the last page of apps? These are about my 4th set of icons that have been changing, but it's only been happening on my last page of apps (page 4 of 4).

@ earless puppy
Nope, I don't have a jailbroken iPhone and I'm still having issues. (See all my problems in #22) haha

My WhitePages app has the iMob icon. Pretty funny, looks like its the whitepages for hitmen or something

My flight control game has the touchgrind icon, my pocket god app has the shazam icon and my ping pong game has the flixster icon. I have alot of junk on my iPhone 3G S.

I've got some screenshots that will blow your mind. How can I get them to you from my iPhone? My computer is down.

I also have a 3.0 icon related problem. It only occurred once tho and hasn't happened since. After going into 'wiggly icon mode' and Shifting around a couple of icons, after going back to normal mode one of my icons remained with that delete cross next to it. To fix the problem I had to press the cross then click cancel. Didn't happen again tho. Has any one else experienced that bug?

Don't think I have had this problem yet but I did find a somewhat funny icon ordeal. The tipb iPhone-Home-Screen-Link icon. ahem Rene ahem I assume when the icon was created, the dev/creator made the classic shadow effect built into the icon whilst apple has a shadow/shining-down effect incurred when the icon link is made on the home screen. The slope of the built in effect is slightly different than the effect incurred when placed on homescreen. It's no biggy. Just a funny coincidence as long as were talking about icon mishaps.

My iPhone 3G with 3.0 os have trouble with the home icons, they seem to get "lowered" from the top...it's kinda strange and i've taken pics of it because it doesn't happen all the times...anyone knows about it?

I my App Store icon disappeared yesterday. Wouldnt even pull up using the spotlight search. Had to do a restore and re-jailbreak. 

I have one of these incorrect App icons.
Installed program a. Deleted program a. Installed program b. Program b has the icon from program a. I've tried restarting and reinstalling but no use. A restore will probably fix it, but its just too much of a pain syncing 16gb of data.

I have the icon problem AND everytime I type the word "me", it auto suggests "M&E", which I have no idea what that is. I'm rather close to the word, "M&E"....nevermind, it's hopeless...

I have an original iPhone and ever since I upgraded to 3.0 my phone has been so slow, and when people call me it comes up blank at first and then 5 seconds later it shows the contact info. retarded huh?
I guess I'm just out of date...

i had this problem but it was due to me jailbraking my iphone
fixed it by restoring all my settings
fixed now
was because i had an app called catergries
i have no problems at all now

To those with no issues: GREAT!!! Glad for ya!!
However this isn't a "fancy photoshop" trick. My 16gb 3g running 3.0 was fine.... No issues at all. The Mrs. 8gb 3g running 3.0 was great. My new 32 gb 3gs running 3.0 has icons that are white out squares. Hers (a new 16gb 3gs) has white out squares and mislabeled icons. I did the resync trick and it worked... We'll see for how long though. Bottom line Apple, fix this crap. Otherwise your another Microsoft, making a big to-do over some great software release and not making sure it was tested all the way through.

FWIW- I solved my little AIM dude problem by deleting the app from my iPhone, rebooting, syncing 1Password Pro back from iTunes.
Now the icon is correct.

I haven't had an issue but I just wish my most used apps (speed dial #1-4) would work properly with 3.0!!!

Today I installed the 'KFC Grillz" app, I wanted to set it next to the radio so I'd see lips moving when I hear the words.
After install, it was deja vu. The icon (on mine, at least) is from the late lamented "Hot Girls" app.

Oh thnk God I thought it was just iphone, I've had this problem since day 2 of owning the 3GS and hadn't been able to find anything about it on the web.
I must say I had the problem after initally setting up my iphone from a backup of an original 2G iPhone. When I did a full restore and installed everything from a sync I have not had any problems with 3.0 and if anything it seems faster now than it did out of the box.
I have noticed that the old bug from 2.0 when saving a pic from the web has surfaced again. All saved images are really low quality when saved. don't know if anyone else is getting this. I have also had an issue with the camera not initialising and not being able to access photo library, butthis seems to have cleared up since the restore.
I have also been victim of the high pitched whine from the speaker after system sounds have played. That seems to be louder since I did the restore, bur then that could just be me.

I have asphalt 4 racing with 3/4 of the correct icon and a quarter of the iemoji icon on top, Doom with airsharing, and pinball with artcamera, plus about 20 or so more blank or switched app icons.

So check this out...in addition to having one of my apps' icons disappear after installing the 3.0 update on my ipod touch, when I went to play my music on my pod it said there was "no content", the same with my videos. But if I looked at my ipod when connected to itunes, all the music and videos were there. It was like the device forgot how to find all my music and videos. The fix was to just play one song on my device through itunes and then there was a few seconds of syncing and after that it found all my music. The same with the video, I played one video on the device through itunes and then it "found" the rest. Weird! I got the icon back by doing a "reset all settings" command on ipod (which sucks because it rescrambles all your icons and packs them into the fewest pages possible

The other bug I had is quite annoying: my iPhone 3g goes slow. I turn it off and it hangs on the apple logo. I press both buttons to force it to turn off, and when I turn it on the USB logo flashes quickly. When I try to open any third party app it does not work; it tries and quits all apps except for the original apple apps. It works again if I install a new app.

Ah...so this was a bug. My dad had this when he upgraded to 3.0...it caused him to have to drive 2 hours to Michigan to retrieve the computer he had a backup of his password database on. That was the only reason for the drive because he left the computer at his vacation home and needed the passwords for the next week at work. Nice Job AT&T...I have a good way to deflect his anger at me now for suggesting the update.

I work at AT&T, we have been showing folks our AT&T Navigator Application for a few days now. I reset my iPhone and to my customers dismay my AT&T Navigator had the icon for some Sexy Girls Application. I thought it was hilarious, so did my boss, but the customer didn't look to happy.

I needed to write you one very ltitle observation so as to thank you so much yet again for your pretty principles you have provided in this case. It was certainly extremely open-handed of you in giving freely exactly what a number of us would've distributed as an e book in order to make some dough on their own, certainly now that you could possibly have tried it in case you considered necessary. Those tricks additionally worked to be a great way to be aware that someone else have the same keenness similar to mine to see much more with reference to this matter. I am certain there are numerous more fun instances up front for individuals who look over your blog post.

So my iPhone 3G after OS 3 and 2 reboots is missing the camera, contacts, and mail apps. I can't search for them and they haven't been there on any reinstall of the OS. The csmera works on 3rd party camera apps. I called Apple and they asked me to reboot the OS again! Does anyone know how to regain these important apps???

My Facebook app disappeared from my iPhone. I tried uninstalling and reinstalling but nothing worked. The only way to fix it was to install it and then go into Settings, General, Reset, and did a Reset All Settings and then the Facebook icon reappeared.

I had the disappearing icons thing too (iPhone 3G) and a restore did not solve it (restore from backup, not setting up as a new phone). I also could not find the missing apps via spotlight.
It turns out the parental restrictions thing mentioned earlier was the solution. Thanks!!
The "offensive" apps?
Facebook
Quicken (financial software)
Shazam
Walt Disney World Secrets

My formerly jailbroken 3G is now updated to 3.0, though I have not re-broken it yet. ALL of my apps that were in "categories"/folders are no longer showing up on my screen, though they are still in my iTunes. Can I only see them again if I jailbreak 3.0? I am not able to use 5-60 apps because I can't see them anymore, HELP!!!

My AOL radio app does not even show up. I search for it and still nothing. But, if I go to the app store, it says installed.

I did a reset and erase all content. Now I have absolutely no apps. Not even the default apps like safari mail calc etc. My screen is blank. I can sweep over to the search but there is nothing. I restored the phone from a backup but it only put on the app store apps and spread them over 4 pages. Guess I'm doing another recovery.

I think I've been experiencing the problem in this blog. Here is what I wrote down in apple support discussions.
" For the past two days, whenever I sync my iPhone, apps were lost and I had to re-install them again. Today, after syncing, the icons were either blank or incomplete. Does someone have any experience with this and how did you solve the problem? See it for yourself - http:/yfrog.com/5751912454j "

Occasionally I have had the pre-loaded apps disappear. Once the appstore icon disappeared. Recently the youtube app disappeared. Since you cannot download these apps through Itunes I had to do a total reset of the phone, and clean install, which is a royal pain in the butt to have to be doing routinely. Damn you Apple!

ok get this i have NO app store... ok so i gave it to my dad... well he took it away for me downlaodin an album... but anyway he gave me the software update 3.0 and gave it back... i searched app store and cant get it... i went on appsniper which i previously doenloaded on my ipod.. and tryed clickin an app it wouldnt get to the store.... there is no icon and no way of gettin to the store..... is this related to this bug on 3.0 or did my dad take it off???? i rly need help bcas i have a gift card and i dont want to get on the computer!!!! thx

MMS requires cecass to the baseband which the SDK does not allow.Video recording is being done by both uShow and iPhone View Recorder.As for other stuff (copy/paste, Bluetooth, MMS, etc.), only Apple is allowed to do that but they can all be done with a firmware update.

removing the affected apps via itunes, reapplying and syncing worked great for me...crossing my fingers.

My husband and I have both had this problem on the touch after upgrading to 3.0. For us, the apps often have incorrect icons. "Moonlights" has the "TuneWiki" icon and "iheartrate" has the "AppMiner" icon on mine. sometimes it fixes itself - PocketGod did with a new update. Will try the sync idea from above.. If it works I'll post again.

I had a number of icons missing and i did a reset all in setting and they came back but the problem with that is u loose ur data.

I started having this problem after i upgraded too. maybe it doesn't like certain apps? so i deleted the latest apps that had caused the problems... still problem was there... so i took wolfmore's advice: I went into settings, General, Reset, and did a Reset All Settings and that fixed it.
worked like a charm.

Follow the tip in link from post #55. Works fine without the need of any restore or app data loss.

Mine happened with switching pictures
I have the FakeCaller app and I had recently deleted the NotifyMe app
My FakeCaller suddenly got the NotifyMe icon

I had this problem and the eaiest way I have found is to go to SETTINGS>RESTRICTIONS>ENABLE then go back and DISABLE. Poof!! They all re-appear. Hope this helps?

My AppStore icon is missing ever since original 3.0 update (still with latest) .. I restored factory defaults and I got the icon back but as soon as I sync my last backup (with all my messages, contacts, etc.) the app store icon disappears again. So glad Apple doesn't have bugs [sarcasm]

Someone may have already had this, but here's the problem:
APPS DISAPPEAR FROM THE LAST PAGE
Try this, even if you have hardly any programs installed, you can recreate this problem.
First rearrange apps so that page 10 is full (16 applications). Even if you have only a single app on each of the other pages, if you drag a 17th app to page 10, the last app on page 10 will disappear. I even did this with Notes- which is a native (not able to be uninstalled) app - and now it is nowhere to be found. I can still access it by seaching for the word "notes" from Spotlight.
Others have recommended resyncing the app, but Notes is not one of the apps able to be sync'd so I'm SOL.
Still looking for a way to get it back without having to go a complete restore.
This is VERY LAME. Come on Apple, get it together!!!!

I was having the same problem on my iTouch, pages of blank icons and any new apps downloaded could not be seen. The apps where there but could only be found when searched. I removed the last few themes i downloaded ...especially the iNav themes and hey presto...everything back to normal! All missing apps reappeared and the blanks gone. My advice is to remove any recent downloaded themes to see if that works. Good luck!

I have 3.0jailbroken iPod touch 2nd gen and when I go in the AppStore some of the "install" tabs in the games r not highlighted and r unresponsive also the screen shots r missing any help?

hi there i have the 64 gb ipod touch and will be getting the 64 gb ipad ipad 2 should have 128 gb flash drive upgrade and yes i notice that iphone and ipod touch have quick time player and you tube feature and if you upgrade too sarfari 4 beta your ipod touch and iphone will run all html5 video too html5 will make flash go buy buy flash wont last with the new html5 video

So today my app store, iTunes store, and YouTube just up and vanished from my phone.. WTF? Tried a hard reset.. Guess I'm gonna restore when I get home.. All updates are up to date.. Hope my ipad works when I get it on Sat..

The back button on my iPhone email account Has vanished! This morning it just happened while reviewing emails out of the office. I couldn't return to the inbox, then Not thinking. I opened an attachment meaning that I now cannot view any emails. Help?

My Monopoly world app and others completely disappeared. But the strange thing is they show up on search. This is an iPhone 3GS with 4.1 software update. Also yesterday my apps scrambled themselves.

The icon for an app called Golfshot has disappeared. When I try to re-load it the icon briefly reappears with the words underneath, "File already exists".
How do I access the app?
I am using version 4.0 (8A293)
I have tried resetting without success

For about 4 weeks now my apps keep disappearing. They are in my iTunes but I can not restore them from back up. I have to fully re install them , natwest, nectar, my orange, radio app etc about 10 of them. Today they have re scrambled themselves into no particular order and also my texts have all been deleted. Please help!!

The app opens, the name is there, but there's no icon! Before, my contacts icon went, but came back when I scrolled to my second home screen and back again. Now, three other ones go missing in rotation every time I scroll to the second screen and back!

Any idea why my App DuggedUp would not have an icon at Appolicious aka BestBuy app pages? Why would that one be missing? Did i need to include it in my app? Any help would be great.

This makes me so ANGRY. This is a fake. If you notice he/she is using VNC! What is not shown is that they are actually connected to their computer through VNC, and are basically just typing into the computer which is connected to the iPhone NOT directly from keyboard to iPhone!